025: Autocorrect "Hi."

If I type

[Capitalized Letter] + i + [period/fullstop]

The entire word is capitalized. I noticed this when I tried to type “Hi.” it becomes “HI.” I tried with other combinations “Ai.” -> “AI.”, “Bi.” -> “BI.” etc. I disabled the “capitalize i” autocorrect, and it doesn’t convert these combinations, so I’m guessing its tied to that functionality.

The fix capitalize sentence enable/disabled affects the behavior, too. If enabled and if I type ‘hi.’ it appears to take effect first as well as negate the “capitalize i” check, and corrects it to “Hi.” But if [disabled and]* I type “Hi.” the “capitalize i” goes ahead and changes it to “HI”.

Typing “Hi.” Scenarios

Fix capitalization of sentence- checked
Capitalize i - checked
Result: HI. (capitalizes I)

Fix capitalization of sentence - unchecked
Capitalize i - checked
Result: HI. (capitalizes I)

Fix capitalization of sentence - unchecked
Capitalize i - unchecked
Result: Hi. (as typed)

Typing “hi.” Scenario
Fix capitalization of sentence - checked
Capitalize i - checked
Result: Hi. (capitalizes H only)

Fix capitalization of sentence - unchecked
Capitalize i - checked
Result: hI. (capitalizes both H and I)

Fix capitalization of sentence - checked
Capitalize i - unchecked
Result: Hi. (capitalizes H only)

Off-hand, looks like the order of the checks as well as the identification of what’s to be capitalized might need to be, uh, checked again. :stuck_out_tongue:

* Edited to add a crucial clarification, otherwise I made no sense. :wink:

This looked like such an interesting bug, and it appealed to my sense of humor. I tried a few of your “hi” examples just for giggles. I got the same result .

Out of curiosity, I did try adding a third letter. I admit I only tried it with a few different combinations (hid, cid, cif, aia, and maybe a couple of others, can’t think of them right now though). While my tests weren’t extensive, my results when typing only two letters of each combination was as Scribbles describes. As soon as I try the combinations with a third letter, autocorrect works fine with these two options checked.

I typed a space at the end of each combination when I tried it, instead of a period. When I noticed that Scribbles said a “full stop” was used in his (her? sorry Scribbles, I didn’t see anything to let me know which) test, I went back and tried with the characters in enclosed in the curly braces in place of a period or space: {, ? ’ " ; : !} and got the same result that Scribbles describes. When I tried it with these characters: {/ \ | + = - _ 0 @ 9} autocorrect functioned properly. I suspect (correct me if I am wrong, Scribbles) that this bug seems to affect only two letter combinations at the start of a sentence where the second letter is an ‘i’, and takes effect as soon as you type a space or use any punctuation characters.

I hope this helps Lee, MM. - Lunarclipper (by the way, Scribbles, cool find! I know, I am easily amused sometimes, but I got a laugh out of it)

:laughing: No worries, but just to set the record straight I am actually a “she”.

I stumbled on this one while drafting a much overdue blog entry, and used “Hi.” as my opener–only to get distracted by the bug and procrastinated a full ten minutes exploring it :wink:

This is pretty funny bug, and Lunarclipper, your further tests and comments has me musing more on what’s the cause–just for my own amusement.

I’m going to guess that it triggers after a full stop/period and space (and not the other symbols) probably because those are the parameters used to define the end of a word that could possibly be “I” (pronoun). (i) (or enclosed in any other symbol) could possibly be a Roman numeral or some symbolic meaning, so I don’t think the auto-correct should trigger in those cases. But you’re right, it does only seem to occur at the beginning of the sentence. I’m not sure why it wouldn’t occur in the middle: perhaps it has to do with the ‘capitalize sentence’ rule. rubs chin :wink:

I’m also going to guess the check is misinterpreting the word length–maybe a < instead of a = check? If not, I’m going to bet it’s some common word length and index values (where the count starts at 0 instead of 1) and comparisons problem that’s making it correct on two-letter words instead of just one-letter words. :laughing:

And finally, I’m going to guess there’s a if-else between the ‘capitalize sentence’ and ‘capitalize i’ rules and the former is first, because when that’s true, the latter is ignored.

Anyway, this is just me having a little bit more fun with this bug. No doubt Lee has more important things, so I don’t expect a confirmation or clarification on my guesses, but it was still amusing to try and guess the cause. :mrgreen:

Thank you both for your thorough testing on this! The auto-correct can get a tad, ah, over excited. :wink:

Odd, I have other problems but not that one. have auto-correct on and had no problem putting in “Hi”

Could it be the operating system?
I’m on XP

Did you try it at the beginning of a new paragraph? That seems to make a difference. After that, it won’t capitalize the “i” anymore for the paragraph, so you’d get “HI. Hi.”