029 compile niggles

029 is an excellent update which installed perfectly and has some really neat new bits - being able to edit your own keyboard shortcuts is peachy!

I was overjoyed to see the ‘page settings’ appear in the compile setup as I use A4. However, after rendering to pdf, rtf and doc I’ve found the following:

PDF - didn’t take the entered right hand margin - text aligned hard on right edge rather than 3cm in. Top, bottom and left were okay.

RTF & DOC - perfect, except the separator between pages (#) was aligned left, not centered.

Finally, is it possible to have page sizes in mm as well as cm?

[Win 7 Pro x64, currently updated.]

I’m entirely new to Scrivener as of this newest beta, so apologies if I’m just encountering the problems of a newb.

a. I’ll second the issue with the right margin on PDF compiles.
b. In trying to compile from Fiction->Novel (or Novel w/parts), the compile always wants to put CHAPTER ONE before the title page, and then labels my first folder CHAPTER TWO… in fact, the compile creates a CHAPTER heading for any folder (even if it’s a Part) and the title page. Is this a bug with the template itself, the compile function, or am I doing something wrong?

PDF right margin: Thanks, this should be on Lee’s list. It doesn’t seem to want to take no matter what–even the default settings don’t apply correctly to the right margin.

Separators left aligned–Also on the list; they should always be centered and spaced appropriately (they’re always single spaced now, which is incorrect).

“Chapter” prefixes–This both a bug with the compile function and, probably, a mistake in the template settings. Are you using 029? The templates in 029 seem to no longer have the prefixes included by default, so I’m wondering if you’re on 026. They’ll be fixed for the 1.0 release, so the proper document types have appropriate prefixes, but I think this might’ve been off in the earlier betas. At any rate, there’s a separate issue with the title page, which is that documents marked “compile as-is” should not have the title prefix applied to them, but this isn’t working correctly yet, thus making your title page “Chapter One” when it ought not to have that prefix at all. You can work around it by adjusting the prefixes for the different document types and levels (presumably you really only want them on the folders, for “Chapter” or “Part”, which means you don’t need a prefix for single documents, such as the title page, at all). To do this, in the Formatting pane of compile, select the row you want to edit, then click the “Modify” button and then the “Title Settings…” button. This will bring up a pane where you can edit the prefix that’s being added:

Note also that there is also a bug here where the prefix won’t be added for a document unless the “Title” column is checked in the formatting pane. This will change so that it’s possible for you to get just the “Chapter One”, “Chapter Two”, etc. without needing to also include the document name.

Spacing – my issue is particularly double and single – is still broken in 029. See this post for my look at the issues:


I am still trying to produce Shunn Short Story format from compile and I cannot. As I mention in the other post, this will only get worse when I get to novel length work. Instead of two dozen edits, I’ll have to do a hundred or two.

I’d like to get a commitment from L&L, if I may, that we users will get release candidates before the final release so that we can check things like compile functionality. (And my take on release candidates is that they are feature, function, and code frozen, and the ONLY changes made are a known published and agreed upon release candidate bug list and customer bugs that are placed on the release candidate bug list after discussion with the beta participants.)

And again I’ll reiterate, Shunn Short Story and novel formats require BOTH single and double spacing. The prose is double spaced, but the separators are three lines – blank line, separator, blank line.