029: Weird ALT and CTRL key behavior

Here’s an odd one. I don’t think anyone’s reported it yet.

I use Windows shortcuts to create the — (ALT+0151) and the – (ALT+0150) characters.

When I do this in Scrivener, I get numbers. For example, holding the ALT Key and pressing the numbers 1, 5, and 1 creates the number 7. I first thought this was related to the font I was using, but I tried several standard fonts and my results were the same.

And in case that wasn’t odd enough…

In the example above, after you create the number 7, hold the CTRL key and hit Z for undo, you’ll get the — character that you were trying to make in the first place.

Weird, huh? :confused:

Which beta are you using? 029 was released today.

I’ve seen this before. To use the Alt-0151 you need to have NumLock on.

With NumLock off Alt-0151 shows a 7 (Only in scrivener though not e.g. in MS Word)

Using Alt-[Numeric Keypad] with NumLock off gives weird results E.g. Alt-4 hides the menu (i.e. treats it as Alt-Left Arrow) then shows a , (comma)

When NumLock is on then all is well.

I assume the Ctrl-Z option worked because you had a line there, you deleted it, tried to add it back using Alt-0151 (with Numlock off) got a 7, pressed Ctrl-Z to undo and got your line back :smiley:

Sorry. I should have specified. I am using 029.

Good to know. Thanks!