035 compile question--may be a bug

After a few crashes and mistakes (which are probably my fault) I got the novel to compile the way I wanted except for one issue. At the end of SOME chapters (not all) the compile has added one and sometimes two underscores in an RTF and a PDF.

Below are two examples from the RTF. I can do a screengrab if that’s not clear.


Blah blah blah blah blah. _

    OR

Blah blah blah blah blah. _
_


When compiling to PDF, the font got much smaller, and I got an underscore and a small square instead of the second underscore. (See screengrab)

I believe I made the settings to be the same as my document, but perhaps someone can guide me to where I can change that.

Also, I noticed that it doesn’t give me page numbers, and I could not find the setting to put numbers in. Is this expected?

Marta
WIN XP SERVICE PACK 3
underscore in pdf.jpg

Going backwards:

You can add page numbers with the <$p> tag in the Page Settings area of the compile sheet.

PDF compile does have a bug at the moment where the output is too small, even though the settings are right; I’m afraid I don’t have a workaround other than just creating an RTF or similar and then producing a PDF from that using a word processor. We’ll get this fixed, of course.

As for the underscore, that isn’t something I’ve seen, so I’ll need to poke at this a bit. Are there any characters in your document in the editor where the underscore/square is appearing in the compiled document? The square looks as though the font is missing a special character. Is there anything you notice otherwise different with these chapters where the underscore appears vs. the others where it doesn’t–any additional carriage returns or spaces in the documents in the editor, or anything else appearing differently in the compiled document?

Also, what program are you using to view the RTF?

Jennifer
I had Scrivener show invisibles and–as you guessed-- an extra carriage return caused the underscores to show up at the end of each chapter. Problem solved.

Regarding adding page numbers, I placed the <$p> in the grayed out area which determines the header. It did put numbers in, but as you can see in the screengrab of the compile page settings, I had designated a RIGHT alignment. When I viewed the compile .RTF in WORD 2003 Professional Edition (my default .RTF viewer) I got a LEFT alignment. I tried it several times, even closing Scrivener in between, just in case it was holding on to the default setting. I also tried the CENTER alignment, but each compile came back with the number on the LEFT.

Marta
WIN XP SERVICE PACK 3

Marta,

I’m having the same problem w/ the header. It only aligns left, NO center or right.

Also – Are you having this problem? I’m having it and can’t seem to figure out what I’m doing wrong.

When I compile, I set the final font type to TNR because that’s what my publisher wants. But when I compile to Word doc or RTF, the 1st paragraph of each “new text” gets smart quotes (double and single) in Courier New, rather than in TNR.

I cannot find out why that is. I’ve done everything I could to fix it, but can’t.

Thanks.

Hi Nadia,
My quotes are in COURIER FINAL DRAFT (same as my text) which is what I wanted. I designated it to give me “smart quotes” instead of “straight quotes,” which it gave me.
However --as a test–I did a compile telling it to give me “straight quotes”, and it still gave me “smart quotes” in COURIER FINAL DRAFT (not COURIER NEW). So it kept my correct font, but not the smart VS straight command.

Hope that helps
Marta

Great, thanks for the extra testing. This still sounds buggy, since a carriage return has no business turning into an underscore, but it should be fixable now.

The header alignment is a known issue, yes–it seems to be specific to Word; if you open the document in OpenOffice, for instance, the alignment comes out properly. So Lee’s looking into this and we should get a fix. For now I’m afraid you’ll need to adjust this once you compile and open in Word-.

Some others have reported this, and I think you may’ve just hit on the missing key, so I’m going to go test this a little further. It sounds like a bug within the compiler, since certainly if you’ve set to override the font, then your quotes should be in that font too (unless the font doesn’t support the character, in which case some word processors like Word will substitute another similar font–but obviously that’s not the problem with TNR). In your compile settings under “Transformations” do you have “straighten smart quotes” deselected?

Yep. :slight_smile: Thanks for taking a look at this.