035 No more compile to .docx?

I’m not sure if this is a bug or a removal of a feature, but I can’t seem to compile to .docx anymore. Is this by design?

Also, I used to be able to see the document in my recent documents right after compile, before opening it. I really liked this as I don’t have to look for the file. I’m guessing this went away with the change to allow compiling to Word format without having Word. Is there any way to give an option to compile the old way?

At the moment, .docx compile is only available if you have Word 2007 or higher installed–although Scrivener is now able to import both .docx and .doc without an installation of Word, the export for .docx still needs to use a third-party tool that accesses Word’s libraries. However, the tool that checks for the Word installation isn’t particularly reliable, and there are occasions when it won’t detect a valid installation of Word and so won’t make .docx compile available. Is this the case for you? I’m noticing it sporadically on my computer with 2010, and some other users have noticed the same. Lee’s aware of it, so he’s trying to find a way around this.

As for the compiled documents showing up in recent docs, I’ll have to check on that–I’m not on the Windows machine at the moment, and I haven’t notice this. Recent Documents is usually populated just by items that have actually been opened, so it may have to do with which libraries are being used to access and create the document–whether Word is being called or not–but I’m not sure on this. I’ll check it out and let Lee know; I’m not sure if there will be anything to be done about it.

Yep, I have Word 2010. I’m running Windows 7 64-bit.

Now that I’m thinking about it, I also noticed .docx missing in the previous beta on my netbook the day before the new beta came out. That one’s running Word 2010 and Windows 7 32-bit. It was the first time I compiled from that machine and couldn’t remember all my settings, so I just assumed it was something I’d done wrong on my end. I also didn’t see the file in my recent documents, so maybe the two are related.

By “in my recent documents” I actually mean in the start menu. I have Word pinned to the start menu, and when I put my cursor over it the “Recent” menu appears. I used to see the compiled file at the top of the list. It was really convenient.

Thanks for working on this. I really appreciate it.

Also, is there some sort of reset I can do to get the tool to check for my Word installation again? It picked it up in the previous betas - this is the first time it doesn’t see it.

I am having the same problem. It is solved by reinstalling 035… I have had to do it twice now. I have word 2010 installed on Windows 7 64 bit.

I’ll admit I haven’t tested this yet to give specific instructions, but Lee’s informed me that the problem has to do with whether or not Word is running when Scrivener goes into action–if it is, Scrivener’s not detecting it. It didn’t work just to quit Word and restart Scrivener, but logging in and out of your account or rebooting the machine will probably do it; and you might be able to clear out the system’s memory of having just run the program as well without that, but I’m not sure what specifically it’d be hanging on to that would cause the glitch. Lee’s fixed this for the release, though, so thanks everyone for the reports.

I haven’t had Word running any of the times that I’ve started Scrivener or tried to compile. Also, I’ve rebooted a number of times and haven’t been able to compile as .docx after the reboots.

I guess I’ll just wait for the fix. Thanks! :slight_smile:

This issue is now resolved for me in the NaNoWriMo version. My laptop (Win 7 64-bit, Word 2010) gave the option to compile to .docx right away. With my netbook (Win 7 32-bit, Word 2010), when I first loaded Scrivener it didn’t give the option to compile to .docx. But I closed Scrivener, opened Word, then closed Word and reopened Scrivener. The option to export to .docx then appeared.