049 Compile problem - Nothing to include

Hello,
I just discovered a bizarre problem with compile. The steps to reproduce this problem are as follows:

  1. Create a new project using blank template and give it any name.
  2. Right click on the automatically created ‘untitled’ text item under draft and select move to trash.
  3. create a new folder under draft and give it any name
  4. select file -> compile
  5. under compile options not the absence of any objects to select for inclusion.
  6. add any number of files, folders under draft
  7. select file -> compile
  8. note that under compile options there is still not any objects listed to be included. It seems that anything done after this occurs will not get compile working again.

I verified that all objects are checked to be included on their properties and they are. I’ve been able to reproduce this 100% of the time though only by creating a folder, not a text file. I was even able to go back and repro it in 035 so it may have been around for a while, I just hadn’t created any new projects in a while so I never encountered the problem. I tried on a freshly installed build of 049

Danny

Unfortunately I cannot reproduce this on my copy of 049.

I was able to replicate it, but then realised what I think the problem was.
When you click to add a new folder you are putting it on an equal level to the “Draft” folder, not inside it. Compare the two examples below, and their impact on the compile screen.
1stImage.jpg
2ndImage.jpg
Just select the folder and then press + to move it on level to the left in the folder heirarchy.

You nailed it exactly. I did not catch that it was adding the folder on the same level and I was able to confirm this resolved my issue. To me, it seems like this should not be allowed as it puts things in ‘limbo’. I would think everything should be either under drafts or research. Not sure if this behavior is intentional or not.

The behavior is intentional, so that users can have items (other resources, older versions of their draft, whatever) at root level. Research is in a way a placeholder to set up an obvious area apart from the binder where you can import non-text files, but Scrivener doesn’t restrict you to just that folder. You’ll see in a lot of templates, for example, the template’s readme file is at the very top of the binder, above the Draft folder–a nice overview sort of location, since it stands out, but without needing to be in the Draft itself. Naturally, you’re not forced to do this either–if you want to keep everything in the Draft and Research folders, go for it. It’s just an option if you want it.

As for the particular scenario, if you do the steps in a different order, you’ll get the folder at the proper level to start. Click the “Untitled” document and create a new folder, then trash the document. The folder will get created on the same level as the document this way, and thus inside the Draft folder.

I understand. It might be helpful if documents outside the drafts folder have the include checkbox grayed out to signify they cannot be included in a compile. This is also a case where it would be handy to be able to print multiple scrivlings as a single document as right now, you can only print one individual document at a time that is in this state (which was what I originally was trying to do).

Thanks!
Danny

The ability to print a Scrivenings session is something that will be coming; it involves rewrites to the underlying code for how Scrivenings are pulled together inside the program, which is why it’s not possible now, but over the next couple months this is going to be one of the top priorities, so there will be a lot of improvements to working with a Scrivenings session when that happens.

That’s great to hear. For now, just enjoying the 1.0 release!

I’ve noticed some unexpected behavior in 1.0. If I right click on an object in the binder (such as a folder) and select new folder (or text) I would expect this object to become of child of the object I was clicking on. Instead, the object becomes a sibling and is created at the same level. This includes when clicking on the drafts object, making such new objects fall outside the ‘compile-able range’. The behavior does not seem to happen to some sub-objects if I left click to select the parent object first. Doing so seems to make no difference on drafts, however. I then have to manually move the newly created object where it belongs. This seems to accent the original problem I reported. I don’t believe I recall seeing this behavior in earlier betas. Is anyone else experiencing this? I uninstalled the beta fully before installing 1.0.