049 Statistics

I am trying to work on the NaNoWriMo and using the BETA Scrivener to do a more live test than just putting data here and there, and it is being quite useful for BETA but I think I have more words input here than in my writing. :O)

  1. Total count is not correct:
    So I needed to update my pathetic word count and I added chapter 1 - 726 plus chapter 2 - 171 = 897 but the project stats says 944 - 897 = -47. Ok… the title page is 26 and that is all I have here. I moved the character and places folders under research to make sure they were not counted, or so I hoped.
    1a) How do I include or exclude documents from the stats?
  2. The “Selection” count is not correct:
    I noticed that the selection count is 3 words, 34 characters, 1 paperback, 2 printed is displayed on a blank document I have labeled Chapter and not Scene. I went to my chap 2 and it shows a different value from that shown at the bottom of the document. Given it stated “Selection”, I highlighted a line of data but the results stayed the same showing approximately the Chapter that I was in.
    I will post the file data out in Lockbox (is that what it is called?) if you want to check what it is doing if you cannot recreate this problem. Let me know. See attached screen shots.stats bug.doc (637 KB)

The Draft (or Manuscript, in this case) count is based on your compile settings, so it’s going to include all the text that is set to compile–in this case, given that you’re using the Novel template, that probably means not just the document text but also the titles and title prefixes (such as “Chapter One”). In addition to your two chapter documents it will also be including the text of the title page. So this is probably right, but take a look at how compile is set up to see what’s going on.

For the selection counts in Statistics, this means your binder selection, not a text selection within the document. (If you want to get a word count just of a portion of text in a document, select it and then right-click: you’ll see the count at the bottom of the context menu.) This is also going to use the compile settings, so it’s also including the title and title prefix. Thus in the top image, you get 171 words for the document (which is what the footer count says in the editor) plus four words from the title “Chapter 2 Henson retires” plus another two from the title prefix that’s being added in compile (“Chapter [#]”), which totals to 177 as the stats box states. In the second image, you get zero words from the text but one from the title “Chapter” and then two more from the prefix.

Incidentally, you will want to either not bother with the “Chapter” and number in your binder titles or else turn off the prefixes when you go to compile, since the way things are you’re going to end up doubling some of this. As explained in the template’s about document, the novel template is set up with the prefix added so you don’t have to waste binder space adding this in yourself for each document–which also allows you to rearrange or split and combine chapter more easily without needing to renumber everything. You can turn it off however by opening File > Compile… and clicking the blue arrow button to see all the options, then selecting “Formatting” from the list on the left. Select the table row with the single document icon (matching that of your chapter documents in the binder) and then click “Modify” and then “Title Settings…” and delete the prefix that’s added there.

MM,
Thank you for the info. I was so not getting where everything was coming from. What I see is rather disconcerting though. All of the Research folders, Templates and even the Sample MS are marked as Include in Compile by default. I would have assumed otherwise.
I know that I did not add any of these docs to be in the compile, as I only found the location to do so after going through the tutorial just a few days ago. So, once I figured out the Outliner would allow me to make that choice, I displayed each folder there, as you suggested to see what was going on.
So what a quick compile has shown me is that just because I have stated to include it in compile, it actually just includes it in the statistics. For it to be IN the compile, I actually have to have it IN the Manuscript folder and marked as Include on the Compile screen. That is probably the cleanest way to address the compiling, but it is deceiving in terms of seeing all of those docs marked as include, but they aren’t really included.
Ok, here are the results that a few tests have produced…
If I mark the inverse, doc count for all not to be included, I still get the same 1400 words, that I got for including just those marked for inclusion and all docs (since I unmarked everything I didn’t want included). Then I get 0 words and 10 characters for the selection stats. So something still is not correct in the Selection department.
I checked the title page count and it only includes the actual words on the page and nothing else, so that looks ok.
I did a test and got rid of the “Chapter” notations as you suggested and put “Two words” on the page and got back 4 words and 47 characters. The 4 words are “Chapter 4” and “Two words”, but the charcter count includes “Surname / Novel Title / 9”. So what should it be? The header count included in the word count or not? Obviously the character count is wrong since the words are not included in the word count.
I added “Chapter” back to one of the text doc titles and it correctly increased the doc and word count correctly, so that is ok.
The Stats for the Chapter 4 above shows 2 words and 9 characters on the Outliner total instead of the 4 and 47 from the stats page. One is compile stats and the other is not? One would think it should be the same regardless. What if I have not compiled yet, will it be the non-compiled totals?
Based on that difference, then the total stats on the Outliner differ from that in the Stats screen. I don’t know whether that is an Outliner or Stats error, so I will let you all sort that out, but I will note it in the title of this post.
I also saw that that Sample MS although it notes is 700 words in the top right corner (I did not go back to verify) on the Outliner Both the Word and Character Count lists it as -1 (minus or negative 1 words). Hmmm. Interesting. I think it is probably due to the fact that it is a pdf. I think that is what the little notation on the text icon reads. I imported the doc I created via the compile and got the same -1 stats.
Well, I think that is enough of my tinkering with Stats tonight. I hope this info is useful in correcting the differences and inconsistencies that are present. I will be glad to retest once changes have been made.
Thanks…