1.0.2 artificial intelligence? a serious problem...

in some documents the ruler appears even if not checked in the menu.

See:


and well, doesn’t this ruler look a bit odd???

And now the best.

  1. uncheck the ruler in the menu
  2. check the ruler in the menu
  3. click into another document
  4. come back to the document with the odd ruler

surprise: a perfect ruler! Voilà:

Any idea, what could cause something like that?

Sorry for spaming you with all these issues in different topics. I have an idea that they are somewhat connected and I just cannot see how…

I get this intermittently, but can’t reproduce it to order. I see the ruler, but it is not selected in the menu. I have to do ctrl-shift R twice for the ruler to disappear.

It’s an issue with Scrivenings and I think Lee’s just fixed it for the next update, but I haven’t confirmed this yet. :slight_smile:

Is this issue with scrivenings also responsible for the following

  1. Select a folder in the binder

  2. Select a pile of documents inside the folder

  3. Go back to folder

  1. Select another folder

  2. Select a pile of documents inside this other folder

  3. TURN OFF SCRIVENINGS

You can see that in scrivenings mode everything is messed up. And it’s not even the same mess with similar structured folders. We can put it this way: scrivener messes up its mess lol.

And one other question related to scrivenings mode:
Does scrivenings only apply to text documents? What if there are several images in a folder I would like to look view the same time?

Thanks for working yourself through this bunch of screenshots :smiley: !

Oh Gosh! I finally understand what must have happened!

Please look at this screenshot again:

I selected the folder “Orson Gwilt” and scrivenings viewed me the text I originally wrote into the text document “Charakterblatt: Orson Gwilt”. It seems as if the text has been moved from “Charakterblatt: Orson Gwilt” to “Orson Gwilt”. This explains why in “Charakterblatt: Orson Gwilt” gives me the message “not enough text items” when selected.

I don’t remember moving the text myself! Wouldn’t do that, makes no sense. And I didn’t realise it because of two reasons:

  1. I did not pay attention to the first screenshot - there ist no free space above the text which would indicate an empty folder containing the text as a seperate text document in the folder (infact there is none)
  2. the folder icon in the binder does not show that there is text content inside it (inside the folder as a document itself)!

Either this is the explanation or I’ve got something horribly wrong about how scrivener works… :wink:

if I’m not mistaken scrivener did this to ALL my character sheets (which are quite a lot) :open_mouth: :open_mouth: :open_mouth: !

Hmmmm… As long as the text is there, it’s all right. But I’m still investigating and the more I do the more new questions arouse…

If you need more Information just tell me.

The text hasn’t been moved from one document to another, but it looks like your Scrivenings session is not set to show the text of the container item selected, thus when you select the document “Charakterblatt: Orson Gwilt”, the Scrivenings session is only attempting to display that document’s subdocuments, which are all images, thus you get the “Not Enough Text Items” notice. (On which point, yes, Scrivenings is only for text. Images inserted into a text document will appear, but images saved directly in the binder and other non-text file types like PDFs or videos won’t display.) When you load the “Orson Gwilt” folder in a Scrivenings session, the text of “Charakterblatt: Orson Gwilt” displays since that is a subdocument of “Orson Gwilt”.

To change the settings so the text of the selected container is displayed as part of the Scrivenings session, go to Tools > Options… and click the Navigation tab, then check the second option: “Include enclosing group in combined scrivenings”.

The best way to view multiple images in a folder at once is to switch to corkboard mode, which will give you a preview of the images on the index cards. If you split the editor and click the double-arrow icon in the footer of the corkboard editor, you’ll be able to click an index card and load it automatically in the second editor, so you can see the full image.

Thank you so much :smiley: !!! Everything is back to normal again, that’s a relieve. I WILL remember not to meddle too much with the settings however :blush:

And another big thanks for the corkboard solution. I didn’t think of that because I am more the outliner type :wink: .