1.0.3 beta Minor to Major bugs

  1. Scrivener doesn’t load after install if the readme box is unchecked. I have no idea if it runs if you choose to run the readme file. Someone else will have to confirm this.

  2. Fullscreen text colour does not change when altered in preferences. It uses whatever text colour is selected in the editor. However, the Fullscreen text colour does alter the colour of the blinking cursor in fullscreen.

  3. I can confirm that the closing on exit bug does appear to be fixed.

ETA: Re #2. The new fullscreen text colour is being applied in some projects but not others.

ETA 2: It’s applying only to certain documents within one project. It’s applying to only specific documents in test project. Will apply to existing doc but not a new one.

Uploaded the project with the preferences for you to look at.

ETA 3: Same thing happens if I revert to program defaults in options and then change fullscreen page and text colour. Same files have fullscreen attributes applied and the same do not :frowning:
test.zip (17.6 KB)

Regarding full screen coloring, have you confirmed that the text itself is not actually colored? If it is, that color will currently override the full screen color; this has been the same all through the betas and 1.0. Select the text, right-click, and choose “Remove Color” from the color option (or do so through the format bar or format menu).

ETA 4: Just discovered the same thing happens when I apply the same colours to the editor. This is not a full screen problem but a having text that isn’t black/default problem.

Can anybody help? It’s not a deal breaker but it is slightly frustrating.

That worked… but I’m not sure how the text became coloured in the first place as I haven’t changed it for my fiction projects. I’d better go through all my projects then. Do I have to go through each individual file? Adding text colour seems to be switched on for my projects as this affects all that I’ve checked.

A lot of programs color text, so if you’ve copied text into your project or imported documents (and then copied any of that text into another document), that’s probably how this has happened. Ideally full screen mode will change in the future so that the text coloring there completely overrides everything, the way it does in the Mac version, but this is a little more complicated in Windows because the text systems are different. For now I’m afraid you’ll have to go through each document and select all to remove the text color.

I forgot to ask about this one:

Do you mean that after you installed and the installer closed, when you double-clicked the .exe or the shortcut Scrivener didn’t launch? I’m unable to reproduce this, so if you could detail exactly how you were trying to launch Scrivener, that might help. If you just mean that Scrivener doesn’t automatically launch at the end of install, this is normal, and is the same as for 1.0. After trying to sort out several issues that were caused by having Scrivener automatically launch from the installer, we’ve set it like this for now, which isn’t uncommon among programs, but you may not have noticed since earlier betas did have this option.

I was waiting for it to run automatically. Thanks MM for clarifying this.