1.5.0.9 Beta Released

Please read 1.5.0.5 and 1.5.0.6 Windows beta posts for background info here -> [url]https://forum.literatureandlatte.com/t/beta-1-5-0-6-released/20377/1]

And latest bug fixes in this Windows post here ->
[url]https://forum.literatureandlatte.com/t/beta-1-5-0-9-released/20921/1]

1.5.0.9 Scrivener Linux tar Package here - > http://www.literatureandlatte.com/scrivenerforwindows/Beta/Scrivener-1.5.0.9.tar

1.5.0.9 Scrivener Linux deb Package here - > http://www.literatureandlatte.com/scrivenerforwindows/Beta/scrivener-1.5.0.9-beta.deb

NEW FEATURES FOR TESTING IN SCRIVENER 1.5:

  1. OPML Import
  2. OPML export
  3. Mind map import (Freemind .mm format)
  4. Mind map export (Freemind .mm format)
  5. CSV export
  6. Import and Split functionality
  7. Import Scrivener Project functionality
  8. Image background (texture) in full screen
  9. Comprehensive Print preview functionality
  10. Print index cards
  11. Print outliner
  12. Inspector comments and footnotes
  13. Revised annotation, footnote and comments options
  14. Scrivener now speaks:-English, Chinese, German, Italian and Sci-Fi. French, Spanish, Russian, Polish underway
  15. Second phase of performance enhancements - Scrivener is faster again
  16. Implemented Cancel within Compile dialog i.e. changes are no longer saved when Cancel is clicked
  17. Project and Preset Replacements added to Compile dialog
  18. Deleting Scrivener project files within the directory of an open Scrivener project is now prevented
  19. Options->General - added checkbox to show full project path in title bar
  20. Added “Take Snapshot” menu item in header bar i.e. right click document icon to see sub menu and added ability to sort snapshots
  21. Improved debug and minidump reporting

Enjoy,

Lee

Answered my own question. Nevermind!

I’m getting a segfault right off the bat when I try to open a project. If I try File > Open, or anything in the recent projects menu, it’ll crash. If I launch a project via command line, it’ll open. These are all projects I’d worked on with the 1.0.5.9 version of windows Scrivener, for what it’s worth.

This is really odd, though. Once I opened a project via command line (/opt/Scrivener/bin/scrivener.sh ~/myscrivproject.scriv/project.scrivx), I can use the File > Open and recent project menu.

Only useful error I get is this, when I open a project: “QTextCursor::setPosition: Position ‘6040’ out of range”

So it crashed when I first installed/ran Scrivener, but once I opened a project (via command line), it seems to be OK. (Aside from the ongoing gstreamer issue some are having with 64 bit.)

Mhh, here, it still doesn’t talk German.

Cannot get it to run on 64-bit Bodhi Linux 2.2.0 running E17 stable. Whenever I dpkg -i the .deb it gives me a bunch of errors that cite “THEME” - at first, I thought it was just reading my mind about my latest WIP troubles :laughing: but I can’t even locate a scrivener.desktop file in all the usual places.

I know Enlightenment isn’t exactly the popular desktop, but I have gotten it to work on an older machine running the 32-bit Bodhi 2.1.0, and it still worked after the distro upgrade to E17 stable.

Anyone want to take a crack at it?

Thanks!

@beedaddy: Thanks for mentioning this, beedaddy. We hadn’t noticed that the translations were not working properly under Linux. We fixed them and all Windows Translations will be available under Linux too with the next update.

@garpu: Do you still experience the crash, garpu? Is it possible to reproduce the crash with a clean Tutorial Project? We found and fixed a crash that might be related to your problem, but I am not completely sure without a step by step guide causing the crash.

Yep. Just got it again trying to make a new project.

File > New project
Chose blank project
Chose a file name and directory

But it’s the same problem I had earlier: once it crashed 2-3 times, I could suddenly create new projects. However, after I was able to create a new project, I opened another Scrivener project, it crashed once (open via recent menu), and I crash every time I try to create a new project.

The only commonality I can find is that if I’m able to open projects, I can’t create new projects. If I’m able to create new projects, I can’t open existing projects. (Although I can always open existing projects via command line.)

Rather, the project file is created, but it’s incomplete. I’ve attached one.

Edit: The crash seems to be random. I can’t reproduce either crash any time I open a project or create a new one.
crash3.scriv.tar.gz (186 Bytes)

Okay, I take that back. I can reproduce it.

Open existing project.
Open existing project #2. (with project 1 still open)
Close project 2
Open project 3 (with project 1 still open)
(Crash)

Does it with both Linux native and Windows versions (on WINE) Both crash when creating new projects now. (Every time.)

I’ve attached the backtrace for the Windows version. I didn’t get anything on the command line when the Linux Scrivener crashed.

Here’s how I reproduce the file open bug:

File > New Project
type the filename, keep the directory the default “~/Documents”
Click Create

Core: dropbox.com/s/ax53a54cgbpo1u9/core
Strace: dropbox.com/s/lruam5bapk44f … _crash.txt

Do you need a strace/core from Scrivener crashing while opening an existing project, too?
backtrace.txt (6.74 KB)

Thanks for the detailed report, garpu. We managed to reproduce and fix the bug. It is a critical bug, so we are going to release an update as soon as possible.

Woot! Glad to hear! :slight_smile:

Also getting this bug when opening a second project via Win Explorer. Second project does open if opened within Scrivener.

Maybe my install worked…and maybe it didn’t. I look in the /usr/bin and /usr/share/scrivener/bin directories and the stuff seems to be there, it’s got file sizes. But whenever I try to run the app, I get the following message:

/usr/share/scrivener/bin/scrivener.sh: 36: exec: /usr/share/scrivener/bin/Scrivener: not found

I can look right at the Scrivener file itself, see that it’s an executable, has read/execute permissions for group and others, and read/write/execute permissions for root, and see that it’s 13.9Mb. Why would my system not be able to find it? Has anyone else had this problem?

I’m running Bodhi Linux 2.2.0 with Enlightenment 17 stable. Thanks for any help.

That’s really odd. Could it have been corrupted when you downloaded it? What happens if you re-download it and reinstall?

Otherwise, can you start Scrivener without the script? (That is ./Scrivener in the bin directory?) If so, that could be a path variable not set.

(Enlightenment’s way cool. I used it for years and years. Have they officially released E17 yet?)

I had that error… regretfully, I’m not sure I remember how I fixed it.

I believe (and that’s a dim memory :slight_smile:) that it had to do with not having the 32bit libraries installed… are you on 64bit?

Bruce

Yes! Back in December, they finally released E17 stable. Bodhi linux uses it as the default desktop. Fast, light, and pretty, too!

Same deal. It returns the message either “not found” or “no such file or directory.”

I’m on 64-bit. I will try loading the 32-bit libraries and see if that nets me something different.

***EDITED TO ADD: using the command line and

./scrivener.sh

I can get it to run! Won’t as of yet launch from Run Everything or the menu, but I’m making progress! ***

Thank you both for your help!

athena

Another beta, and another copy of the same comment: It sure would be nice if:

  1. Scrivener would work without gstreamer (provided, of course, that I don’t wan’t to open any audio or video files). This is my strongly preferred option.
  2. The Scrivener beta had a 64-bit version. This would be next best.
  3. The beta included it’s own pre-built 32 bit gstreamer.

It looks like a good release so far, but as usual it requires an absurdly deep dependency graph of 32 bit libraries, due to the (unfortunately persistent) gstreamer requirement.

For any new 64 bit Linux users (like the previous poster): You’re on the right track, and you can get Scrivener working. You just have to build (or install, if your distribution provides them) 32 bit versions of libgstapp (a gstreamer library) and all its dependencies.