update problem


When I open Scrivener I am prompted to update to version . It downloads fine, and I run the installation wizard as admin. Then I get the following error:

Anybody know what’s going on?

EDIT: I’m running Windows 7 64-bit

It means Scrivener is unable to find the correct location to install the update (because the file path isn’t being returned correctly from the registry for whatever reason); you can just download the full installer from the link at the top of our website (for convenience, here) and then run that manually so you can specify the location. You can install over your existing version if you wish, just make sure Scrivener is closed first. If you install over the existing installation, you may need to reset the keyboard shortcuts once you launch Scrivener by going to the Keyboard tab in Tools > Options and choosing “Scrivener” from the Import button drop-down menu. (If you’ve already installed 1.5.5 this shouldn’t be necessary; some shortcuts changed from 1.5.3 to 1.5.5.)

Thanks Jennifer

I have the exact same error message, however with the following additional issues:

  • I tried to install it on a brand new Windows 8 platform (so no previous installations);
  • I tried running the installation as an admin as as a normal user;
  • I tried compatibility modes.

Nothing worked. What can I do to get Scrivener installed? I need it on my new machine because I am working on a paper, and the deadline is looming :frowning:

Marifox - Could you try downloading and installing the 1.5.3 version first, from here, then (with that installed) running the other installer (downloaded from the main site, here)? It looks like there may have been a mix-up with the installers such that the main installer is an update rather than the full installer, which means it won’t know how to install on a machine that doesn’t already have an installation of Scrivener. By installing 1.5.3 first, you’ll be able to get it working while we’re sorting it out on the server. In fact, you probably won’t need to run it at all separately; if you install 1.5.3 and then run that, you should get prompted to update from within Scrivener and can just run that and relaunch Scrivener to get up to date. Sorry for the hassle!

Brilliant, thank you so much! Works like a charm now :wink:

Same problem here. Hope the same fix will work. Thanks for the advice!