1.5.7 - No way to get Scrivener to work

Hi,

Please help me…
I do not know what is wrong. I can only tell you what I did.

  1. This afternoon, I was working on a small project (7 pages).
  2. I had to leave, so I turned off my computer.
  3. When I came back, I decided to install a new external hard disk before starting. I had decided to move all my projects from my computer to that hard disk, and then work directly on that disk.
  4. To see if that would work, I began making a zip of that project without going through the Scrivener procedure, simply with 7zip.
  5. I accidentally created a 7zip file, which I sent to recycle bin, then I made a .zip of it
  6. I moved the complete directory (with the project inside) to the HD.
  7. I launched the project, but Scrivener would not open it : The program simply closes and nothing happens, not even a message saying that Scrivener stops working.
  8. After having tried to open that project (by clicking on it in the directory and by “open existing project”), I tried to open another project… NONE of my projects would open…
  9. So I tried creating a NEW project. Scrivener crashes.
  10. I launched an installation of Scrivener and tried it all over. Still without any success in all of the steps used.
  11. I uninstalled Scrivener and installed it again. Nothing changed : I cannot open any of my projects, and when I try to create a new project, Scrivener crashes.

All my files are still there. Nothing is lost, but I cannot open anything.
I simply cannot use Scrivener anymore.
Please, help… that program is addictive :laughing:

Hi Lilith,

I remember you as a long term person here, and I am sure with the talented people in Support and around, you’ll soon be running again.

I had a lot of wide-ranging thoughts myself (‘what can have happened’), but then I had a kind of simple idea.

What if Scrivener is having problems because it remembers where you were working, but can’t find any of that again? You might have uncovered a bug here.

To find out, I would put a copy of the project you were last working on exactly where it was before – then try running Scrivener.

If it loads normally, then you know Scrivener itself is Ok. You can add a New Text and write a little something in it, to identify that this is the extra old copy of the project.

What I would do then is open your new copy of the project, the one over on your external drive. Close Scrivener. Run Scrivener again, and see that it is finding the new copy of your project, compared to the old you just modified.

If all this works, then you can use Scrivener again, and can report what happened so that the team can protect against it. What you might do for now is check the ‘Show start panel when there are no projects open’ in Options:General, which may help prevent Scrivener from getting confused if it can’t find the last project opened.

I know you’ll post whether or not this works.

Best,
Clive

Hi Lilith, When you say you installed an external hard disk, what precisely was involved in that? Did you have to install new drivers or other software? What kind/brand of drive is it? It sounds like something new on the system is conflicting with Scrivener and causing the crashing, so this part of your description jumps out at me more than having moved the projects. Which version of Windows are you running?

Hi,

Well, yes Jennifer, the hard disk itself installed drivers.
It is a TOSHIBA “STOR.E ALU 2” of 2 thera, which I puprchased several months ago and never used, because I was just too lazy to start that backup.
But… these days, the power block of my pc is coming up with some nasty issues and before that leads to a crash with losses, I wanted to backup all my work.
I’m running Win7 Home, fully updated (and the most recent update was… yesterday morning, the day where all this happened).

About Scrivener remembering where it last worked, as suggested by Clive, I have included that possibility in my investigations, so that the directory containing the project was present on both the hard disk and the pc, and none of these projects would open.
I also unzipped what I had zipped, but nuts…

As I said, I even tried to create a brandnew project, for a test, but even that would not work : It causes Scrivener to crash.
I alsways use the start panel of Scrivener (show start panel when no project open).
I also noticed that in the “recent files”, the project concerned was no longer visible (probably because, at one point, it was no longer present on the pc).

I really believe that all this has something to do with the drivers installed by the hard disk, simply because I moved only one single project around, and NO other project does open.

I know I can continue it all under Word. Instead, I just feel like a kid that lost it’s favourite toy. :cry:

Edit 1 : I also noticed that there is another program that no longer works (even when the hard disk is turned off). It is called “Tree Size Free” and it tells you how much space is used by a directory.
I guess that makes one more reason to believe that the hard disk must be the very cause of my troubles.

Edit 2 : I forgot to mention that Srivener’s start panel still opens. That is how I am able to try to create a new project.
I just did this again. The result I get before the crash is that a “*.scriv” directory is created, inside of which, a “files” directory is created (empty). And that’s it.

Yes, definitely sounds like the root of the problem is a compatibility issue either with the new installations from your external drive or with the Windows update, which you say ran about the same time. Moving the projects and so on wouldn’t affect this and wouldn’t prevent you creating new projects.

I’d try verifying or disabling your new drivers and taking a look at any other software installed with it–it looks like the Toshiba drive you mention comes pre-loaded with Nero, and there many have been other software you could install on your machine to facilitate transferring data to and from the external drive. The Nero backup software I’d take a look at also just because if it’s monitoring your other drive and running backups while you’re working, you may want to have it exclude your projects and handle those manually to avoid getting unstable backups of your project that don’t have all the pieces in sync. I’m not familiar enough with BackItUp to know how this will work, but generally speaking it’s usually best if you can get your project backups when the project is closed rather than while being edited, to ensure that all the pieces are fully synchronised. So long as you’re making sure that you do get an “end of the day” sort of backup of all your work, it shouldn’t much matter if you get partials during the day.

To further test the crash issue, you could try booting in diagnostic mode.

  1. Go to your Windows Start menu and type in “msconfig” and hit Enter. (You’ll need to run this as an administrator, so depending on your UAC settings, you may need to use Ctrl+Shift+Enter.)

  2. In the General tab, choose Diagnostic startup

  3. Click OK

You’ll be prompted to restart Windows. When you next start up, Windows will only load the basic services and devices. Try launching Scrivener, then creating a new project and loading an existing one. Does this all work correctly?

(Once you’ve tested, you can return to the msconfig panel and switch back to Normal startup to start Winodws as usual.)

Hi,

So here we go :smiley: :laughing: :mrgreen:

As suggested, I wished to uninstall the Toshiba drivers… but, without knowing which could be these drivers, I could do nothing.
So I called the Toshiba hotline and talked to a very nice guy who did not speak French, but only English and German…
I’m used to computer terms in French and English, my computer is installed in French, but my native language is German… :wink:
So we talked a long time, trying to get the right words out of it…

He said it can’t be the drivers, as they are exactly the same as for any other hard disk or USB stick.
So he suggested that the Windows update might be the cause.

At first, he told me how to uninstall the harddisk (I was so panicked that I had not thought of using the Windows function for this !)
That was NOT the solution indeed.

Then he suggested to go back to the installation before the Windows update. (Again, I cannot find the right terms… System restoration ?)

While waiting for this to be done, I talked so much about Scrivener, that he went looking for it, quite interested in the program :slight_smile: :wink:

And now… I’m glad to announce that Scrivener is working again !!!

Windows update was the cause.

Wow ! That was a stressing week, ending on a stressing moment during that restoration… but with a HAPPY END !!!

Hi again,

Something is definitely wrong with that Windows update (win 7 Home premium).

For about one week, everything went fine, but now here it is again.

Another update happened in between, and it did not change anything : Scrivener worked fine.

Then there came one tiny update for Windows, which messed it all up again : Scrivener does no longer work, and Microsoft Office 2010 does not work either (I remember that, the last time, I noticed already that Excel stopped working too).

Now, I do not expect the L&L team to find a solution for this. I’ll simply do the same thing as last time.
Nevertheless, it would be nice if some other user experiencing the same problems could tell me a little more about this…
Thanks a lot.

Hi Lilith,

it’s difficult to help without sitting in front of the computer, but a few notes to maybe help.

  1. Turn off any automatic update, allow searching for new updates but prevent windows from fetching and installing them.

  2. Wait one week or two before installing them.

  3. Before you update, or before you install anything, set a new restoration point.

  4. Depending on how old your windows installation is, it could be better to simply restart from scratch. I do this once a year to keep my windows clean and fast.

  5. Consider doing a full backup of your drive from time to time.

  6. It’s windows, good luck :wink:

Thank you, Philipp.
Last time I had this issue, I did a system restoration, and it worked.
This time, I did the same, and it brought no help at all.

What I cannot understand is that none of my writing software is working any longer.
Scrivener, Word, WordPad and even Jarte!
But also Excel and Powerpoint.
That looks so silly : Microsoft messing up their own software by their own updates…

You might want to take a look at this post on ghacks.net:

http://www.ghacks.net/2013/04/12/microsoft-recommends-to-uninstall-windows-7-update-2823324/

It applies to

Obviously, I don’t know if it specifically applies in your situation or not, but, if you have that update installed on your Win7 machine, it should be removed. It can be removed by following the instructions in the ghacks.net post I linked to, above.

There’s a typo in that ghacks post. It’s Security Update for Microsoft Windows (KB2823324) that should be removed.

Hi,

Well, Twolane, that sounded great.
I was so excited about that solution…
But the first time I encountered the issue was on the 5th of June, right after an update I had the day before, thus on 4th June.
In the morning of the 5th, everything was still working. After having quit for a while, nothing would work.

Now I checked that thing with security update 2823324…
This is an update I had on April 11th, and it caused no further problems until the beginning of this month.

Could it be the cause ?
I don’t know.
Would it be useful to uninstall it ?
I don’t know.
Could it be the interaction of that update from April, with another one I received this month ?
I think that might be possible, but I still don’t know. And I’m no real daredevil, even if I sometimes look like one…

And I don’t know Win7 enough from the “inside point of view” to make up my idea about “what if”…
I only know that very soon, it is my brain that will need an update… :laughing:

Yes indeed Lilith, this is really silly, the reason why I always have two systems running. If one fails, I can always check on the other.

But that doesn’t help you right now.

How many restoration points do you have? Maybe you could try reverting to an older one?

You could try to repair your system with a windows cd. (that didn’t help me the last time ms messed up with an update :wink: ) But I’m not sure it is an update problem in your present case…

There’s always the possibility to have become lucky with a virus.

If I were you I would make a full backup now and reinstall windows properly. I know I know, it’s an ugly procedure, but it helps miracle for all the performance and quirks. It’s windows after all :wink:

Best of luck.

Hi,

Well, if someone can help with some good ideas, I’ll be glad.
Until now, there is nothing I can do.

Last time, the system restoration did work, until the next update.
This time, system restoration of the update concerned (the one that came juste before the problem occurred again) does not allow the computer to restart.
What I get then is a message saying that a solution will be found, and the solution is apparently to bring the update in again, over and over, so that I do not dare to remove it with the uninstall program function, as I do not know if the computer will start after that.
Nor do I dare to chose an older system restoration.

Once I will get bored with this, I shall make a new install of Windows and see if that works…

Hi Lilith,

If the problem is windows drivers, then a fresh install will probably result in the same situation once windows downloads its updates again.

I would suggest switching windows updates to “notify but do not download”. At that point, you will get a notification when the updates are available. Select just one, making a note of which one it is. Download and install just that update. Test scrivener. If it works, proceed to download the next update. When you get to a point of failure, roll that one back. Make a note of its ID so you won’t inadvertently click it again later.

Also, it would be helpful to know if you are running windows 7 or 8, and what the international settings you have. If you have a French or German version of windows, it may be reacting with one of the windows updates, when the english version does not.

If you can identify one or more updates that break things, you can at least let Lee know what they are. Also, report it to Microsoft. They are the ones who should be fixing it.

good luck
David