Word by word selection with mouse makes text jump

I know similar issues have been addressed before, but this particular case seems to linger.

Steps to reproduce:

  1. Select typewriter scroll mode.
  2. Go to a document that is longer than one screen page.
  3. Double-click and drag somewhere in a document, start at a position that is a bit up or down from the middle (double-click is used to select word by word, rather than letter by letter).

The text jumps so that the starting point of your dragging is positioned in the middle of the screen.

Expected result:
The text should not jump at all when selecting, not until you start typing.

Thanks, we do have this down to address. It occurs when working in Scrivenings mode in with Typewriter Scrolling enabled; until it is fixed, you should be able to get around it either by toggling off TW mode or by working in just a single document.