Upgrade broke Scrivener

I was on Scrivener (with Windows 7 SP1).

I had not used Scrivener since November 2019. On starting Scrivener yesterday I had a message to perform a “Critical Upgrade” to which I accepted.

On starting the updated Scrivener I was presented with a message (afraid I didn’t write it down - about can’t find licence server, I think) and Scrivener just froze with a white screen and circling cursor and “Not responding” in the window top bar.

I uninstalled and reinstalled my, with however exactly the same result. It was working in Nov 2019.

With some searching here I gather there has been a change in the way the licence server works and a possible need to update .NET framework. I was on .NET 4.6.1 so upgraded to the latest, 4.8. Unfortunately the same result, white window and Not responding.

Can anyone assist please? Thanks.

I found that setting the Compatibility Mode to WIndows 7 did the trick, on the version as per : http://scrivener.tenderapp.com/help/kb/windows-troubleshooting/fixing-not-responding-with-compatibility-settings

I don’t know if .NET 4.8 contributed to the solution.