Hi all,

Beta 0.2.0 is now available for full download or via the ‘Check for Updates’ help menu within Scrivener.

There will be no Linux release this week, we will look to provide both releases next code drop (beta 0.2.1) next week. They will be identical code bases then.

There’s lot’s of fixes in this release. We still have a big week next week so I imagine another release with a large number of minor fixes next week as well.

We are still on track for end of month/early April release.

Anyway, time to lay down the tools and take a break for a day.

Bugs we fixed are as follows (from release notes):

  1. Auto-Synopsis Crash - I clicked on Auto Populate Synopsis and it caused a program crash. Tried this several times with the photo and each time it crashed. But when I brought up a non-photo research window and clicked on Auto Poplulate, it did not crash.

  2. Snapshots - When I click on roll back the text from the version I am trying to roll back too is inserted at the cursor in the current version. It does not replace the text of the current version as I would expect it to.

  3. Status stamp - But as far as I can tell, you can’t change it by going to the Appearance tab under Options. No matter what it says, the status and the cards both revert to default settings. It seems maybe something’s not working right. (What was happening was the two settings tabs were in conflict, so it was ignoreing the appearance tab and always doing what the corkboard tab indicated. Removing the ability to change font in the corkboard tab fixes this).

  4. Novel Format Title Page - The Title Page which used to have the table format wherein the left half would have your name, address, agent name; and the right half would have the word count and copyright date and then below would have the title of the novel now only has one long table with one row with only the word count and copyright date and then below the title of the novel.

  5. Scriptwriting - a) I did a hard return after entering a line of Action, the cursor went to it’s usual place at the beginning of the next line at the left margin. I usually navigate through the format choices by clicking the bar at the bottom of the page. Decided to use the tab feature to tab to Character. (I’ve done this many times and no problems there, using the Character funtion).
    Then realized I wanted to continue a string of dialogue I had broken up with a General Text entry line, so the tab prompt offered me to [enter] to type dialogue.
    b) I hit [enter], and a dialogue box opened on the page with the format options. I selected Dialog, nothing happened. I clicked of the box, it wouldn’t go away. I tried selecting other options in the box, no response.
    c) When I hit [enter] again, the box did go away, but no format changes.

  6. Tables loose cells - If I create a table and then exit the program, it loses all columns and info entered into the table. I lost a lot of info in the one table I’d had created. It’s not a big deal, because it was just for fun, but this was not a problem before.

  7. Just seeking clarification. Are separate options for fullscreen colors in the pipeline like the Mac version? (Full screen is now complete customizable. We’ve also incorporated an automatic fading scrollbar - simply mouse over scrollbar area to make it appear again).

  8. I accidentally created a short story project when I wanted a novel project. When I tried to create a new project with the same name, it did nothing–no error message, but no actions either. (Note, if the previous project was closed, the user should get an error message. I couldn’t only reproduce this by leaving the first project open - fixed based on this.)

  9. Delete Templates - One thing I did wonder: is there a way to delete templates using the interface like on the Mac? (Yes, now there is.)

  10. Corkboard - a. A corkboard with more than one card on it will help (I used two initially)
    b. Set label style to Pin instead of corner mark
    c. Leave all cards unassigned (no label)
    Now try moving the mouse in and out of a card. All of the pins should toggle between a dark blue, dark green, and charcoal colour. There appears to be a definite cycle to this. If you move the mouse in and out of a card around 3 times, it should return to bright blue (which isn’t accurate anyway as they are un-assigned) for each card.
    I also noticed it appears to be row based. Each row of cards will independently malfunction, discrete from the other rows. So if you hover over a card in Row 2, all cards in Row 2 will display the bug, but the cards in rows 1 & 3 will not until you hover in their respective rows.

  11. The find and replace function does not allow a user to specify a blank value. (I’m not sure if we fixed this in the previous beta or this one, but it’s fixed now).

  12. Snapshot crashing - I was walking through the tutorial and when I got the part that talks about taking a snapshot (5f) when I choose the command it completly crashes the program.
    Testing Steps:
    a) Start the tutorial.
    b) Go to 5f - Snapshots
    c) Click Documents | Snapshots | Take Snapshot

Program will completely crash wth message “Scrivener has completely stopped working”. Using the shortcut key of Ctrl+D has same results.

  1. Footnotes and annotations - The in-line footnotes are still there and the text can be seen if I select it, but otherwise the text is totally covered with black.

  2. Search highlight - I did a search and all the results were blacked out although the settings were on yellow I changed to another colour and it came out white set defaults tabs and the search colour returned to black again.

  3. Fonts sticking - I just tried to change the index card font and size for both the title and the text, and it doesn’t take the change. It always goes back to the default of Courier 12 pt for the title and 10 pt for the text.

  4. Scratchpad not saving and crashes - I thought I would try out the scratch pad since I wanted to move some text to another folder but not until after editing the text. I had the desired text placed in the scratch pad. I closed the scratch pad and opened it again and the text was still there. At this point, Scrivener crashed. When I opened Scrivener again, the scratch pad was empty. The text was gone.

  5. Import issues - For the last few updates I’ve been working with projects I created in Scrivener for Windows. Today I tried for the first time to import a document–one chapter of a novel, in .doc format. I have been unable to import that or any .doc file.
    I get the Import dialogue window, but when I then Import, I get nothing–just a blank screen. I tried saving a .doc file to an .rtf file to see if that worked, but apparently Scrivener doesn’t recognize .rtf files. Anyway, I see that people have reported Import problems for 1.7 and 1.8. It’s happening with 1.9, too, unless there’s some obvious thing I’m doing wrong and just don’t see. Which is possible–but a function like Import should be pretty idiot proof.

  6. Find crash - Click on a folder (one I picked is a sub folder of a folder within default “CHAPTERS” folder)
    Select the “multiple pages” in “show text view”
    Click in the document where there is text
    Hit CTRL+F and search for a word (any word) - close search
    Select a different folder (same level for my test)
    DO NOT click in the document - just hit CTRL+F and try to search for something
    Scrivener will pause for a few seconds then crash

  7. Snapshot sound - There sound for snapshot is only triggered on menu selection not when triggered in inspector buttons.

  8. Snapshots multiple documents - Snapshots do not work for multiple selected documents.

  9. Nested folders - Repeatedly clicking CTRL+ALT+N nests folder creation, when it should act like CTRL+N when clicked repeatedly i.e. create documents at same level. So, too with folders it should create at same level and not next them.

  10. Convert to folder right click - When you right click on a document in the binder, there is a “Convert to folder” menu item in the popup menu. When you click the menu item, it does what it should and converts the node to a folder, but if you right click the same node again the text hasn’t changed and is still “Convert to folder”. Only if you click on something else and then right click on the first node the text will change to “Convert to file”.

  11. Remove full screen border.

  12. a. Create New Project
    b. Select template from fiction category
    c. Named it ‘test’
    d. Clicked on corkboard icon without adding text first.
    e. I get a scrivener.exe has encountered an error and needs to close message.
    f. When I reload Scrivener I get a ‘project open on another computer’ message, however project does re-open.

  13. Right click: cut, paste, copy do not work in fullscreen mode. (I think this was fixed last beta?).

  14. Add shortcut for Strikethrough formatting - this was fixed when we enabled users to full customise the main and editor toolbars.

  15. Change the colour of an annotation by clicking in it and changing the font colour. (This can be set for full screen and standard editor in the settings only currently).

  16. Switching documents by dragging a document from the binder into a header view.

  17. Crashing on full screen - a. Entered Screenings (i.e. select more than one doc in binder)
    b. Entered full screen mode
    c. Selected one document (as in clicking on it to begin typing.)
    d. Exited full screen mode
    e. Re-entered full screen mode
    f. Selected the same or any other document.

  18. References not remembered - When I create a reference, if I update the title, no entries/updates I make in the second block actually take, so creating a reference is multiple steps when it appears to only be one.
    Reproducing the error:

  • Pull up a document.
  • Click the references button.
  • Click the + and then Create External Reference
  • Double click the New Reference
  • Change the title to Reference and type something into the bottom block, then hit enter.
  • Double click the Reference and you will see nothing is in the bottom block. Type again into the bottom block without altering the title block, then hit enter.
  • Double click the Reference again and the changes are there.
  1. CTRL+N and Corkboard - a. Go to a corkboard view
    b. Decide you want to create a number of scenes
    c. Press: Control-N
    d. Instead of typing a name, immediately press: Control-N

When you hit the first Control-N it works as expected, you get a new notecard in the Corkboard view.
When you hit the second Control-N it switches to titling a blank document in the Binder.
It’s not a big issue, as you can continue hitting Control-N to add new scenes, but it changes the view, and that is unexpected.

  1. Rapid scrolling blur - with a notecard selected when you have a split view leads to the corkboard background becoming pixel-lated. It goes away when you click anywhere in the program.

  2. Auto drill down to text view in corkboard - When in the corkboard view if you try to add more index cards by either pressing the green add button at the top of the screen, or either of the add text icons on the bottom left hand side of the corkboard window or binder window, you are able to add one index card. If you click to add a second index card you automatically drill down into the text of this second card. To get back to the corkboard view you then have to click on one of the textfiles listed in the binder and then on a folder listed in the binder which takes you back to the corkboard for that folder.

The only way to add multiple index cards in the corkboard view without having to constantly switch back from text view in this way is to add an index card and then move the cursor to the corkboard itself and click on the corkboard before adding another index card.

  1. Drag and drop - Unable to drag and drop keywords assigned in the HUD into a document through the binder or header. I am able to drag and drop from the HUD only to the keyword section of the inspector pane.
    I should be able to drag and drop directly onto the document(s) in the binder or onto the header.
    These keywords should be appended to the bottom of the keyword list as per the Mac platform not the top.

  2. Inspector launch in full screen - Interesting bug. The inspector can not be launched in fullscreen mode if a folder is selected in the binder prior to fullscreen mode selection. If a standard text element is selected prior then the inspector can be launched in full screen. (Wahooo, finally someone emailed on how to reproduce this reliably - fixed in 5 minutes).

  3. Doc count apply button - Minor, but the Apply button in the options doesn’t set this. It only gets set when you click the ‘OK’ button.

  4. Research folder and include in draft - Documents and folders created under “Research” have checked by default the option “Included in Draft.”

At the very least, there needs to be an setting to have documents other than under “Draft” not default to be included. (By definition can’t include in draft files that are not in the draft folder…however, the mac version also has folders created in the research folder marked as “Included in Draft”
Think of it this way. Maybe you plan on moving the file from research to draft later. Or maybe you use it as a template. Wouldn’t you still want to be able to fiddle with that setting (and have it on by default) in these use cases? Where as on the other hand, there is no harm in having it there and checked for files in the reasearch folder, they can’t be included in the draft anyway. We have not changed this behavior, unless of course there’s a public outcry).

  1. Alt-Tab and disappearing cursor - If I am in full-screen mode, alt-tab to a different window, and then alt-tab back, Scrivener is still in full-screen mode but the cursor is not there, and shift-arrow to highlight text does not show up. The focus is still in the editor, so typing will show up, but it’s focused on the main editor, not the full-screen version: if I have it set up so that I can see the normal Scrivener window while in full screen mode, I can see the cursor blinking, and can see the blue text of highlighting, all in the background window.

(…in making sure this was reliably reproducible, I managed to get Scrivener into a state where typing in the full-screen editor doesn’t work. I can F11 out to type in the normal editor, but if I F11 back to FS it doesn’t seem to respond.

  1. Editor position memory - Remember rough position in document when you click on other documents in binder and then return to editor.

  2. There were probably a dozen other minor bugs we fixed whist addressing the above.


Lee, you truly do have a head of steam built up on this. I think you’re going faster than any of us in a normal life can keep up with, so we can mostly just test what we’ve seen personally. Should work.

  • I tried the menu activate upgrader, and it worked solidly, even over a pretty dodgy indeed wireless connection out here in back of the house. The wording of what it says it will do caused a moment, as Scrivener didn’t shut down for the download, but indeed it did auto-close when the installer told it to - great. You’ve even made the command window smaller and much more attractive with the words in it - think that is fine. With the wording fixed, this should do you for a while. Win7 SP1 for reference.

  • The forced window height with Inspector up is still there, and I know you’ve heard the several of us on that, so no problem with patience, know it’ll get in there.

– Same and same response on the offered path selector for Backups.

  • I think you fixed the issues on the spelling mentioned, as it’s right away checking capitalized words and handling locutions like de-install - Bravo.

  • Footnotes & background in text now fine, also controllable. I just need to understand what meaning is between ghost and not. A quick check of endnotes in compiled looking very good, will go over foot/endnotes more later, but think this is in there.

Over and out, but thanks, Lee, and your crew, for all the fine accuracy on display here.

Here we have a bright sky of stars, out over our end of your Pacific.


WHEEEEEEEEEE! :laughing:

Wow, Lee, this is awesome work.

In my excitement , I didn’t read this otherwise I would have paid a little more attention, but there was a “moment” for me, too, as Scrivener didn’t shut down for the download. I got a prompt that said something about “another instance is running, continue anyway?” … and then my itchy fingers clicked on the still-opened Scrivener, which triggered a “Not Responding”. :blush: Eventually, I crashed it, but the “continue anyway?” prompt was still up, so I clicked continue, and it proceeded to install.

So: in other words, go slow people! :laughing:

EDIT: Lee, I seem to remember you wanting to work on the performance optimization after 1.9 (0.1.9 ?) and was just curious if you managed to work a little bit of that into this version? I have a project with 35++ index cards, and I’m not sure if I’m imagining it, but the loading time on the corkboard feels significantly improved.

Hi Lee,
I love this program, and am so impressed with all the updates and how helpful everyone is!
Re item #17 (import bug), I posted this earlier, but not sure I did it in the right place:
I had scrivener 1.6 and when I downloaded 1.9, I couldn’t open my scrivener file. Mimetic Mouton helped me unzip my file and import the various parts of my scrivener doc back into my binder in 1.9.
While I couldn’t import all the documents and document notes all at once, I did them in small batches and recreated my scrivener file.
As I got to item 60 or so (I had about 80 items)–and I was dragging about 5-10 items at a time back into the binder–scrivener kept crashing. When I reopened it, everything was there, but it happened 5-6 times.
The entire size of what I was importing back into the binder was 10MB, but I was doing it in bits and pieces (mostly b/c trying to import all 80 pieces at once didn’t work), between 5-10 items at a time, so I can’t really tell how big the chunk that was causing scrivener to shut down was. I tried isolating the chunk, but that didn’t work.
I’m on Windows XP, version 2002, service pack 3.
All best,

Just a few photons to confirm that Beta 020 upgrade performed as expected on a Win 7 32 bit platform (Windows firewall and Microsoft Security Essentials antivirus).

On my Win 7 64 bit platform (Zone Alarm Firewall and antivirus, run at the highest security settings) the Beta 020 upgrade performed as expected, with the various confirmation windows from Zone Alarm, right up to the end when Beta 020 didn’t restart automatically. It subsequently started OK ‘manually’. I don’t regard this as a significant problem, and am not looking for a fix, but I hope the info is useful in resolving any other reports of upgrade difficulties.

Terrific job, by the way.

Thanks Lee,

It’s looking good but I’m still having trouble with auto update program which I tried three tines on a Vista Business machine (fully patched) and running Microsoft Security Essentials for AV and firewall.

Auto update works as expected to the download stage. Monitoring Task Manager, Scrivener and Scrivener Update are running.

When the download stats a third program, Update, runs, and the file is downloaded.

On completion of the download the update starts, and in the process closes 1.9, and appears to complete but does not re- launch Scrivener. Manually restarting the programme shows it has not been updated.

No file is left in liveupdate/tmp

It might be worth noting that on a manual download Vista blocks the install as an unknown program.

BTW installing over 1.9 does not clean up 1.9. It is still necessary to uninstall and reinstall to get a clean install.

These niggles aside, an outstanding application.



I just downoaded the update.

I noticed two major things, one bad, one good…

  1. the install instruction says that Scrivener will close before installing.
    That is the bad news : it didn’t close (Win7 Home Premium fully updated), but said that another install was already active, and prompted me to stop or continue…
    I chose continue and closed the application manually…

  2. and this is the very good one : the huge project I am workin on opened in only 1 second… waooow !!!
    The look is neat as if someone had cleaned my screen from the inside…

Seems to be greater than ever !

Thanks for your hard work !!!

Long-time lurker, diligently experimenting with each version that’s come out–I just wanted to say that, with the separate editor/full screen color options you’ve integrated into this version, Scrivener for Windows has become seriously the only novel-processor I’ll ever need. I can’t wait for the full version to come out, I’ll be first in line to buy it. :smiley: This is fantastic. Thank you so much.

Loving the new beta. I’m positively giddy!!

Can’t wait to purchase.

Must be the longest changelog yet!

Any way, really looking forward to the Linux version, since I’ve switched to CrunchBang Linux for my primary OS and I can’t really test on Windows XP any more :frowning:

Hi Lee,

The download link on the main page (literatureandlatte.com/scriv … taller.exe which is now 404 not found… :slight_smile:

(Having not read properly that I could update through 1.9, I uninstalled it then went looking for the 2.0 installer. I did manage to download the 2.0 installer by modifying the link.)

Also, I think there is an issue with the installer’s final page with the “Run Scrivener” and “View Readme” options. Installing 2.0 (and 1.9 for that matter) on Windows 7, the Readme will open when checked, but Scrivener doesn’t.


My document notes have disappeared after the upgrade. The files still exist in the project folder but they do not pull up in the screen. I cut and pasted one of the notes from the rtf into the document notes for the appropriate section and it saved a new document note with that text to the disk. It shows up, however, for all documents. Selecting any document never changes the notes. I closed and opened the app and the same notes were there and showed for all documents. I checked the links file and found the XML docs basically empty (no data besides the structure). I’m assuming that the links file links the document notes to the document (just an assumption). Here is the contents of the link that corresponds with a document with notes that should be there but is not:

<?xml version="1.0" encoding="UTF-8"?>

For now I’m going to cut-n-paste my notes into a research doc since I need them and the docs and structure are coming up find.

Also, I just noticed that the Synopsises and titles are missing from document view as well. They show up on the cards view. When I switched a single document to card view everything showed back up. When I switched back to document view it was there so I have my notes back. I closed and reopened and everything was working right again.

I don’t know what caused it but maybe that’s enough info to help isolate it.

Thanks for the hard work.


Awesome …

Now I, for one, think you deserve a well earned rest for a while - alongside some sunny beach (do you have one nearby :snicker: )

Thanks for all the hard work …

mmm The update got a little confused as it opened up a dos shell window and then complained there was an instance of Scrivener running, perhaps the routine should accept this and shut it down automatically?

Running Beta 2.0 on Windows XP SP3. So far so good.

When I installed Beta 1.9 and opened my short story project, I was surprised to see that the only information in the “First Page Header” document was the title, my name below that, and the field I had left unchanged in the upper right corner “<$wc100> words”.

All of the info for the fields in the upper left corner were gone. (<$template_fullName>,<$template_street>, <$template_city>, <$template_state>, <$template_ZIP>, <$template_phoneNumber>, and <$Template_email>) I found this very strange, as I had highlighted the fields with my mouse, and then simply typed the correct info in. Having replaced the field tags in this manner, I found it odd that updating Scrivener should have any affect on the info I changed, even if the template had changed.

I tried creating a new short story, and the fields were missing there as well.

When I updated to Beta 2.0, I was happy to see the fields return in the blank project I had created to test the problem in 1.9, although they were still missing in my short story.

I have fixed my project, but you may want to look into why Scrivener would change an existing document just because the template used to create it had changed.

On a side note, I noticed that it still doesn’t matter whether I have ‘created’ or ‘modified’ selected in the inspector: the date still does not change, even when the document is modified.

I made a comment in your “24TH FEB - LEE’S UPDATE - BETA 1.7 IS HERE” about Scrivener not giving any indication on screen when it was doing any kind of internal processing (ie: saving and such).

The following snippet of that post sums it up pretty good:
". . .there is no visible evidence the program is doing anything. . .
. . .whenever Scrivener is doing any kind of “internal” processing (i.e. saving, checking for updates, etc.) For all we know the program may have frozen, or the feature may simply not be working.

We software users are an impatient, panicky lot, and like to have assurances that the program is actually doing something when we tell it to. (Beta testers are are worse than most in worrying about program crashes). . .

. . .Basically what I am saying is this: Whenever Scrivener has to do something it would be good to have an on screen animation to show us that Scrivener is busy. (It will also calm our fears about the program crashing: if the animation is still in motion the program is running; if it is frozen for more than a few seconds, the program has frozen.) Oh, and if you do decide to implement this, please make it something besides/in-addition-to the little hourglass mouse icon."

Is this something you might include? If so, will you attempt to include it in this version, or will you wait for the next version?

Thanks, Luncarclipper

Although I see your point (although it’s not a problem I’ve come across), perhaps it would make more sense for Lee to wait until he’s done his optimisation work and then see if these pauses are still troublesome and require this type of indicator?

Obviously, this make good sense to do this kind of thing if required. We have certainly been slipping in performance tweaks in both beta’s 1.9 and 2.0 and we have not finished. I’m not sure it’s absolutely necessary to put animations in just yet.

Thanks for the answer Lee. I love Scrivener, I just get a little nervous when I don’t have any visual confirmation the program has done something, like save, after I have told it to. I am happy to wait for this until you have more time.

Thanks, Lunarclipper

I agree with Lunarclipper; I tend to get a little confused when I don’t get any feedback from Scrivener when it’s doing an internal process, or when it’s completing it. It need not be a fancy animation, just a placeholder to “please wait” and a “[process] completed”?

Backing up, for example, seems to make the Scrivener application inactive–which makes perfect sense to me, since it’s zipping up all the files and I shouldn’t be poking around until it’s done, but I have no indicator. If I click too early (and too impatiently/frequently), I can actually trigger a “Not Responding”. But if I wait… I’m sort of sitting there, wondering when I can resume my work.

Still, I’m also with Lunarclipper in that I’m more than willing to wait for this. I understand that other bugs and features would definitely have a higher priority. Besides, when I’m not trying to crash Scrivener and simply want to use it, I’ve learned how to play nice :wink:

I’m really loving the program. :smiley:

Good work. Looking forward to the 1.0 “final” release.

One thing bothered me, when I installed 0.2.0 and went to FullScreenMode… everytime I point+click my mouse, I’m searching the (massive) screen for where the cursor and the willing-to-correct-typo went. Could the “always type at middle-screen” become an OPTION? (while doing wordwars and other sprints this is indeed helpfull and gives the feeling of unlimited space to tell the story)