13th APRIL - LEE'S UPDATE - BETA 023 RELEASED

Looks nice! Some UI tweaks? Looks more like my fiance’s copy now. :wink:

Compile bugs (pdf, odt) still there, but it’s something one can work around. Do you need screencasts of those still?

Installation for me was straightforward as with any Windows installers. You might check the reference documentation here in the pdf file:

28th MARCH - Reference Documentation Which is a draft of the User Manual for Scrivener for Windows. I wish I could be more helpful to you. :slight_smile:

Hi. Thanks for the quick update. But it re-introduced another bug. :frowning:

I posted before about compiling for docx and receiving the error that it “may require MS Word to be installed.” This was version 021. Then in version 022 it went away and I could compile for docx no problem. I downloaded 023 and it is giving me the same error again. So something was fixed and now is not again.

FWIW, I do have Windows 7, Word 2010 installed, all bought and paid for, legal eagle, scout’s honor.

Please let me know what I can do to help you find this little bugger.

Thanks!

Lee, good stuff, which is looking very well.

I actually encountered the release at 4:30 this morning when I woke up for a while, and just wanted to check again that the split-stuck synopsis bug was really fixed: looks like it is.

The binder scriv highlight still isn’t keeping up when you close the editor split, but things do work otherwise both before and after a close-reopen. I’m keeping a little list of misses like this, and will send a set up soon.

Confirm with garpu that compile-to-pdf isn’t there again yet, and that it is a low priority until getting ready for actual release. Probably something very simple, since it tries to work, and worked before.

7-zip. It’s a tight compression framework, but a nasty little program, perhaps just in its GUI add-on, as I think it started out in command-land. I suspect that by comparing what it prefers from Winzip with the QT output, you can figure out the actuality of the flags, but there are many more important fish to fry at this time, much agreed.

Saves themselves are looking solid: I tried to rush them by creating a text and immediately hitting the close button, no 2-second wait I intended. The writing was there when I opened Scrivener again, which I imagine is your intent.

Great job on the recovery, Lee, and the other team (ExpressionEngine) also got a fix in this interval, so software works again in this world. Kind of amazing, isn’t it :wink:.

Best,
Clive

Thanks guys and girls.

I have noted the following issues raised:

YES PLEASE. I can’t duplicate the ODT, PDF or DOCX compile generation issues reported. I produced all the files immediately after reading the post. I did however notice that I had to press F5 to refresh my desktop and see the files which wasn’t usual, but it’s probably my machine needing a re-boot?

I was not able to reproduce point 5. See notes on point 1.

Lee

Here’s a link to the post with the screencast on this I posted yesterday, in case you didn’t see; might be helpful. Doesn’t show the “requires MS Word” issue, but I’ll toss that up when I can get it if someone else doesn’t first.

Ok Weird. I have 023 on my home computer–also Win7, also Word 2010, and it does fine. Something hincky with the installation on the laptop. I’ll re-install Scriv and see what happens.

And I still love Sciv so much it’s probably sinful.

Seems to just not be consistent (the worst kind of bug!), as I have had it throw the “you need Word” error on a machine without Word but also go through the process and use WordPad instead without giving me that error and ultimately create a successful PDF.

Lee,

  • looked at MimeticMouton’s screen drama - not exactly like mine, but I picked up the Very name and downloaded their pdf kit after finding also the dll in Scrivener folder.

  • I can’t see making you a film of this myself. The action is very simple, after some tries at variations:

    = with a long file or tiny, try Compile to PDF. It doesn’t matter if you use custom (very mild) or one of the preformatted compiles selectable.
    = upon setting the file name, a small progress window comes up. It doesn’t say anything about Very. Progress is very slow indeed, something like 1% per 2 seconds.
    = at some point between 7% and less than 20%, the small progress window disappears. Waiting longer, even minutes longer, doesn’t change what you get, so it is really done.
    = observe your generated PDF. It won’t open, says corrupted. It’s 6KB for a tiny (4 scrivs of 1 line) project. It’s about 168KB for a huge project.
    = try compile to print, printing to Adobe Acrobat. Takes about 3 seconds after filename approved, for the huge project. Output pdf is 401KB, and it works splendidly.

  • now, Scrivener compile to pdf worked, just a version or two ago. I know because I was making a small portion of those font observations with it. It was quick - maybe quicker than Adobe. Output I think was actually fine, and we are in future going to assure that.

  • I am on Win7 like Mouton, all freshly fresh to include yesterday’s MS updates, and Scrivener has been installed each time by a deinstall followed by dump of any progdir Scrivener folder. This last time, Scrivener deinstall had fully removed that folder itself, with my thanks.

  • i am speculating, but to no usefulness. So I look with a hex editor. Guess what – the entire text is there in the bad Very pdf, apparently in UTF-8 because each character prefixed with zeros. I can see its beginning and end. The adobe file is three times as large, while all the text and inclusions are compressed, so I can’t read it. Apparently there is lots of the usual included stuff there, and perhaps this is where Very is at present breaking down. Is it possible there are resources missing in the install, esp. as the fail came after clean deinstalls?

Think that’s as helpful as I can think to be, Lee. I would have cleared for and run one of the old installs again, but of course they’re date-limited.

It’s a very solid problem - repeats much the same each time. One other clue is that dual 2GHz cpus seem very busy (or something is) right about the time the small progress bar dialog wants to come up. It’s very sketchy, then fills in as the amount hits between 2 and 10%.

Regards,
Clive

Hi Clive,
Would you mind emailing me those PDF files and I look into it further?
lee AT literatureandlatte DOT come.

Thanks
Lee

Headed yr way.

Regards, Clive

Ah yes, had meant to mention a small idea.

That if included stuff (pdf boilerplate) was missing, perhaps it’s the path to those that’s wrong, rather than missing includable items.

Just a thought,
C.

No action needed, just wanted to update on a prior feedback about being able to crash Scrivener if I clicked too quickly on the program while it was backing up. I installed Jing and all that jazz, preparing to replicate it, but so far, it doesn’t look like this version has that problem. Even if the program seems to be “busy”–it’s for the briefest of moments-- and me trying to click madly away doesn’t trigger the “Not Responding” anymore. Still think a feedback dialog would be nice but this can be moved waaaaay back on the list for more critical issues.

I re-installed on the laptop and getting the same “MS Word may be required” bug. Then I un-installed, restarted, deleted the …Progams (x86)/Scrivener folder, reinstalled and getting the same error.

I have Win7 64-bit, MS Office (32-bit). Could that be the problem? What can I send you as far as error-reporting tools?

Oops. Tried to compile to pdf and got this error, which also froze Scrivener:

Golly, I’m harassing this forum. I re-tried the compile to pdf and it now works, but compile to .docx is consistently not working with the release. Now I’ll sit back and wait…er, write. Sit back and write.

Thanks for the new Beta! It seems much better, though I’m still playing with it.

I’ve just complied a 3000 word short (plus title page) straight from Scrivener to PDF, Doc, Docx and html. They worked without a problem- the Doc and html was almost instantaneous, but the PDF and Docx took a few seconds. The only visual problem was that the compiling bar (PDF and Docx) vanished half way through - but the compiled files were fine.

Nice work getting the new one out so quickly!

A few fairly minor notes (working in a new project created in 023, Win7 Pro 64bit):

  1. Page breaks don’t seem to work in compile, either to .rtf or .doc (haven’t tested others). Checking the boxes for “page break before” in the contents pane doesn’t do anything, and they are unchecked when you return to the compile settings in the project after running the compile. Likewise, the “page break” separator option does not insert a page break.

  2. The final “scene” document of the Novel (with Parts) template (under the “Chapter” folder of the second “Part”) exhibits the margin issue that makes the RTF file have about a half-inch of text space so you get the compile with one letter/word per line. As noted elsewhere, it’s actually present in the underlying RTF, as you can see if you open the file from Files\Docs in the .scriv folder in an external editor. Fixing the margin (either in Scrivener or, after export, another editor) works just fine, but the templates should be fixed at some point to help avoid this issue continuing. (I know the templates all still need to be fixed up anyway, as they’re full of Mac pieces that don’t correspond to anything in Windows; also the compile settings seem to not have been adjusted from the Mac version, at least for Novel with Parts–so basically, just compiling with the default template settings does not at all do what you want it to. All obviously minor issues, just something to check whenever templates are redone.)

  3. Searching/replacing carriage returns does not seem to be possible at present. It is possible to copy and paste the invisible characters into the find and replace fields (or it seems to work, anyway), but nothing is found if you then run the search, and likewise nothing is replaced. I have no idea how hard this is to implement in Windows, but it’d be a fantastic feature if it could be added at some point down the road. Obviously again, nothing compared to bugs, so this is for a later date.

  4. New projects, regardless of the template chosen (including “blank”), always start out taking up the entire screen space so that the bottom section (all of the footer) is hidden under the Windows task bar. Could this be changed so that they’re either a smaller size and can be easily dragged or maximized to fit the screen, or so at least they’re maximized properly, resting on the taskbar instead of moved underneath it? (This has been mentioned elsewhere, but it’s still an issue in 023. Seems to also happen the first time projects are opened in Windows after being edited in the Mac version, no matter what size the window was when closed on the Mac. Happens in XP as well as Win7.)

Thanks, and great work with all of this!

Thanks for the quick update, Lee. No need to apologize for the problems. You’re doing us a big favor by letting us use these beta versions in the way you do.

I’m assuming that you know that the check for updates feature is still non-functional but thought I’d mention it in case I’m wrong.

Thanks for getting the Find function working again. Works great for single files. Finds the text, highlights the text and moves the display to the location.

Not so much joy for Finds over several selected files. It will find the text and it does highlight the text. But Scrivener doesn’t move to the hit location so you’ve got to scroll down until you find it.

It’s hard for me to believe that I’m almost done with revisions on a novel that I started when you first made Scrivener available. The software has really matured during that time. Thanks again.

Cheers — Larry

Major problem when trying to open an existing scrivener project in the latest release:

I followed the link from this post and clicked on the refresh button for my browser, as instructed. I uninstalled 022. While the uninstaller was working, I downloaded the installer for 023. I installed 023 after the uninstall of 022 was completed.

-Scrivener opened up like a first time install (the project template selection dialog with an empty “recent projects” drop down) since all options were reset to the defaults with this install. (this was expected)

-Browsing to a previous project and selecting it took me down a level into the parent “folder” (the folder with the project name and .scriv extension) as if I had selected a folder. The expected behavior (the behavior that all previous versions exhibited) was for Scrivener to open the project.

I figured maybe this was just a problem with the that dialog box, so I created a blank project just to get me into the program.

-I went to file->open and tried to select a project from the “open” dialog box. The same thing happened: When I select a scrivener project it is treated as if I had clicked on a Windows folder. I am taken into the project’s .scriv folder.

In short, I can see all the files in any of the .scriv folders, I just can’t open any projects :frowning:

I hope this is just a problem with the install. I will uninstall and try the whole thing over again, then let you know if the problem persists

Sorry to rain on the party, Lunarclipper

Well, after much trial and error (including uninstalling and reinstalling this version, installing the prior version, doing a system restore to a few days ago. . .) I finally got Scrivener to open the files. I simply clicked on the “project” file in the .scriv folder for the project of choice :blush: .

I don’t remember having to do this before, but I could be wrong. If I am wrong, chalk it up to lack of sleep for this week and fatigue after getting off shift this morning. . .and stop laughing at me :stuck_out_tongue_winking_eye:

P.S. Still can’t get the “modified” selection in the inspector to show a new date when I modify a file. Saving the document still doesn’t help, neither does closing Scrivener and reopening it.