17th MAY - BETA 024 RELEASED FOR LINUX

Hi Beta Testers,

Beta 024 has been released for Linux. The expiry for this beta is 30th June 2011 and can be downloaded here: http://www.scrivenerforwindows.com

Lee

When trying to install the Linux beta (24), I’m consistently getting the following error:
libphonon.so.4: wrong ELF class: ELFCLASS64

I realize that this beta is compiled for a 32 bit system, and mine is a 64 bit, but I’ve not been able to trace down the appropriate file (or fix). I am currently working with Scrivener using Wine - but I would like to use the native Linux if possible. Great product, by the way.

I’ve made an ugly hack to make sure the bundled libraries are loaded consisting of a simple wrapper script dumped in the bin-directory.

Disclaimer: I am not a developer, and noone would likely call me careful either. If this screws up your PATH-variables and transforms your dog into salami, well, just go ahead and blame me. :slight_smile:

/home/(your username)/LiteratureAndLatte/bin/scrivener.sh:

#!/bin/bash export LD_LIBRARY_PATH=/home/(your username)/LiteratureAndLatte/lib:$LD_LIBRARY_PATH exec /home/(your username)/LiteratureAndLatte/bin/Scrivener

After creating this file, run:

~/LiteratureAndLatte/bin$ chmod +x scrivener.sh ./scrivener.sh

This should make sure that the proper libs are loaded.

phibxr -
The ugly hack worked like a charm. Thank you - and the dog is fine. Also, the Linux version works much better than the Wine wrapped Windows version.
bill

The file I get is LinuxScrivenerBeta14.tgz – is this just mislabeled?

Also on 32-bit Archlinux it doesn’t run for me, even after the above fix for the libraries.

/home/data/LiteratureAndLatte/bin/Scrivener: symbol lookup error: /home/data/LiteratureAndLatte/bin/Scrivener: undefined symbol: _ZN19QTextDocumentLayout16staticMetaObjectE

When I download the file from the link, install it and launch it, I get a message that this beta version has already expired. The file that is being downloaded is LinuxScrivenerBeta14.tar.gz. The extracted folder shows a last modification date of March 4, 2011. Somehow I don’t think I’m downloading the correct file. Any suggestions?

Assuming you’re on Ubuntu, why don’t you try the deb package?

I tried two different deb packages. I downloaded from sources linked to from elsewhere on this forum, and tried installing both through the Software Center and CLI (dpkg). Neither one successfully installed.

Unfortunately, this is the second time that the auto-expiry on the betas have ground my writing to a halt. I respectfully suggest that the developer either abandon the auto-expiration feature for the betas, or develop a more reliable way to promulgate updates. Google project hosting or launchpad or something?

I had no problem with the .deb on an a fresh 11.04/32-bit installation, so I’m not sure where the problem is on your system. Was the error the same with both debs? What commands did you use exactly? What was the output?

I’ve also had the windows version work through wine, using the wiki instructions, if you can’t get the native working. Also note that your work isn’t locked up, even if the beta expires on you. Look under .scriv/Files/Docs – you should see your documents stored as .rtf files.

It worked perfectly. I just put the code for a desktop launcher (and my idea of a icon) over here.

Thanks for being the helpful kind of linux user!