1st time Compile... confused about document selection

I can’t compile (to enumerated outline, but that seems incidental info) the specific documents I want. Compile “Manuscript” + filter “All [Documents]” + exclusionary filter doesn’t seem to work for me.

The manuscript section in the binder looks like this

image

The “Unplaced” folder is marked “Include in compile” in the inspector, but nothing under it is marked for inclusion.

Q1: Is there a way to toggle “include in compile” for everything under a binder item (all children)?

Not knowing how to easily include more things I tried something else.

When I try to set up a compile the default option is “Manuscript” for the things to Compile, and I see in the dialog the list of items included/excluded for compilation: it includes only the items in Manuscript that are marked “include in compile”., which is perfectly reasonable and fits the UI choices made.

image

However, to get the selection I wanted in the absence of an answer to Q1 above, I elected to use the Filter method as shown below, choosing to compile not just “Manuscript” but “All” (documents) except those I exclude - and for this I put everything outside the manuscript into a “non-ms” collection

image

But as you can see “Excisions” is still not included. It is not marked “include in compile” but from my reading of this method it shouldn’t need to be.

I also tried compiling by selection in the binder - a small part like this

image

with this result

image

Q2: How can I easily compile a selection of documents regardless of the “include in compile” setting, which the “all documents” start point seems designed for facilitate?

Update 1 Q3 - maybe I should not expect the selection in the dialog to update with changing selections… would it actually do what I expect if I allowed it to proceed regardless of what it looks as thought it is going to compile?? Answer No. Just tried that too, “Unplaced” is there, but none of its children.

Update 2 Having noticed the include subdocuments for the selection, I tried that too… no luck (“folder” shown, but other documents still not selected)

image

The filter to override the exclude from compile state of a document and rather compile “all” documents doesn’t work for now. There is a known bug with it(about to be fixed). [Funny timing : I just learned of it myself only days ago.]
You have to manually mark your documents for inclusion. Either in the list in the compile panel, or in the documents themselves.

Thanks for the info; very helpful to have bug confirmation - I suspected as much!

I have now marked all the documents by hand, which was tedious.

Looking forward to that fix… I’m sure there’ll be plenty of others at the same time, which is always nice.

I wonder when that might be. :slight_smile:

. . . . . . . . . . . . . . . . . . .
Meanwhile,
to compile only a single folder or parent document and its content, select it here (compile panel) :
image

To compile non consecutive documents across the binder, the best solution is to create a collection, and then compile that collection :
Right click the desired documents in the binder :
image
→ You can add them a few at a time to your collection. You don’t have to select all the desired documents at once, so long as you add them to your collection in the order in which you want them to be. In other words, starting from the top of the binder, going down.
Then compile that collection rather than your draft.
. . . . . . . . . . . . . . . . . .

Note that modifying the include for compile state of a document in the compile panel list affects the document just as if you would have made the change for it in the editor. In other words, it does not revert to what it was before once you close the compile panel.

1 Like