2.0.2 mixes up chars

:open_mouth:
when editing my project as complex documents (scrivenings), characters get mixed up in a completely unpredictable way. All my work of this morning has to be redone - shock.
I know it sounds improbable, but it is the case. I did not manage to figure out how to reproduce the error. It seems like a kind of overlay of the old and the new version.
Project is in German, so no sense to show the Details here probably …
Example: “lässt sich nicht wieder finden, ist klarumrissen oder formlos, versinkt am Ende in den Tiefen des Vergessens. In all dem verhält er sich wie ein”
became
“lässt sich nicht wieder finden, ist klarumrissenn oder formlos, versinktam Ender in den Tiefen des Vergessens. In all deem verhält er sich wie ein”
and these are not my editings! (also dashes and fullstops jumping around)
Oh, Keith, can I please get 2.0.1 until this is cleared? Is there a link to download the older version?

This has nothing to do with 2.0.2 - nothing changed there. And I can’t clear this up until I’ve seen it for myself. Ioa said he saw something like this once, but we never found any cause and until I can reproduce it, there’s unfortunately nothing I can do.

What does the Console say (~/Applications/Utilities/Console.app)? Are there any errors there?

Do you have auto-correction or anything like that turned on? There’s nothing in Scrivener I can think of at all that would cause characters to get swapped around. Also, did this happen while you were typing, or after you reopened the project or document and came back to it later?

Is it possible you’ve run a spell-check on it that might have changed the words? This looks very much like some auto-correction has been applied somehow.

Thanks,
Keith

Keith, thanks, like always, for your incredibly prompt reply.
I’ve experimented a bit and can reproduce what happens.
Take some docs together in scrivenings. Lock editor. Text looks like this:

situation.jpg

Then, edit something (I added a sentence, and overwrote some words):

experiment.jpg

now unlock editor, dissolve scrivening by viewing some other single doc. After this, reconstitute same scrivening. it looks like:

result.jpg

This happens systematically.
No auto-correction activated. Scriv pref “symbol and text substitution” is off. Scriv “correct spelling errors as you type” is off. System prefs only first seven symbol substitutions are on ( “©” etc.). Used font is AdobeGaramond pro. Console says as coming from scriv:
01.12.10 15:39:48 Scrivener[2077] dealloc arbitrary collections table controller!
Then there is stuff from com.apple.dock.agent and skype, seems not relevant to this behavior?
One more symptom: When editing in a scrivening the last line before a new doc begins, the last letter is systematically eaten away.
I use the new, small (and very nice) dividers between docs.
Any ideas? Writing has become dangerous like this. I had an “last line in doc edit doesn’t hold in scrivenings” problem before, but this behavior is new, and is weird.

Now there is one more entry in the console that could maybe have to do at least with screen rendering (but I’m a complete fool in system console messages):

01.12.10 14:31:20 osascript[2203] Error loading /Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types: dlopen(/Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types, 262): no suitable image found. Did find:
/Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types: no matching architecture in universal wrapper

This message is recurrent in the console.

incredible. sorry for flooding the forum with this.
The behavior disappeared. At least for now. Can not reproduce it any more. What I did:

  • indentified the error message concerning “osascript” in some Adobe forum, and updated a file in Library/ScriptingAdditions (has to do something with 32 and 64 bit?!).
  • restarted the computer.

Now editing is back to normal. No idea, if this was caused by the “osascript”-thing (what ever it might be). Maybe just by the restart. Maybe the symptoms will be back. Just wanted to let potential readers and / or Keith know that the shuffling of characters has stopped somehow miraculously.
If it reappears, I will reapear here myself, and continue flooding. Because, it was weird, and potentially hazardous for any writer.

:frowning:
now it’s the same as before.
no editing of scrivenings possible without shuffling the characters.
I even didn’t restart the computer - it was just on sleep for the night.
No idea on what it depends.
I’m near to desperation.
No one else here having these problems?

Hi,

Could you please split the editor and have scrivenings open in one editor and the single file that is being edited in scrivenings in the other editor. Then edit the file in scrivenings - do you see the text appear in the wrong place in the single file in the other editor? To me it sounds as though for some reason, the edits in scrivenings are getting assigned incorrectly to the underlying single file, but I can’t reproduce it. Let me know the results.

Thanks,
Keith

Any update on this? I’d like to investigate this further…

Thanks for asking, Keith.
I tried splitting the editor and see what it gives, but without success: the symptom just didn’t show up.
In regular writing I am a bit hesitant to use scrivenings now, as I had already to clear up some good servings of character-salad. I am editing mostly single documents now.
My suspicion by now is, that the problem could be linked to something else going on in the system at the same time, as it is present sometimes, and sometimes not, without any visible reason. Maybe some stack getting mixed up.
I suspect my level of caution will drop again, and hope to trap the strange error. If I get something palpable, I’ll post here.

Thanks. That is strange. When you edit text in Scrivenings mode, Scrivener works out which bits of text are being edited and does some offset adjustments to work out which underlying single text is being edited, and which part, and it updates the underlying text at the same time. In this case, it sounds as though Scrivener has applied the changes to the wrong parts of the underlying text, so that only when you switch back to the underlying text, or back to Scrivenings after (which is rebuilt from the underlying texts at that stage), do you see that it has messed things up.

But there must be another factor involved, otherwise everybody would be experiencing this. If you can locate it, I’d be very grateful!

Thanks and all the best,
Keith

tried it at once and now could at least provoke what we are looking for.
splitted editor, left in standard editor view, right in page view two up.
left:
Screen shot 2010-12-06 at 18.03.18.png
and right:
Screen shot 2010-12-06 at 18.03.45.png

actual editing done in left editor.
first we have an example of an “already consolidated mess”, stemming from a former cycle of editing / viewing:
look at “hese are strange things.” - (don’t care for the rubbish I’m writing) - its “t” miraculously hopped over to the beginning of german “auch”, which became “tauch”.

now, “real time”, as the screen looks immediately after some typing, without resolving the composed documents:
left has “now one more test Und dann,” - right: “nnow one more test nd dann,”
when resolving the scrivening and reloading, confusion continues: Sometimes it’s the faulty version that is incorporated into the main text file, sometimes the correct one. Could it be that the version of the active editor is maintained?

besides (not sure about the precise time of editing the text), there were two messages of scriv in this time interval in the console (the second is after the event for sure):

06.12.10 17:54:41 Scrivener[4698] dealloc arbitrary collections table controller!
06.12.10 18:16:53 Scrivener[4698] NSMutableRLEArray objectAtIndex:effectiveRange:: Out of bounds

Okay - that last error message on the console is most likely the cause here:

Scrivener[4698]	NSMutableRLEArray objectAtIndex:effectiveRange:

After that gets thrown, all sorts of weird things could happen. Could you please try quitting Scrivener, then relaunching, then experimenting with the Console open alongside Scrivener until you see this message spewed on the Console. Then try to isolate the exact trigger and let me know, and provide the steps to reproduce - if you can do that, I’d be very grateful, as this is a nasty one!

Many thanks,
Keith

Oh - I tried to PM you, but that didn’t work out.
This specific message appears in all my week-long console file only once (just scanned the file), and came definitely after the shuffling. I will keep the console open as you recommend, but to me it seems that there has to be still something else, as the other occurrences of shuffling did not induce “NSMutableRLEArray” ?!

me again. restarted scriv, provoked the error, no messages in console.
screenshot attached.

Hmm, okay, the error is a separate bug then - that’s not good!

Can you now provoke the error every time with a certain chunk of text following a specific sequence?

Thanks!
Keith

I’ve managed to make a small scriv file that behaves systematically like this if you follow some specific steps. I could zip it and send it to some address.

Great! Could you please send it to support AT literatureandlatte DOT com and mark the subject line “Attn. Keith” (Ioa answers the support e-mails but will forward any to me that are marked for my attention).

Thanks!
Keith

I’ve forwarded further instructions to help us reproduce this (it doesn’t with just the project); so check your e-mail.