2.41 to 2.5 Update Problem

I use Scrivener 2.41 on an Intel iMac with Snow Leopard. After being reminded day after day to update to 2.5, and selecting the “Remind Me Later” button, I finally decided today to go forward with the update. But something very strange happened.

  1. It went through its usual update sequence, and I waited for it to finish and then reopen my project like it usually does. But it didn’t. The menu bar was there, but my project wasn’t (it didn’t open). I found it in the recent projects list in the menu, clicked on it, but it still wouldn’t open.

  2. I tried quitting the app, but it wouldn’t quit. I finally had to force close it.

  3. I went to the app icon in my dock, but it was different–just a generic paper with pencils. I opened it, the menu came up, but again nothing. I force closed it and went to my apps folder. There I found two copies of Scrivener: the one with the generic icon as described; the other the 2.41 version.

  4. I opened the 2.41 version and got a message that said something like: “…that project is already open. Make a copy if you’re not sure…. Or continue…” (I don’t recall the exact wording.) Anyway, I selected the “make a copy” button and my project opened as a -1 version.

  5. I closed the -1 version, and went to the actual folder where the project is located and found both the original version and -1 version. I selected one, then the other, but neither would open.

  6. Since I was unable to open my project by clicking on either the original or copy, I went to the menu’s recent projects list again, and got the same copy or continue message. I selected copy and another version opened, -1-1. So, now I have three versions of the same project: the original and two copies, but can’t open any of them without resorting to the menu’s recent projects list.

  7. Lastly, I clicked on “Check for Updates” in the app menu, and the 2.5 update prompt opened, asking if I want to update, as if I didn’t initiate the update at all.

I rebooted my Mac but am still experiencing the same behavior. At this point I’m afraid to touch, update, or open anything. Again, a project is not accessible at all unless it’s in the recently opened list in the menu. And then only available after going through that copy or continue cycle.

Should I just trash the weird generic icon (keep the 2.41 of course) and try to update again?

I hope you can help me fix this. Scrivener is one of the least temperamental apps I’ve ever used, and I use it every day.

Thank you.

One more thing…

I forgot one more oddity. When I tried to open my project or any of its copies directly from the project’s folder, this is what happened:

  1. I clicked on the icon.

  2. The progress bar opened with that project’s title, but nothing happened.

  3. I tried to quit the app but it wouldn’t quit, and the frozen progress bar remained.

  4. I tried to open the project from the recently used list, but was unable to. So I had to force close the app again.

  5. I opened the 2.41 app again, and got the copy/continue message, specifically this:

[b]"PROJECT ALREADY OPEN

This project seems already to be in use in another copy of Scrivener on this machine ((null)). If the same project is opened more than once at the same time, data could be lost.

It is also possible that this project didn’t finish closing properly the last time it was used.

Choose ‘Make a Copy’ to make a copy of the project and work from that, or ‘Continue’ if you are sure that this project is not already open anywhere else."[/b]

Below this message there are three buttons: Cancel. Copy. Continue. If Cancel is selected, this message comes up:

“PROJECT NOT OPENED
You have chosen not to copy or continue opening the project. The project will not be opened.”

Very strange.

Thanks again.

Sounds like the installation process got halted somewhere along the line.

Do you keep regular backups of your machine using Time Machine? You could revert to just before you attempted to upgrade.

Another less severe thing to try however would be to uninstall Scrivener completely and then reinstall. Your project should be safe and unaffected by uninstalling (and should be largely unaffected by this too), but to be safe, better make a backup copy of your project file and any associated files.

I also kept a backup of 2.4.1 in case 2.5 had some bugs (bugs would not be welcome at this final stage of my writing). You can do this by simply duplicating Scrivener.app and renaming it to something like Scrivener2.4.backup.app.

Thank you. I’ll try what you suggested. If I initiate an uninstall, can I just select the bad version of 2.5 to uninstall? Or will it also uninstall my 2.41 version?

Thanks again.

Well, I think unless you backup the older 2.4 app then the install process overwrites it, and as such you can’t uninstall 2.5 and revert to 2.4. You might be able to download 2.4.1 from lit&lat somewhere if they keep older versions. But I’d jut try reinstalling 2.5 again and see what happens.

Did you have automatic backups enabled in Scrivener? If so, you should have a number of previous versions of your project somewhere, so if things totally stuff up, not all would be lost. Still backup your .scriv directory now though.

I also responded to your support email, but wanted to share with the forum in case anyone else is having similar problems.

  • If you ever have a problem with the upgrader tool, the fastest solution is usually to just download the installer directly from our download page, and try again. Delete any previous versions, including the “bad” install from the upgrader.
    literatureandlatte.com/trial.php
    If you’re a registered user, the “trial” should pick up your registration credentials automatically.

  • You can revert to version 2.4.1 if needed, by downloading that version’s installer here:
    literatureandlatte.com/scrivChangeList.php
    Scroll down to the version you want. Generally only the immediately previous version will be available: we want to let people step back in cases like yours, but don’t want to spend our lives troubleshooting long-fixed bugs.

  • You can also run multiple versions of Scrivener at once, by giving each item in your Applications folder a unique name. I do it all the time for support purposes. It can be a little confusing when a new 2.5 feature is mysteriously unavailable in 2.4.1, though. :open_mouth:

  • Uninstalling and reinstalling won’t affect your data, but of course taking additional backups is never a bad idea.

Katherine

Just so you know, the exact same thing happened to me. Going to try a reinstall tonight when I have access to backing up my stuff. In the meantime, no writing that novel (all my notes are in Scrivener). Argh. Very frustrating.

Jangari, many thanks for your help. And, Katherine, thank you also for your post here and your prompt replies to my emails. I did what you both suggested: backed up my projects and a copy of 2.41 (to an external drive); trashed the bad 2.5 version; then downloaded a clean copy of 2.5 from the website.

So far all looks good. I’ll keep the 2.41 copy on file for a while just in case, but I don’t really think I’ll need it.

Thanks again.

John

P.S. kaonevar, all this didn’t take me very long. But be sure to back up every .scriv thing you have, including the 2.41 version. Then update only through a fresh copy of 2.5 from the website via the link that Katherine provided in her post. Don’t use the software update function from the app. Good luck.