Style created via Format is not showing up in Styles

So I tried adding a new style inside the Format panel for the compiler. Strangly though the style doesn’t show up anywhere else. So i can’t use it in the editor.

The other way round i can add a style via style panel which will show up in the format style panel of the compiler. Yet any changes to the color ect. doesnt seem to have any effect on how the style is displayed.

Im new to scrivener but if ind this rather confusing. Maybe im doing something wrong.

First basic question: have you done the interactive tutorial you find under the Help menu. If you haven’t, I strongly recommend you do so, because it will/should help you to understand how Scrivener works.

While if you set up Styles in the Editor, you are able to access them through editing the styles in the compile format pane, any changes you make subsequently either in the editor or compile format will not be reflected in the other. This is what gives Scrivener its flexibility of creating your text in a font etc. that you are comfortable with and yet compile to a standard manuscript format, whether for print, or differently for ePub, etc. So if it really grabs your fancy, you can do your writing using a header in 36pt Comic Sans and have it compile with that header in some appropriate size of TNR Bold. When you go back to the editor, your setting there hasn’t been changed by your style assignment in the compile format.

Although I do have headings set in my editor, the only one I ever access is “Heading 4”. My text is split up into “Chapters”, Sections" and “Subsections” in the binder, with those being allocated appropriate Section Layouts in the compiler which assign the appropriate levels of heading. In point of fact, I could easily split up further to have “Sub-sub-sections” which would work the same way, but I haven’t yet found the need.

Working that way, splitting your text into individual chunks and using the binder hierarchy to allocate section types and then appropriate section layouts means that, in the editor, you might need nothing but the default “No Style” and depending on what your text is, “Block Quote”, “Code markup”—or whatever it’s called—and other non-standard styles in the text, and handle all the Headings in the compiler. Essentially, that’s what I do with the exception of “Heading 4”

Hope that helps. :slight_smile: