2 out of 6 or so IOS files syncing with desktop but no text??

I’ve had Scrivener on my iPad for a few weeks and although initially had issues syncing, figured it out with the helpful file provided here. Have been happily working on the iPad - some documents from my desktop iMac and some newly created in the IOS app.

Finally sync’ed for the first time tonight and 4 or so of the files sync’ed with no issues. The other 2 sync’ed but the text in the IOS files is not showing up in the matching desktop files.

In one instance, one folder in the project with the text DID sync, but the second folder did not. It shows up but there is no text inside. I’ve tried many things including restarting, re-syncing, waiting and trying again, etc.

Any suggestions much appreciated.

Maybe it’s a ghost?

Sometimes, I think they exist in Dropbox, preying on unsuspecting files…

Hi Billie,

Have you been working on this project from both ends without syncing? OR do you mean that you opened the project in ios and worked on existing docs and made some new ones there?

Just to establish a baseline: Everything looks right in the project on ios, but doesn’t when viewed on the mac. You don’t have the project open on both machines. You open on ios and fidget about, then exit the project there and sync. When that is done, you go to your mac. You let Dropbox finish any automatic syncing it wants to do on your mac. Then you open the project in your Dropbox folder there and some of the text docs in the project that should have text are empty. Does that all sound right? The description here is meant to rule out (or bring to light) some ways troubles may develop.

-gr

Yes, that is right, GR.

I moved files from desktop via Dropbox following instructions in the help file and they opened perfectly in IOS. I worked on them there, and created a few NEW files in the IOS version of Scrivener. When I went to sync back with desktop, most of them made it fine. Two did not. Both were files created in IOS - but oddly in one file, I had two folders (I use folders for chapters) and one of the folders sync’ed back to desktop perfectly but the other did not.

A second project file created on IOS in Scrivener also did not sync back.

And when I say did not sync back - I mean specifically that the files appear on my desktop in Scrivener but when you look inside the folders inside the files there is nothing there.

I wasn’t working on the files from both ends - though it is possible I did something out of sequence.

I love having the ability to work from my iPad away from home - but until I can get this fixed so I can be sure that what I do syncs back it’s not going to work very well for me. I do all my compiling for publication from the desktop - so would mainly like to use the iPad for editing existing documents and occasionally creating new ones that I can share back with my iMac.

What version of desktop Scrivener do you have?

Katherine

Other things I can think to ask:

  1. Any chance the sync from ios just didn’t get to complete. Where did this syncing from ios happen? When you got back to home base or while you were out on a cafe’s network or over cellular?

  2. Can you make changes to these same files and get them to sync now? Or are they persistently anomalous?

Desktop has current version of Scrivener.

Sync’ed at home with our WiFi. My iPad doesn’t have cellular activated.

I moved a new file from desktop to iPad and made a change, then sync’ed, and that worked. I’m not sure what is going on with these 2 files.

What is best thing to do next? I did try copying and pasting the missing folder text into a new file on IOS and syncing that - it did the same thing - folder appears to sync but there is nothing inside on the desktop.

Is the text really missing? Sometimes, people find that “missing” text was actually stored in the document synopsis, rather than the body text, or vice-versa.

If that’s not it, please try clearing the Dropbox cache on the iPad, which you can do via the Reset Scrivener button in the Scrivener section of the iOS Settings app.

Katherine

I am looking again closely at your description of the case and I now suspect the following might resolve your issue:

In mac Scriv, when you click in the Binder where you are expecting you should see your text are you clicking on a folder or a text document?

Both folders and documents in Scrivener can contain body text (and both can be containers!). I suspect you have typed your text into the text area of a folder.

When you click in mac Scriv on a text doc, by default Scriv shows you the body text of the doc. But when you click on a folder in the Binder, Scriv by default shows you the objects (docs & folders) the folder contains, not the folder’s own body text.

Thus, if you have typed your text into the text area of a folder, and the folder contains no objects, then when you click on that folder in mac Scriv it will seem that Scriv has lost your text. It hasn’t though. It is just showing you what is in the folder as container, namely nothing.

Look at the icon of the folder that seems to have nothing in it but should. If it looks like a folder with a little text document in front of it, then my hypothsis is right.

Some of the language you have used in describing your case suggests that this might be what is going on.

-gr

Thanks for all suggestions.

GR, I will look further when I get back to desktop later today - but yes, iirc the folder that is not showing any text in the project that has another folder where text DOES appear has a little thing sitting on it which I tried to “fix” to make it like the first folder (plain folder, no little white thing sitting on it) w/o success.

I thought something was situated differently with that folder but clicking on everything I could think to click on still didn’t reveal the text.

Will look at it again and report back.

The icon doesn’t need fixing. It is telling you something!

Click on that trouble folder in mac Scriv. Then look at the three-part Group Mode button on the toolbar. Probably the rightmost (outline view) or middle (corkboard view) button is darkened. Click on whatever is darkened to tell Scrivener that you want to see not the documents inside the folder, but the body text of the folder itself. Now you should be seeing in the Editor area whatever body text might be associated with the folder.

You can select that text and Cut it from there, and then create a new text doc and paste that text in there. Whew!

The ordinary use of folders in Scrivener is to contain text documents and further folders. If you use folders like this, they will behave in the way you are accustomed to. Text goes in text docs, text docs go in folders.

I think what has happened is that while in iOS Scriv you accidentally typed into the body text area of the folder in question – and so stumbled into an advanced feature! In iOS Scrivener, if you click on a folder and look at the top right of the editor pane, there is a button there that either looks like a single sheet doc with writing on it, or looks like an array of four index cards. If you are clicked on a folder, these buttons toggle you between seeing the body text area of the folder and seeing a corkboard representation of the subdocuments inside the folder.

I am betting you clicked on that single-sheet-icon (“Show me the body text!”) button and typed some text – and hence got it lodged into the body text area of the folder.

Best,
gr

Thank you so much, GR.

I will work on the trouble folder today. Have been working on another project this week and have sync’ed back and forth as needed with no issues, so I think you are spot on about why this one folder is giving me trouble.

Another glitch though - the one other project that was not showing up in Mac Scrivener didn’t have this issue - I had not typed any text in the folder but in that project had made notes in the Research folder. They were showing up fine in IOS but not on desktop - now the research folder in the IOS project is empty!

I’m not sure what is going on. I emailed myself the info last week just to be safe so I didn’t lose anything. I am going to completely delete that project and start over with it.