29 crashing on opening docs

Don’t know if this is “the” fix to the problem but I had the same issue with the constant crashing. I read in the release notice that someone who had “read” the readme file first didn’t have the problem. So I uninstalled. Let the readme file open, clicked ok, and now it no longer crashes. (Originally I had skipped the readme file.)

I tried this fix just now; no dice for me. Although it is also notable that even though the Start Scrivener box was checked, Scrivener didn’t open automatically, even after I clicked ok on the readme page. YMMV.

Yeah, I just tried this multiple times too and nothing changed. Scrivener still crashes.

Weird…no problems with crashing, and I actually did read the README this time. :mrgreen:

Tried this as well and Scrivener still crashes. It did launch for me after I closed the readme file.

Win 7 - beta 029

Can someone tell me shortly how to get started without crashing ?
I’ve tried several ways, nothing helps : Scrivener crashes as soon as I open a project.

Now… maybe after a reboot… :question:
If that works, I’ll tell you more…
For the while, I’m a little disappointed…
I wished to use it urgently, I was confident…
It “donged” me “timeout” :mrgreen:
Then I was too happy to see the new release, and have been patient… :unamused:
Now, no way to open anything… :cry:
Maybe :bulb: soon…

Edit :
Ok, reboot is done…
:frowning:
Shall I have to go back to Word now ???

2nd Edit :
Thanks to my hyperlink shortcuts from within Excel… Hooray ! I got one without a crash… Let’s hope this is contageous for the others… :laughing:

Lilith, here’s a way to successfully open a project with 029:

  • open Scrivener, which will then ask you to open a project
  • open the project, and Scrivener 029 will crash, given you are one of us who experiences this
  • after the crash, just open Scrivener again.
  • now your project will be opened automatically, and you can work.

This procedure will work similarly when you create a project and crash, or try to open another project and crash. The next time you open Scrivener itself, it will happily open your last attempt.

Hope this works for you.

Regards,
Clive

Ok, I did what I said I wouldn’t, did ultra-clean reg-clean installs and tests. Plus.

Please note carefully that it is in opening a project, in any condition other than a registry-preset auto-open-on-start, which causes the crash. This should really help narrow the problem down.

Validation: Scrivener 029 crashed on the very first attempt at file open, after install on a registry-free-of-Scrivener.

Restating: It’s not about multiple open files; rather it is about manual (File menu or double-click .scrivx file, doesn’t matter) project open.

Crash events: on Win7 are always, since first install yesterday:
Exception code: 0xc0000005
Fault offset: 0x0006d1c9

Testing and Results:

First phase:

  • deinstalled 029, checked that the Program Files\Scrivener folder was gone. I would have removed it as necessary before if not, but it was gone (this was already a clean 029 install, likely the reason).
  • rebooted and installed 029 after quiescent. Faithfully left the checkboxes set to read Readme and start Scrivener.
  • Read Readme including scrolling down, and waiting for quiescence, then quit the Readme and Scrivener 029 opened.
  • It crashed on first attempt to open an already-present project.

Second phase:

  • deinstalled 029, checked no Program Files\Scrivener folder
  • rebooted, then when quiet, installed 029
  • left checkboxes on Ok, Read Readme, quit it so Scrivener would open
  • told Scrivener to create Tutorial, gave name to save it. Scrivener 029 crashed.
  • opened Scrivener from icon, and Tutorial was there, everything fine including the sound Resource

Third phase:

  • installed the optional Kindle resource from Amazon, in case that was actually needed
  • Started Scrivener, and Tutorial was there
  • Compiled Tutorial to Kindle .mobi, after entering a few required Metadata items
  • opened Tutorial.mobi in Kindle PC, looks quite reasonable throughout, no ToC, cover, or title page. Those can be sorted out later; would count this as working, for a stage of beta.
  • moving around in Tutorial no problems whatsoever, Kindle or Scrivener
  • tried to open another project from File Menu. Scrivener 029 crashed.

Free-of-cost extra phase:

  • Started Scrivener, Tutorial shows fine
  • double-clicked the project.scrivx file in another Project
  • Scrivener 029 crashed

Hoping this helps.

Clive

I am seeing all these crash-on-open-project as being Application and Module both Scrivener.exe, Module being presumably where the program counter offset applies.

I notice that in the other thread, from jravan and duende, the Application is Scrivener.exe, but the Module is QtGui4.dll. Apparently on both 026 and now 029.

I’ve posted a wondering if theirs might be a display driver bug/interaction, especially with the way it arrives out of seemingly little or no screen action, rather than from opening a project.

These do appear to be quite different issues, at least.

Hope you are seeing the posting from me just above this one in your hurry, as it contains some pretty precise testing, information, and further clues about the project opening crashes, at least as observable here.

Regards,
Clive

If you just double-click a project.scrivx within a project folder, only when Scrivener 029 is not running, that will open the project fine, and you can work with it.

This seems 100%, so is another way to use 029 until the fix.

As before, double-clicking a .scrivx when an initial project is open will always crash 029, so you always have to close Scrivener before using this trick.

Regards,
Clive

Confirmed here as well.

I’m running into it under Windows 7.

Either creating a new project or launching a project from the Recent Projects results in a crash. When launching after the crash I end up in the intended document (a blank with the correct name for New Project, and the proper populated document from the Recent Project).

I just installed 29 after uninstalling 26. I followed the default request after installation and allowed the readme to open and Scrivener to run. The project I’d been working on opened properly. I used open command off of the file menu and tried to open another project and Scrivener crashed per what has been previously reported. I’m running Scrivener on XP SP3.

Gina

Hi,

Environment Windows XP Pro fully patched.

I think this might be, in part, a template issue.

With a project already open, creating a new project using the Blank template causes Scrivener to crash. Inspecting the file directory the files and the settings folders are created but nothing else.

With no open project creating a new project with Blank template also causes Scrivener to crash leaving the environment as above.

With an open project creating a new project with the lecture template causes Scrivener to crash but inspecting the file directory shows a full set of files and the project can be launched by clicking on the icon.

Opening a second project causes Scrivener to crash.

That’s all for the moment as I need to go to give a lecture, but I hope its helpful.

Regards
Jeffrey

I am also experiencing the “crash on opening” problem, with an added twist. If I create a new project, Scrivener crashes. However, if I then try to restart Scrivener, it tries to open the new project, but gives me an error message indicating that the “file does not exist.” If I go and find where I put the project, the folders are all there, but there are no project files within them, so I cannot open them from there. Not sure how to work around the problem when none of the workarounds work for me.

J

Are you creating a new project from the “blank” template or from one of the others? Some other people have reported this with the blank, that it isn’t properly creating all the files, but the other templates seem to work. Try using the novel template and see if that project will work–I expect it will crash initially but it should open properly when you restart. (Also you can try setting your preferences, in Tools>Options… under the General tab, to not have Scrivener reopen recently opened projects on launch; this way you should be able to launch Scrivener and then choose which project you want to open without having to deal with a crash first. Just make sure you always have only one project open at a time.)

Thanks, Jennifer. I have been using the blank template exclusively; switching to a different one has allowed me to use the workarounds for the initial crash.

Jay

Scrivener crashes also if you close a project and then open one via the recent projects menu in the start/new project panel.

Error log

Faulting application Scrivener.exe, version 0.0.0.0, time stamp 0x4e4746db, faulting module Scrivener.exe, version 0.0.0.0, time stamp 0x4e4746db, exception code 0xc0000005, fault offset 0x0006d1c9, process id 0x1288, application start time 0x01cc5ddb8f49269e.

Wow. I haven’t seen any of these problems at all. No crashes, no refusal to open, no refusal to create, multiple opens of multiple documents works fine… everything is working swimmingly for me. Windows (Windows 7 Pro) and Linux (Ubuntu 10.04 LTS) the same. Some random uninitialized thing? Crikey, I’m glad I don’t do software any more…!

Good luck to you, Lee & team!

I had this problem intermittently at first with the 029 release, but did not come here until I could reproduce the crash every time. Here is the methodology for the crash on my system.

Scrivener beta 029
Windows 7 Ultimate x64

Open Scrivener
while project is active, open another project from “Recent Projects”

The crash comes based on this variable:

If the project I have chosen to open resides on the same HDD as the original project loaded on startup, I cannot cause this crash. If the project I have chosen resides on any other HDD or flash drive, it will cause the crash every single time.

I did not know if this had been fully addressed, I just thought I would throw in my experience. Like I said, I can reproduce this over and over again without fail.

FM

I just installed on my Windows XP netbook after uninstalling beta 26 and there’s no issue at all but my Windows 7 is still having the issue. :-\