3415: NOT FIXED: eBook ToC is using the project name for every ToC item [#3415]

This bug is still present. Beta 14, just now. Epub2.

This has been fixed in the ePub3 compile format. Please, prefer using ePub3 over ePub2. ePub2 will be removed in some of the following releases and only ePub3 will be left listed as ePub only. Still, thanks for pointing out that ePub2 still has this issue.

Indeed this problem is most likely caused, if you compile your documents As-Is. Using Structure based section should work in ePub2 too.

No, it hasn’t.
Compiling in epub3 gives me one item only in the ToC - still with the name of the project.
epub2 at least gives the list that I I can edit in calibre afterwards

btw: what does that mean - structure-based? Anyway I can’t switch to structure-based inthe compileer windows - doesn’t accept it.

May I suggest reading the tutorial section about section types and compiling the draft? This is not always obvious, even if you’ve been using Scrivener for years.

In particular, the piece about Assigning Section Layouts is quite useful. Some of it is incorrect in specifics (there is no “Part Title” section layout, for example; it’s “Part Title Page”, at least in the layouts I have in Compile).

You may. :wink: I tried. But I’m rather lost in that part of the tutorial.
I’d hoped someone here had a more comprehensible explanation for me.

I got lost a couple times there, too, and started over again. But once I made the structure of the project follow the pattern prescribed, epub3 ToC’s worked. I’m a bit disappointed with that design decision. However.

But having just done that, I’ll try. It may be clear as mud.

“Structure-based: Tells Scrivener that the current document should use the default section type based on its indentation in the binder”

Your documents may already have a section type of Structure-based; it seems to be the default. In the Binder, right-click → section type, to see. In the inspector, General Metadata, section type. If the text in the “Section Type” drop-down in the inspector is GREY, you can click the dropdown arrow and see that “Structure-based” is checked.

However, if you don’t tell Scrivener how you want them organized, it has no clue.

Scrivener’s current “Structure-based Project Settings” assumes you have Parts, Chapters, and Sections, or their equivalents. Currently, I don’t really have Chapters; I have Parts and Scenes, which I’ve got Scrivener set to work with as Groups and Text (Chapters and Text). And it doesn’t really matter what they’re named. You’ve got folders and documents. You can even make this work if you have a long string of scenes in your Manuscript, with no folders at all (and some very established authors write that way).

Projects → Project Settings. Select the Section Types tab.

Compile expects section types of Part, Chapter, and Section. I suggest following Compile’s wishes.

Here’s a screenshot from the Tutorial Project Settings, after adjustment.

You may not have two levels of folders in your project. Don’t sweat this; it doesn’t matter. I have projects that only have Chapters and Sections.

In Project Settings, select the Default Types by Structure tab.

If you have just Chapters and Text (one folder level), you should see three lines:

  • all folders (assigned to Chapter)
  • all file groups (assigned to Section)
  • all files (assigned to Section)

If you have Parts, Chapters, and Text, you should see 5 lines:

  • Root folder (assigned to Part)
  • Level 1 folders (assigned to Part)
  • level 2 folders and deeper (assigned to Chapter)
  • all file groups (assigned to Section)
  • all files (assigned to Section)

(the section type names will vary if you chose different ones)

If that’s all squared away (and once you’ve chosen “structure-based”, it should be that way automatically), then click Compile.

In this case, Compile for Ebook3.
On the left of the dialog box, select Ebook. I duplicated and edited format, saved to “my formats”. This created Ebook Copy. This made a copy of the default I can adjust with impunity; if I screw things up royally, I’ll just delete it and make a new copy. So I worked with Ebook Copy, in My Layouts.

At the bottom of the dialog box, click on Assign Section Layouts.
At the bottom of that dialog box, click “Show unused section types”.

On the left side of the box lists section types. The right side lists layouts.
If you have “Part” as a section type, click that. On the RIGHT side, I suggest clicking “Part Title Page.”
Click on Chapter, and then click on “Chapter Title”. Or if your chapter folders have text, click “Chapter with Title”.
Click on Section, and then click on “Section Text” or perhaps “Section with Title.”

I hope that’s almost as clear as mud?

Now compile, and see if your chapter titles make it into your ebook.

This was actually very clear and informative. Thanks!

Thanks. Important question: did you get it to work that way?