A blank line in script mode?

Is there a simple way to put a blank line when typing in script mode.

I’m using highland to format my script and I love just typing. However, I’d really like to use the script mode to remember my character names and also to automatically put things into capitals for me.

The only thing that’s driving me crazy is that I can’t put in a blank line in between character and dialogue. (I know you can format it to put a double space - but highland won’t work with that).

I’ve worked out that you can press CONTROL-RETURN - but that’s laborious when you have to do it so often…


I’m a bit confused, isn’t Highland a basic plain-text editor designed for working with the Fountain markup format? And isn’t the Fountain format all about adherence to the screenplay format, which doesn’t put a space between a character’s name and their dialogue? I am not seeing the relationship between it and Scrivener’s rich text formatting, I guess, or what you are using to write with.

Anyway, inserting actual empty lines into a script is very rarely done, which is why there is no straightforward way of doing so. You’ve found one of the shortcuts for Edit/Insert/Line Break, do you really line feeds in your script though? You aren’t making an empty line when you use the Ctrl-Return shortcut, you are inserting a visual break in the paragraph line.

Does the line need to be empty? Maybe Space, Return is good enough if not.


That post explains it way better than I can.

Basically I’m just writing in scrivener as a plain text editor and writing in fountain format. I prefer this because I can send files from scrivener to any other devices and continue to edit them in this plain text form. I only convert them right at the end.

Thanks, that’s helpful, and I better understand what you are going for. I didn’t see any examples where the character name is separated from the dialogue by an empty line—but is that the point? Or was that just an example of how trying to use a rich text scriptwriting mode to type in a plain-text file is a bit awkward?

I would agree with that, the scriptwriting mode certainly isn’t designed to be used like a plain-text editor in any fashion, it’s modelled more after Final Draft, CeltX and other dedicated scriptwriting programs where you type into a formatted document and that formatting is driven by underlying element-based rules.

Hmm, another thing to consider is that Scrivener’s scriptwriting feature, owing to its design as a formatting system for rich text, can be toggled on and off for a document at will with no loss of scriptwriting information (so long as you don’t mess around with the formatting of existing text naturally). You can use it for the bulk of your writing, with the benefit of auto-caps and adding names to the lists, etc., but when you need to do some “plain-text” stuff, just hit Cmd–8, do it, then switch back.

Another approach, since you aren’t using scriptwriting to produce scripts out of Scrivener (rather, to produce a plain-text Fountain formatted file) is to use the plain-text compile method and in the Transformations pane, enable the option to convert whitespace to literal plain-text spacing. That way, you can visually offset your character line from the dialogue as you already tried, but now in a way that actually generates a space. Obviously, that binds you to the compile feature as copy and paste won’t run that transformation though, that’s the downside.