A bunch of different "how to" or "can I...&qu

Just downloaded the application yesterday, and I ran through the tutorial, but I still have a few questions that I didn’t see in the forums (or maybe I missed them).

  1. is there a tool that lends itself to organizing a timeline? That is, to keep track of the chronology of the main piece.

  2. this may fall under the heading of “can’t do it here; that’s final formatting” but… I’ve imported a document I’d been working on in Word, largely successfully. In addition to chapter divisions, I had put in what you might call gaps. Lacunae. That is, a slight jump in continuity. To do so, I’d added four asterisks, a space apart from each other, and centered on the page. I’d added this to Word’s autocomplete function, so that if I simply typed four asterisks, it would automatically switch that over to the “gap” version: add the spaces and center it. Any way to duplicate that here?

  3. Autocomplete doesn’t. I’ve added items, but nothing happens as I start to type those words. Cmd-period or opt-Escape don’t bring it up either. Am I missing something obvious?

thanks

There is no pre-built tool within Scrivener to accomplish this. Have a look in the “Software by Others” board in this forum. There have been a few threads recommending various software to do this easily.

You are right in assuming there is no way to do that in the manner that you are describing. However, the way in which you are describing scenes is the type of thing one must do when working in a linear editor. Scrivener is designed to be a very accomplished non-linear editor. In other words, scene breaks are best handled as sequences of sub-documents in the Binder. For example, when you are ready to switch to a new scene, simple press Cmd-N. The focus will switch to the Binder, create a new document beneath the current one, and let you type in a name for the scene. To jump back to the editor without using the mouse, you can press Cmd-Opt-Shift-L.

So a chapter fashioned in this method might look like a folder (though it could be a document with sub-documents), filled with a half-dozen scene documents inside of it. Each of these is self-contained. If you ever wish to view the chapter as you would in a word processor, you can select that chapter in the Binder, and press Cmd-Opt-1 to create an “Edit Scrivenings” session based on your current Binder selection. The editor will now display every sub-document one after the other, as if it were one file. You can edit each of them in this form, and when you disband the session, these edits will all be retained in the individual sub-documents they belong to.

There are many benefits to working this way, as each scene becomes an index card which can be viewed and re-ordered in the sequence of your book with ease. It is best practice to break things down as far as you can before Edit Scrivenings becomes annoying to invoke. If you are having to invoke it to do most of your work – things are probably broken down too far. But if you never access it and find yourself scrolling through long documents looking for a section, you might want to consider using the Split function to break that document down a bit into something more manageable.

It is definitely a different way of thinking about your book, from a software point of view, but it is quite natural in any other context, so after a short adjustment period you should easily find a pattern of working which jives best with you.

Not sure if this is what you are looking for, but try just all by itself. This accesses OS X’s built-in auto-complete function.

There isn’t, and from what I’ve heard there isn’t going to be. There are a few different timeliner apps out there; I’ve just started evaluating Bee Docs’ Timeline and watching what’s posted about that program’s version 2, but I haven’t yet settled on a program that suits me yet. The one I liked the most so far was TimeLiner 1.1 eMate, which is educational software (and now up to a much higher version).

That sounds like a scene break to me. I’d actually start a new file for a new scene, and keep both scenes inside a chapter folder. You can specify on export what character separates scenes from each other, then when you export the draft, they’ll be inserted for you.

Just tap escape, no option keys, and the list pops up.

Thanks for the replies; I’ll experiment with the suggestions.

However, AutoComplete still doesn’t function. It works just fine in Text Edit, but the same steps (using either Esc or F5) do nothing in Scrivener.

Odd, because I tested it before posting - I typed a couple of letters and pressed ; a nice little list popped up.

Have you changed any of your keyboard shortcuts, or anything like that?

For what it is worth, I have not been able to get the [Auto-]Complete function to work either. I can add items to the Auto-Complete list for the project, but have not been able to get the Edit>Complete (opt-Esc) function to actually complete anything. It sounds like Scott is seeing the same phenomenon.

I have checked my Keyboard Shortcut prefs and my QuickKeys shortcuts, and none of them override these key commands (and they work fine for me in Textedit). Scrivener Help says cmd-period should also invoke the Complete function, but I have had no luck with this either.

(Of potential diagnostic interest: I notice that if I hold the fn modifier key as well as option and hit Esc, I can see the Edit menu toggle, but still nothing happens, and switching my F1-F12 preference in Sys Prefs>Keyboard does not help.)

I’m not a natural auto-completer, so I did not worry about it much, but just wanted to say that I can corroborate Scott’s experience with this function. [I am using a Powerbook G4 with up-to-date Tiger and Scriv 1.01.]

–Greg

I can also confirm this. If it’s pilot error, I’m making the same mistake.

Your insight is appreciated.

Very curious. Like Janra, I tested it before I made my response, too. Given your description, Greg, it sounds as though it is trying to invoke it, but failing. I cannot think of anything else that would be triggered in the Edit menu when pressing fn-. I did notice one thing while I was there, the keyboard shortcut is actually Option-; yet it works when only pressing by itself for me – as well as Ctrl, Option, Cmd, Shift – no matter what I press in conjunction with it works. This is also true in TextEdit. I also noticed that no matter which combination (or no combination) I used, the Edit menu never flickered. I am using a standard keyboard, though.

Have you tried manually setting the keyboard shortcut to something else entirely, and seeing if it works at all?

I am not sure how I would do this, since I do not find this keyboard function listed in System Preferences>Keyboard>Keyboard Shortcuts. (Perhaps this is a clue. Do you find it on your system shortcut list?)

But I think this cannot be a key command issue anyway. For two reasons: 1) both keyboard commands (and more) work in TextEdit (opt- and cmd-, and even , as you noted). 2) Picking Complete off the Edit menu after typing a partial word does not work either.

Best,
Greg

BTW, it is fn-opt- that makes the Edit menu visually toggle–in case this matters.

Before experimenting with changing the shortcut, does using the menu item (in Edit) manually, work at all? If not, then there is definitely some bug. Well there is probably a bug anyway since it works elsewhere but not in Scrivener; but changing the shortcut probably would not fix it if using the menu does not work.

You can add a new keyboard shortcut that does not already exist by manually typing in the name of the menu command. So in this case, you would click the ‘+’ button, choose Scrivener as the application, enter “Complete” into the the Menu Title field, and then assign some shortcut that does not require the key. Try Cmd-Shift-8. Restart Scrivener, and check the Edit menu. It should have the new shortcut assigned.

Complete works fine in TextEdit, non-functional in Scrivener.

What system are you running? There has to be a common thread.

I am using a PowerMac Dual G5 with a standard 109-key keyboard.

Maybe that’s it – Greg and I seem to both be using

Sorry to disappoint, but it works (using either control-escape or option-escape) on both my PB G4 12", Tiger & Scriv 1.01 and my Intel 24inch Imac (same setup)

Does it perhaps require assistive devices be turned on?

E

Scrivener does nothing special to auto-complete - it overrides nothing and just relies on the standard OS X text system. Moreover, it works fine on my MacBook Pro, my MacBook, my iBook G4 1GhZ, and my MacMini, so I have no idea why it would not be working elsewhere.
All the best,
Keith

I have found a resolution for the problem on my machine which suggests that: The auto-complete feature was not working b/c the Scrivener app was located inside a folder inside the Application folder.

Moving the app so as to a be direct child of the Application folder fixed the problem. I was tipped off when I went to Sys Prefs to make a new kbd shortcut for the Complete function and noticed that Scrivener was not listed on the list of apps to specify.

Best,
Greg

[UPDATE: I was misled by sloppy testing here. See my considered view on this: http://www.literatureandlatte.com/forum/viewtopic.php?p=8676#8676]

I was having problems on a Dual 2 GHz G5 running 10.4.8, but I had a number of other utilities (QuicKeys, TypeIt4Me) and wondered if they were the root.

Apparently not. Tried it on my PowerBook G4 (with 10.4.8 and a pretty bare system) and had the exact same problem. Auto-complete works in Text Edit but not Scrivener. Fn-Option-Esc also causes the Edit menu to flash, though nothing else (having the “Use the F1-F12 keys to control software features” checked make no difference).

Works as intended on my iBook 12" 1.25 ghz, running 4.0.6 and Scr. 1.01. Don’t use 4.0.8 because it caused sleep problems on my iBook (Apple knows about this issue). But I don’t think that makes a difference since it seems pretty evenly split on who this works for and who is having problems, and all seem to be using 4.0.8.

Also, same experience for me as with Amber—I can hit Escape alone or with option, etc, and get the auto complete menu.

I thought of assistive devices earlier, and gave it a try, but it worked just fine whether or not it was toggled on.

It sounds like Greg has the answer up above, so if you are down this far in the thread and missed it, scroll up and give that a try.

My Scriv is in a folder within my Aps folder and Autocomplete works as advertised (though it does not appear in the apps to mod drop down, as per Greg’s observation). Must be something else.

Tim