A few things...

Hi,
Here a list a few things I noted:

  • Capitals are automatic after ! or ? But in dialogs (in French, I don’t know in English) you don’t use capital after this punctuation. So it’s just a bit annoying to have to remove the capital every time…
    Exemple :

  • Hello Charles ! said John.

  • Would it be possible to create shortcuts for specials characters? Indeed, to put a À we’re obliged to do ALT+0192, etc. etc. Not a big issue but in French it’s really repetitive (because we have a lot ^^)

  • I noticed I a problem of different font on accents after compiling my novel in docx (see the screenshot below). That is not systematic :

Thanks !

Having to do ALT+0192 is also a problem in English for those of us with laptops without a numpad. ALT+0192 on the number row doesn’t behave the same as on the numpad. Therefore, I don’t know how to do cafe, though perhaps I could get around it with key mappings.

I don’t think that’s so much a problem with Scrivener as it is with you using an English keyboard.

You can set up substitutions for accents if you want; these will work in the main text and in notes but not in plain-text fields like titles and synopses. Your better bet is just to add the French language layout or an international keyboard layout to your Windows keyboard settings so that you can type these more easily, e.g. '+e would become é. Switching between layouts or language, once you’ve enabled them, is simple with a keyboard shortcut or via the keyboard icon in the task bar, so even if you don’t want it on constantly it’s not a big deal to flip in and out.

There are also third-party applications for macros or text-expanders that will let you set up a substitution that you can use across other programs, so that may be another option for you; some folks around here will have suggestions of their favorites.

You can turn off the auto-capitalization under the “Auto-Correction” tab of Tools > Options.

And finally, the bug with the letters coming in the wrong font in Word (it’s mostly Word that’s displaying them this way) is under investigation. For now you’ll just need to do a select-all and reset the font in Word after you open the document.

Thank you for your answer. For the auto-capitalization (if I turn it off) that will be a bit worse because that won’t be automatic anymore at the beginning of normal sentence. And there is more than dialogs ^^

Thanks for the tip for the bug with letters: I thought I was obliged to indicate the font size when I reselect the original font - and that would destroy all my work ! :wink:

To finish, I completely forgot I could edit substitutions… Good!

I use AutoHotkey and PhraseExpress, both free for private use and can highly recommend both of them. However, you will have to invest some time (especially with ahk) to get the results you are aiming for.