A return being added at end of text files

I just went through 110 scenes deleting the return at the end of the text (a blank line). When I reopened the file about half the returns (blank lines) were there again. I can not figure out the rhyme or reason, but about half of my scenes this last return is deleted permanently, and the other half keep coming back. Why would this be happening?

I am not sure what the deal is with the empty lines coming back, but there is an easily solution for not having to worry about this kind of problem at all, in the first place. In the Transformations compile option pane, check off the “Remove trailing whitespace from documents” option.

As for the problem itself, can you think of any particular routine you followed for a good number of them? I’m assuming for 110 items, you probably had some kind of repeated efficient sequence of commands for switching from one document to the next, deleting the line and so on, so maybe something in there, if done rapidly and frequently enough, caused auto-save to fail to trigger or something.

Oh I just love finding new features!!! Will check that in compile.

As for repeated process, I wish I had…but no. I simply went text file to text file in the Binder and deleted the last blank line…only to see most of them there again the next time I opened the file. Really doing nothing fancy, just put cursor at the end of blank and deleted until cursor was adjacent to last character.

The only thing I can think of that might have introduced something is that I created my own format preset “Manuscript Format” that sets margins at .5 & 6.5; removes all tabs; puts indent on first line of paragraph at 1; Times New Roman; 12 pt; and double spaced. I did this because I like to view the document while I am working in the same format in which I will print. I did not begin writing the manuscript with this preset and I have gone back to apply it to the scenes whenever I revise an older scene I have written (not all at one time–and I do not recall when I applied the preset to what scenes when). Perhaps there is some correlation between if the scene was written in another preset and changed to which scenes keep showing this white space? Is that possible? Might my preset be adding a line of white space? I don’t see how or why…but it’s a thought.

That should all make no difference, with one potential exception. The main reason this would make no difference is that carriage returns are “physical” characters, actually no different than the letter G or p in your document. They just so happen to be a character that instructs text editors to wrap the line. So changing the formatting of a document, where the line wraps, how much space is in between them and similar, will not impact carriage returns any more than changing the indent would delete or add alphabetic characters to your document.

Now, the one exception to that is an oddity with how some text layout engines work, where if a paragraph has no tab stops (a form of formatting) left where the tab occurs, then tabs (another “physical” character just like carriage returns) can cause the line to prematurely wrap, making it look like a carriage return to the naked eye. Since you mention removing tab stops, that is the first thing I would suggest looking for. Use the Format/Options/Show Invisibles menu command, and examine your documents, particularly near the end of the file. Do you see any blue arrows in the text? If so, those are tabs, and without any tab stops they will advance the line. While you’re at it, you can also check for pilcrow symbols to see where the returns really are.

I’m not entirely convinced that is the problem, because they should have been deleted just like carriage returns. I.e. if you backspace out invisible tab characters that were acting like returns, that should be no different than backspacing out letters in your text—they absolutely should not return, and if they did that would be a bit alarming. So I’m not sure—but it’s worth a check since that is one thing that can cause formatting to seemingly insert line breaks.

One last thing: you mention preferring to work in the final look of the document, have you tried Page View, or at the very least, enabled Fixed Width editor in the Editor preferences tab (by default it only displays)? That’s usually going to be better than messing with the right-indent settings. It doesn’t matter a whole lot if you use the compiler to clean up the text formatting, however. It can be a nuisance if you don’t, because Scrivener’s ruler doesn’t take page margins into account—6.5“ is very likely more like a 7.5” indent, which is of course nearly way outside of where you’d want the text to actually be. Again, nothing to worry about if you override formatting though.

Thanks for the lengthy response. I looked at invisibles and there is definitely a difference between the scenes/text files with white space at the end those that do not. The whist spaced scenes are enclosed in blue line (a box) and there is a paragraph symbol at the end of the text inside that box that will not delete. The other scenes do not have that feature.

As for the margins, it was my understanding that 0 on scrivener ruler is effectively 1 on the page since the margins are not documented in the ruler. Wouldn’t that mean that for an 8.5 inch page with one inch margins you would want your Scrivener text margins at 0 and 6.5?

Here is a picture of box and end of scene.

Ah ha, try right-clicking in the areas surrounded by a blue box and select “Remove Table”. You must have pasted in some text within a table at some point, maybe from a web browser or another word processor.

Let’s see, with the margins I think you’re right. Setting an indent at that point wouldn’t conflict with the page margin, my mistake!

Mystery solved!!! Thanks. The strange thing is that now I am looking through whole manuscript and about half the scenes have 5-10 tables in them. This is all in the manuscript where I did not cut and paste anything from internet. These were just Scrivenings started with the plus (new text) button. Could a preset format or default format I have created be adding tables?

The only place I cut and paste from the internet is the Research area of the Binder outside the manuscript–and then I typically print a web page as a PDF and then import it that way so that it is just an image and not html.

Hey, since we are talking, there is one other nit. I drag the markers on the ruler so that left margin is set at 0, right margin at 6.5, and first line indent is at .5 and I have “applied” this to my preset format “manuscript”, but if I go under Formatting>Text>Tabs and Indents it reads left margin at -.01, right margin at 6.49, and first line indent at .5. Which is correct–the ruler or that tabs and indents summary window? Which should I use to set the preset format? Thanks.

Adding on to the last post above of mine…I just discovered how the tables are appearing. If I “select all” within a scene and then apply my preset “manuscript format”, it boxes the entire text file in a table. Is this a select all bug or is there something in my preset formatting? I’ve looked through my preferences and can’t see how and why this is so. Thanks.

Looking forward to your thoughts on this and margins inconstancy.

Yes, table settings will be saved with a preset if they are created from a range of text that is in a table (so you can save table layouts easily). So it seems that is what happened, and then whenever you used that preset it wrapped the text in a borderless table. I’m not sure how it got that way to begin with, but perhaps you started writing with the manuscript cover page document, which does have an invisible table in it to keep the word count token on the right with the contact info on the left.

On the indent settings drift: is this is a consistent result for you? If you apply settings via the ruler again and make a new preset, do you get that result every time? I’m guessing you won’t, because I think it’s just a precision problem—the ruler is very precise, and the slightest amount of mouse movement can cause it to drift when you let go of the button or something. If you need precision in the text editor, it is best to just use the Tabs and Indents palette.

I rebuilt the preset and deleted the old one–I don’t know how table got in there, but it’s gone now! :smiley:

Yes, the indent setting is consistent result and it is always off by .01. It is not a sensitivity issue––I am super careful and exact. Here is snapshot of “tab and indent” and the ruler at the exact same moment.

Screen Shot 2014-09-19 at 4.43.22 PM.png

tabs and indents setting

Set manual tab.png

I don’t even know how you got the thing to drag over into the negatives :confused:. that shouldn’t be possible. Does this happen in a test project? Maybe open the tutorial, or create a quick “Blank” test project and see if you can drag the left-indent marker out beyond 0.

What’s interesting is that I didn’t drag it into the negative. That’s where it is put when I manually enter 0 in the tabs and indents left margin field.

I opened a test file blank template and the text file was perfect–ruler and tabs and indents in agreement. But when I applied presets (not just mine, but Scrivener defaults) the ruler and the manual selection did not match. I can’t quite figure out the pattern. It looks like if I move the ruler, the tabs and indents settings will reflect the change–but if I manually enter the settings the ruler doesn’t move–or in stye case of my preset it moves but it is .01 off.

I think I am going to trust the ruler over the manual setting–that seems more stable, I just don’t know if it is actually “true”.

To expand. I just set the ruler manually sliding tabs and margins and then redefined my “manuscript” preset. Now if I select text and apply that preset, the tabs and margins are all correct. Problem solved, right?

Nope, if I open the tabs and indents formatting window they do not match what the ruler says. And again off by .01.

Again, no problem, right? I’ll just select the text I want to format and apply the “manuscript” preset and it will be applied correctly, who cares if the tabs and indents dialogue shows it .01 off.

Nope, because each new text file I create is now starting off at -0.1, .49, and 6.49 even though in the Preferences I have selected 0, .5, and 6.5 as my “main text style”. So each new Scrivening starts off with a wonky ruler and I have to remember to select all and apply my manuscript preset to it. How has this miscalculation gotten in there–any idea how to identify or fix the .01 culprit?

Unfortunately I have no clue, I have never heard of an issue like this before. Out of curiosity do you use the editor zoom feature at all? That can sometimes cause weird problems—though I’ve never heard of it doing anything like this.

At any rate, the way I would test this, since you are getting conflicting information from Scrivener, is to compile and open the output in your word processor. If the rulers are fine there, then I wouldn’t worry about—it’s probably just some weird display bug.

It does seem that changing the zoom percentages makes the ruler markers skip around. I work with Editor at 150%.

Thanks for all the attention.

Thanks, playing with zoom settings allowed me to reproduce the condition. Unfortunately, given that, we probably can’t fix it, as the ruler is a thing that comes with the text editor—it’s all kind of behind a “code wall”, you use it as it is, or you don’t :confused: . But I’ll put it on the list to look at.

Interesting. Given that, I have been trusting ruler over the “tabs and indents” manual setting. Which would you trust?

Again, I’d trust whatever works when you compile and it comes out correct in your word processor. If either seems to work, despite the display glitch, then just try to ignore that aspect.