accessing backups

This may be complicated, because I am running Scrivener for Windows in a Virtual Box on my Linuix machine; but I don’t see how it should be any different from working on an actual Windows machine.

When I opened my Scrivener project today, one of the files (the chapter/section I have been working on for the last several weeks, approx 3000 words). Was gone. Just blank. I tried to access the backup, which is cross-platform available on Dropbox: I found the correct files, unzipped, and tried to open the last backup (which includes the missing text, I could see this from Preview which has the first few lines of every section). But it would not open. I get the message that the file cannot be accessed. I have tried to access the backup on the Mac as well (I have purchased Scrivener on both platforms) but that still does not work.
Is there any way I can just recover my text for this one section?

shaviro, there should be.

It’s part of the ‘no matter what’ safety strategy in Scrivener, that your text, notes, etc. are kept in universal .rtf format, directly on disk. So you can open the rtf of your missing text, and copy it in, or may well be able to just import it into a fresh project via Scrivener.

To find the files in the project, open it, then the Filed folder you see, then the Data folder that then appears. In there, you’ll find a series of folders with long alphanumeric names, and materials for a given document of your project will be in each one.

Now, the problem that you have shouildn’t have happened, of course. VM managers are notorious for having problems depending on how your files are actually being accessed. As part of the Windows VM in your case should be ok, but for that to seem to open files that are actually on the Linux filesystem, could be an area of problems. I think we’re more used to that happening on Linux VMs hosted on Windows, but perhaps similar issues can come going the other way.

And VirtualBox is indeed one that’s had the problems, longterm…

I wouldn’t try to advise here exactly, but an excellent VM manager at least in my experience is available free for personal use, and on Linux. It’s here:

You can read the fine print to see that free use is intentional, and the way you get it is just to install, then not enter a license on the last page of that, where it asks if you want to. I’ve been using it so for years, through the regular updates that keep it well matched to platforms as they evolve.

You probably know the alternative, that there are persons here running via Wine under Linux, but I would feel the Windows VM route should be preferable – unless :slight_smile: . I don’t think we expected your problems…

Best fortune, and fingers crossed you get everything back, and then a reliable situation…