Add front matter option greyed-out


I’ve been using Scrivener with MMD–>Latex to write course outlines for university courses. I’ve done one and it worked really well. I was using a meta-data document.

I’ve started to work on another course outline. It has a lot of shared material (plagiarism policy etc), so it makes sense to put this in the same project and have a different set of compile options. I copied the folder with the meta-data document in it, on the model of the Scrivener manual (as I remember it). I then changed the ‘Add front matter’ option to the new meta-data folder.

That much seemed to work, but it compiled with no meta-data at all, and the ‘Add front matter’ options are all greyed out so I can’t make any changes.

Any ideas what I’m doing wrong?

Many thanks

Front Matter, as a feature, is not always available depending on your Contents selection. If you’ve chosen only a portion of the Draft folder, it will be disabled (as the most common usage of this capability is to compile a single chapter for proofing, and you wouldn’t want the title page, preface and all that coming along for the ride). But you can tell the compiler that your partial Draft selection is in fact the entire output, in the drop-down menu to the right of where you chose the sub-folder. Change that so Treat compile group as entire draft is enabled. That will bring back the front matter checkbox, and the meta-data file.

Thanks, Amber, that’s solved it!