Add Snapshot hangs Scrivener

OS X 10.7.4
Scrivener v.2.2 (15858)

This seems to reproduce the problem reported in this section by cwoac on Wed April 18 2012 (“hang on add snapshot”). When I click the button to add a snapshot, the button itself remains highlighted and Scrivener hangs. If I switch to another application, then switch back, Scrivener is invisible apart from the top menu bar. I have no option except to Force Quit.

Scrivener’s console.log file is empty.

Hi,

I was never able to reproduce this, I’m afraid. Two things:

  1. Have you tried the latest beta, just in case that cures it?

https://forum.literatureandlatte.com/t/scrivener-2-x-update-betas-download-here/11262/1

  1. If not, could you please zip up and send the affected project to us for testing at mac.support AT literatureandlatte DOT com?

Thanks!

All the best,
Keith

The hang occurs on any project – even a new one, created from your Novel template.

When I synchronise through Dropbox and open the projects on another machine – an Air, running OS X 10.6.8; still Scrivener 2.2 (15858), I can take a Snapshot without any embarrassment.

So there doesn’t seem to be anything untoward with the projects themselves…

Downloaded the beta. When I tried to overwrite the existing version of Scrivener, I got a message:
The operation can’t be completed because the item “ScrivenerMetaDataImporter” is in use.

Foolishly, perhaps, I restarted the machine; but when I attempted to open my existing version, I got a Problem Report with a request to check with the developer to make sure that Scrivener works with this version of Mac OS X…

And the following report to send to Apple:

Process: Scrivener [258]
Path: /Applications/Scrivener.app/Contents/MacOS/Scrivener
Identifier: Scrivener
Version: ??? (???)
Code Type: X86 (Native)
Parent Process: launchd [147]

Date/Time: 2012-06-22 16:51:07.157 +0100
OS Version: Mac OS X 10.7.4 (11E53)
Report Version: 9

Interval Since Last Report: 241022 sec
Crashes Since Last Report: 1
Per-App Crashes Since Last Report: 1
Anonymous UUID: ECCF8826-AD0D-4946-9C8E-37A73E2FA34C

Crashed Thread: 0

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Library not loaded: @executable_path/…/Frameworks/Sparkle.framework/Versions/A/Sparkle
Referenced from: /Applications/Scrivener.app/Contents/MacOS/Scrivener
Reason: image not found

Binary Images:
0x1000 - 0x2cfff7 +Scrivener (??? - ???) <1485446E-C0D8-A356-3B01-6DE5FDDE5A72> /Applications/Scrivener.app/Contents/MacOS/Scrivener
0x8fe7b000 - 0x8feadaa7 dyld (195.6 - ???) <3A866A34-4CDD-35A4-B26E-F145B05F3644> /usr/lib/dyld

Model: MacBookPro8,2, BootROM MBP81.0047.B27, 4 processors, Intel Core i7, 2.4 GHz, 8 GB, SMC 1.69f3
Graphics: AMD Radeon HD 6770M, AMD Radeon HD 6770M, PCIe, 1024 MB
Graphics: Intel HD Graphics 3000, Intel HD Graphics 3000, Built-In, 512 MB
Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1333 MHz, 0x0198, 0x393930353432382D3035312E4130304C4620
Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1333 MHz, 0x0198, 0x393930353432382D3035312E4130304C4620
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xD6), Broadcom BCM43xx 1.0 (5.106.198.4.20)
Bluetooth: Version 4.0.5f11, 2 service, 18 devices, 1 incoming serial ports
Network Service: AirPort, AirPort, en1
Serial ATA Device: TOSHIBA MK7559GSXF, 750.16 GB
Serial ATA Device: MATSHITADVD-R UJ-8A8
USB Device: FaceTime HD Camera (Built-in), apple_vendor_id, 0x8509, 0xfa200000 / 3
USB Device: hub_device, 0x0424 (SMSC), 0x2513, 0xfa100000 / 2
USB Device: BRCM2070 Hub, 0x0a5c (Broadcom Corp.), 0x4500, 0xfa110000 / 5
USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x821a, 0xfa113000 / 6
USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0253, 0xfa120000 / 4
USB Device: hub_device, 0x0424 (SMSC), 0x2513, 0xfd100000 / 2
USB Device: IR Receiver, apple_vendor_id, 0x8242, 0xfd110000 / 3

On the off-chance that it might add further murk… I restarted again in Safe mode and Scrivener wasn’t unimpressed. It is clearly embarrassed, however, and has tried to conceal its identity by dressing itself in a new icon:

Screen Shot 2012-06-22 at 17.27.54.png

I find that happens with a number of apps in beta mode, and apps installed when in safe mode. Running the app then transforms the icon into the proper one.

Mark

Edit: Afterthought — if you’re using Lion, to avoid this “x is still running” situation occurring when you restart your computer in such situations, turn of “Reload apps on restarting” or whatever it says on the Shutdown alert. I have it turned off full-time anyway.

It’s probably best to just move the current version to the Trash and replace it with a freshly unzipped copy of the beta. The “this thing is open” OS X issue can often be resolved by trashing the item that is being stubborn, because trashing it doesn’t destroy it, only moves it. That frees up the original location for you to drag the replacement item in.

Okay, that got me back in. So now running version 2.2.0.5 (18217).

The Add Snapshot bug persists on the original machine (Scrivener just hangs), so the Beta doesn’t fix it. It does, however, look Lion-specific. But not related to any particular project…

This seems to be fixed in 2.3 (19120). Well, working anyway… :slight_smile:

Strange… I can’t think of anything that changed that would have fixed this. But, fingers crossed…

I’ve taken a few Snapshots over the last week or so and it’s still holding. So thanks, or something… 8)

Fingers still crossed… :slight_smile:

Sorry if this is the wrong place, but I’ve looked everywhere to report this problem.

I’m having this same issue. Scrivener 2.3.1 runs fine on my Air as long as I don’t try to take a snapshot using any method. Then everything freezes. I can open the same file or any other on my Macbookpro, same build and no problems with snapshots. I use Dropbox as well. The only differences I can see is that the Air is running Lion 10.7.4 and MBPro 10.7.3. Now I’m afraid to update on MBPro.

I’ll be happy to forward a zipped file if this hasn’t been resolved. If I need to uninstall and reinstall please send post a link with the newest procedure for doing so.
Thanks :smiley:
Martie

Do you use any kind of audio enhancement software on your computer? I recently ran across an issue with a piece of software called Audirvana that purports to increase the fidelity of the standard audio output. The only problem is, it basically hijacks the entire audio system and any program attempting to play sounds through the standard OS subsystem for doing so will hang up until the software is quit. You can’t even get TextEdit to speak some sample text out loud. As soon as the software is shut down, everything on the computer that has queued up sounds will fire them off at once—which is kind of comedic—and all of the “frozen” applications will return to normal functioning.

Interesting. Considering I dropped this laptop and the only thing that no longer works are the speakers. Perhaps something could be hung. I’d have no idea how to tell though. Honestly, I can’t remember what came first the problem with the snapshots or my clumsiness. :neutral_face:

There’s one other difference I noticed between the MacBook Pro and the Air. In the Application Support folder on MacBk Pro there is a Scrivener folder with Backups and Logs. On the Air, there is none.
Would reinstalling help?
Martie

Do you use the Mac App Store version? If so that would explain why the support folder is not where you’d expect it to be. In accordance with Apple’s stipulations, the App Store version is now sandboxed, and can no longer access the normal library folders. It has to use a special spot in the Containers sub-folder in Library.

No, I bought it from the Scrivener site via Esellerate. I’ve been running Scriv since 2007. Haven’t had any problems prior to this. Given workshops using the snapshots too - last year before 2.3.1. I’ll go back in tomorrow and see when I last took snapshot with Scriv on the Air. See if it was before the Lion update??

Well, snapshots are not never stored in the Library folder anyway. Those are stored in the project package. If you look inside that, you’ll find a “Snapshots” folder that should have everything. It’s strange you do not see an application support folder though.

But in regards to my earlier query, you’d have to specifically be running a certain type of software to encounter the problem I was mentioning. If you do not use Audirvana or something similar, then that is entirely irrelevant.

Amber, remove the missing Scrivener folder from the problem. Sorry, I looked in the wrong library file. Forgot Lion’s was hidden.

I can’t find a snapshot I’ve taken since upgrading the MacAir to Lion about six months ago just before my job got crazy. (MacbookPro came preinstalled with Lion) I can open all my scrivener files and look at the snapshots in the Inspector but just can’t add one.
Martie

An update on my previous post. I was finally able to do a clean install of Lion on my Air instead of the upgrade and now Scrivener and snapshots work perfectly. I suspected it wasn’t Scrivener’s fault all along.
Martie