Adding a linkby drag & drop not possible often?

When I try to add a link by drag & drop often this sign is shown and I can not add (the clickable) link.

Why is that? What could I do to make it work?

And how else could I easyly add a link which is clickable.

Where are you trying to drag from?

I find that if I click (either left or right) and drag from the binder onto a document in the editor, it adds the link. When the link is clicked, Scrivener opens it the other editor (and will split the editor if it is not already split.

And when I drag a file from Explorer onto an open doc, it creates link, which when clicked will open the linked doc in the default app for its file type.

Is that not happening for you?

E.g. from Firefox, a link in its address bar. Or a file mananger, e.g. Q-Dir or FreeCommander. Or other programs.

I find that if I click (either left or right) and drag from the binder onto a document in the editor, it adds the link. When the link is clicked, Scrivener opens it the other editor (and will split the editor if it is not already split.

Yes, the same here, I would say.

And when I drag a file from Explorer onto an open doc, it creates link, which when clicked will open the linked doc in the default app for its file type.

And when I drag a file from Explorer onto an open doc, it creates link, which when clicked will open the linked doc in the default app for its file type.

When I do that the sign on the screenshot is shown, the folder or file cannot be added as a link.

Is that not happening for you?

Yes, besides of that I mentioned above. But sometimes it works like it does above, mostly it does not.

I don’t have Firefox installed, but when I drag from the Chrome address into Scriv (which I never thought to do before) it works as expected.

Never tried Q-Dir or FreeCommander. But when I drag a file into Scrivener from somewhat comparable Explorer alternatives (e.g., Ultra Search and X1), all works as expected.

Is this with all file types?

Yes, when it does not work it does not work completely, so with all file types and folders.

I don’t have Firefox installed, but when I drag from the Chrome address into Scriv (which I never thought to do before) it works as expected.

Yes, sometimes it does here as well, but often it does not.

Never tried Q-Dir or FreeCommander. But when I drag a file into Scrivener from somewhat comparable Explorer alternatives (e.g., Ultra Search and X1), all works as expected.

Yes, sometimes it works here, somethimes / often it does not.