Adding a table in landscape

I am trying to add a table in landscape mode to my portrait document. The Page Setup, Landscape button does not change my document to landscape.

Technically, all the landscape option from page setup does is interchange your page/paper dimensions and tell the printer to flip the document 90 degrees.
Scrivener’s documents having no relationship whatsoever to the output page size or orientation, it won’t show in the editor.
Unless we’re talking File / Page setup (and not the compile format setting) and you use page view:
View / Text Editing / Page View

Note that you can’t have such settings for a single document. Whatever you do will affect the whole project.