After 3.1.2, the color black does not appear as a color in label tab of inspector or outliner mode when not selected

See images for reference:

When not selected, it doesn’t appear:
(in inspector)

(or outliner)

When selected, it does appear, but the black dot is tiny af and…

…as soon as you click to something else again, it disappears

It also still doesn’t appear in the outliner label dropdown, EVEN WHEN SELECTED:
Screenshot 2022-10-30 143131

I know this feature worked just fine in 3.1.1. I always use it as a standard color in all my projects and now it’s just… gone.
(Also, to add in further, the color WILL APPEAR on documents that are already labeled as such, in the binder when the project is set to show it there. That is why I didn’t notice this bug until now. Everything I already had labeled black shows up as such.)

Hope the pictures are clear, but let me know if you need anymore information from me.
– Jaay

But I was unable to reproduce.
I noticed that the black circle left of the label name is tiny in your case. Never seen that. May well “indicate” that something is wrong with your label. – Not sure it is the color itself that is at fault, here.

But, given that I just created a label and all is fine with it, how about you try to reassign the color to your faulty label ? Like: switch it for another color, hit “OK”, and then set it back to black. (?)

I too use black as a label color. I just loaded a project that pre-date the last update and that has that label assigned to documents → no issue to report.

That does nothing. Problem persists. It also occurs when I make brand new projects as seen with the example project pictured above.


Zeros everywhere ?

From a template with the label already in it, or from the ground up ?

Would you share that new otherwise empty project ?
I could load it, and if I don’t get your issue, we’ll know it is not the project itself; nor the color.
Would narrow the issue down to your current Scrivener install.

Yes, zeros everywhere.

From the ground up.

And sorry, but I don’t share projects or files with anyone except tech support over email.

Just to be clear:

I meant the empty / blank project that you said you created and that still won’t display your label.

That is correct. It’s just how I do things.

Black (12.7 KB)

Then, the other way around ? See if that works ?



Stupid question:
Have you rebooted your computer recently? Like, since the last update?

Why not make off black with values slightly off faulty numbers and will look the same and delete faulty value

1 Like

I can see the label dot disappearing from the dropdown, but not the size problem. Can you confirm you are using a high-res monitor? That might be the difference there.

And yes, I can confirm that using a value of “1” instead of “0” makes the problem go away, so that should suffice to work around the problem, but obviously the original report is valuable.

1 Like

Hello @AmberV,

Sorry for the very late response. I’ve had double shifts nonstop and just saw all these replies. :dizzy_face:

I can confirm that I’m using a high-res monitor, so that’s definitely not the problem.

And thank you and @GoalieDad for the workaround. I’ll use that for now until/if the big gets fixed. :slightly_smiling_face:

Using this for now. Thank you so much!

Just wanted to let you know that I created a new project in and tried this , and it works fine for me - both as a black dot, and as a black background colour in the Binder.