All pages are not coming after another

Hallo,

I am having the problem that the pages are not coming one after another, the content of the pages is like flow, there is no page break or so …

I want that the pages will appear on a dedicated page.

Can you give me some advices?

Thanks!

There are no settings that would cause that. Perhaps some very specific content issues might, here and there, but not page after page.

Thus, it would help to know a great deal more about what you are doing. For example, can you demonstrate this problem when compiling the interactive tutorial project from the Help menu? If so, which steps should be taken? More information, like what operating system version you use, and what version of Scrivener, will also help.

@ Ogi Karam,

Are you just trying to make a page break at the start of some documents? There is more than one way to do this.

First, just to be sure: Are you seeing the problem IN Scrivener or in the output of a Compile operation? You should not expect to “see” page breaks in the Scrivener editor. (In fact, I am a little concerned that you might just have accidentally turned on Scrivenings mode and are confused by what you are seeing!)*

So, page breaks are implemented at Compile time and only appear in compiled output.

That said, there are two main ways to make a page break.

  1. Assign each doc you want to start with a page break to a Section Type, then in the Compile dialog, you can assign that section type to a Section Format the has the page-break-before setting enabled — this shows in the format preview in the center pane of the compile dialog. This is Scrivener’s preferred method.

  2. You can also impose ad hoc page breaks using a Placeholder Code in the body of your text.

The Scrivener manual (and tutorial) will help you with both these.

gr

  • Scrivenings Mode is a way to quickly see many of your documents altogether in the editor pane as one continuous document. It is one of Scrivener’s most powerful features!

Thanks for the fast reply and the hints :slight_smile:

Problem solved.

For further reference will share that

I went to Compile - > Section Layouts → Assign Section Layouts , Choosing “Section break with New Page”. (mine was previously without Section break).

Hope this will help others later ;)