All .scriv packages empty or corrupted after restoring from Time Machine and external hard drive

Hi,

I am trying to recover a novel. I had it saved on Google Drive and Time Machine. I (now) see that Google Drive isn’t recommended (would’ve been great to know that when I bought Scrivener like 6 years ago!) but Time Machine and an external hard drive should be fine. I’m getting the same errors from both the backup I pulled from GD and the backup I pulled from TM and the external hard drive.

The first error set I get is that it’s an old file format and needs to be updated (see pics). When I click to update to the new format, it creates a second ‘backup.scriv’ version and updates the other, but when the other opens, there are no words. All of my notecards and sections are there, but they’re empty.

The other error I get (I have about 20 versions of .scriv backups, that I thought would save me from this ever happening) is it can’t find a file in the package (pic). I have tried making a new project and importing as it says, but it just imports empty sections again.

I’m on the current version of Scrivener now after having to reformat my computer (thus, the Time Machine). I started writing these docs in the old version of Scrivener for Windows, then moved to the old version of Scrivener for Mac ~5 years ago, but have been on the new version since it came available.

Is there any way I can recover my files?


Screen Shot 2017-07-11 at 10.26.31 PM.png
Screen Shot 2017-07-11 at 10.30.41 PM.png

Did you restore using the Time Machine interface, or by inspecting the drive manually?

From Google Drive, are you sure you downloaded the entire .scriv folder, including subfolders? One way to automate this is to install the Google Drive application on your system.

Katherine

Have you looked for the backups created by Scrivener when you close a project and not only the copies TM makes of your live project?

Before you start opening older versions/backups, give them some kind of temporary name, because if they keep the original name and you put them in the same folder as the live project, Scrivener will overwrite the current version, not knowing that you actually opened an older version with the same name. So restore it from TM to a folder where you don’t have your live projects, rename it (e.g. by adding ‘-restored from backup on MM-DD-YYY’) and then open it. If you find what you are looking for, delete the broken current live project, rename, move and open the backup you found and you will be up and running again.

I restored with Time Machine by manually choosing the files. I can’t do a full Time Machine restore because it’ll wipe my computer.

In Google Drive, I selected the Scrivener folder and clicked ‘Download’.

I just installed Google Drive again and tried to download that way. It has all the folders but none of the files inside. I did a CTRL-Click to view the package contents, and the folders are all empty.

I don’t have those backups anymore because I had to reformat my laptop (why I moved everything to backups to begin with). There aren’t any old files on my computer to overwrite. :frowning:

You should still have those backups if you have the Time Machine drive of your user folder. Unless you changed the default to save backups some place outside of where TM looks, it would back those backups up just like other files—and since Scrivener’s project backups are .zip files by default, they will be one single file each, instead of a package of many.

The default location for those is ~/Library/Application Support/Scrivener/Backups; that is where they should be in Time Machine unless you designated your own backup folder. In that case you’d navigate TM to wherever it was you kept them.

Backups of backups aside, the projects you restored with Time Machine should be okay—but they might have permission problems, making it impossible for the software to load it correctly and resulting in confusing errors. I would first confirm that the errors are incorrect—where it says such and such internal files are missing, visit the project in Finder, right-click on it and Show Package Contents. Is there anything in there? Are the files it complains about actually there? If so, try the instructions in this knowledge base article on a copy of one of the projects.

This is bad. ALWAYS use the T.M. interface when restoring files, and NEVER manually interfere with the T.M. files. No-one’s asking you to do a full restore - just use the starry sky interface to go back to the last date you feel confident there’s a more or less up to date, working version of the project then click Restore. The ‘starry sky’ will disappear and you will be asked if you want to replace the original (pre-restored - yes, I know : confusing!) or keep both. I’d start by keeping both.

IF you still have Time Machine for a different machine or earlier OS (and you should always keep these for a good while), you can access its files by clicking the icon in the menubar while holding down the Option key. This will look for earlier Machines and invite you to use those.

Hopefully you haven’t ruined your T.M. files and can use the proper interface to restore your .scriv project(s).

To save disk space, each individual Time Machine backup copies only the files that have changed. A single project might have hundreds of component files, but each individual TM backup might only have two or three. If you use the Time Machine interface, OS X will stitch the component files back together to give you a complete project. If you don’t, the result is likely to be exactly the kind of mess you’re looking at now.

Katherine