All text missing on iPad/iPhone, all present on Mac?

Hello all,

Any suggestions? Been syncing for months without issues. On the iPad and iPhone, the Binder and all the files/notes/folders are there, but when opening any of the text sections, the editor is blank (0 words). Opening the same project on the Mac, sees all is working as it should.

This is only happening with one of my projects. In the others, all the text/Binder etc. is present across all the platforms - it’s just with this one, where the Mac has the text, but no amount of syncing with Dropbox is pulling the text down to the iPad/iPhone…

The sync to on Dropbox the Mac is up to date, and I allow the sync to finish completely on the iPad/iPhone, without any difference.

I am a tad nervous that an “empty” version of that project is going to pull-up from the iPad/iPhone to the Dropbox project, but have backups on site, and in TM.

Restarting the App and iDevices, does nothing.

Options? Delete the project on the iPhone/iPad, and re-download?


Deleted the Project on my iPhone.
Ran the sync - when I tried to open it again, the following message popped up:

“Unsupported project file format.
The .scriv project is of an older format that cannot be opened on mobile devices. Please update it in the latest version of Scrivener for Mac…
Please ensure that the project has been fully uploaded from other devices and then try syncing with Dropbox again.”

Will see what I can manage - popped this up here, more for me to remember, than anything else.
Not sure why I am seeing this now.
Pretty sure I opened all my projects on my iDevices after upgrading to Scriv 3, and they were all working.
Currently still working on this very project on my Mac, with Scriv 3 as well.


Ok. I have sorted this now. :smiley:

Just to close this loop – I have managed to fix things.
Still not clear on what might have gone wrong, since I cannot think I did anything out of the ordinary on this one project, compared to the others, but so be it.

For anyone in future that might stumble across this thread, some points:

1.) I did not fully appreciate the fact that deleting a project on my iOS device, appears to delete the .Scriv project from Dropbox as well… This is obviously quite significant.

I noted the ominous warning that flashed up when I did it, but assumed that this was telling me that there would be no way to undo the delete on my iOS device - whereas I gather this pop-up was trying to tell me the entire project will be deleted, everywhere

Maybe I alone failed to appreciate it, possibly as a result of how some of my other Apps work - I assumed it would ONLY be killing the iOS instance of the project – when it in fact, wipes it all, everywhere.
Something to keep in mind!

2.) Backup, backup, backup.

I have my Scriv projects set to back-up to a folder on my MBP, which is in turn backed-up to 3 different externals using a combination of TM and CCC.
I also have Scriv’s preferences set to back-up on opening, AND on closing any projects. And I regularly hit CMD+S by force of habit. Overkill maybe, until you need it!

When I wiped the project on my iDevices, and noted that the .Scriv file was then also wiped over in Dropbox, what could have been a major issue, was resolved a few moments later.

As in - open up the local backup folder, find the latest zip file, unzip to desktop, drag .Scriv project back into Dropbox, wait for sync, back in business.

3.) So, to be clear, after not managing to get either iPhone or iPad to properly open the project, I basically nuked it, and then dropped a fresh version into Dropbox. After letting the necessary sync UP take place, I simply re-synced on my devices, and all working again.

Joy. :smiley: