Almost whole project seems gone after crash

Hi everybody,
I use Scrivener basically for 2 projects, a major one and a private one (for recipes). Some weeks ago my Mac had a horrible crash, it took me several days to understand that I had to reinstall the whole system and could not just migrate my files and settings. Today I wanted to open the recipes project for the first time since the crash, and what happens? Only one recipe is shown (out of about 50), and I get a warning like “Not all the changes could be saved. The files that could be restored are saved in <path/restored>. The project will be closed now.” (My translation from German)
When I go to the restored project in the Finder I see that it contains only the RTF file of the one lonely recipe. I tried to go back to my backup, but unfortunately I had the automatical backups turned off (relying on Time Machine) and my older Time Machine versions were deleted. The most recent one contains the project but with the same error.
Finder Preview shows me all the recipes that should be there, though. I also should have a PDF or .mobi of the file somewhere. What can I do to really restore the project? Thanks so much in advance for any help!

How did you restore the project from Time Machine? This sounds a bit like what might happen if you pull the project directly off of the Time Machine backup disk, rather than using the TM interface. It is important that you use the latter, because to save space, TM does not write out the entire project every time it backs it up. It only writes out the pieces that have changed and then creates empty link files pointing back in time to older copies. Thus your real project is stretched out over dozens, maybe even hundreds of folders, and needs to be put back together again. The only way to effectively do that is with Time Machine.

Secondly, if you just copy the project straight out of TM, it may very well not have its permissions reset to your new computer account. This will cause the effect you describe where Scrivener discovers it cannot write to its own project, and shuts down to avoid you working in a scenario where it can’t save what you do.

I restored from a clone of the whole (already crashed) system before the reinstall, I didn’t use TimeMachine. I would have tried to restore from former versions of TM but they are gone, but as you say, they might not have been of much use…

Okay, well resolving the permissions issue may sort things out, but if you want to take a look at the project data itself to ensure it is all there from the cloned backup, right-click on the project in Finder and select “Show Package Contents”. In this window, drill down to the Files/Docs folder and see if it looks like you have enough text files here. Note that there are multiple files for each Binder entry in some cases. If you write index card notes, you’ll have a synopsis txt file as well as a plain numbered RTF file, so a simple count of the files in this folder may not be precise enough, just want to count the numbered RTF files (like 23.rtf, not 23_notes.rtf, the latter would be anything you’ve typed into the Document Notes sidebar). You should have the same number of RTF files as you had sections in your Binder that you’d actually written into. So we should expect to see at least 50 numbered RTF files, one for each recipe you’ve typed in. If you use Finder’s Quick Look here you should be able to flip through them quickly and ensure everything is intact.

Again though, there is clearly a permission error, so getting your whole home folder cleaned up so that you can read and write files to all of it is an essential first step to take after restoring a Mac. If you’ve never done this before, here is a handy web page on resetting user permissions.

In the Files/Docs folder there are about 100 different .rtf files, so everything seems to be OK there.

May I ask what makes you so sure that there is a permission error? I haven’t had permission troubles with anything else (many other kinds of troubles, though) and the warning the program gives me does not say anything about permission issues.
(Just trying to find a pretext for not doing the whole permission resetting thing, especially as I’m not able to print the instructions right now…) :unamused:

The warning you received only occurs when the project is in such a state that Scrivener cannot write to it. If it every fails to write a file within the project package, it aborts with this message. There are a few things that can cause that:

  • Opening the project from a read-only device, such as a CD-ROM backup (I think we can disqualify that one!).
  • Opening the project straight out of a Time Machine folder (it will be marked as read-only on the TM disk—also not a factor here).
  • The project has been copied to a location that won’t let you write to it. Since it is in your user folder that shouldn’t be an issue, but it’s worth investigating whether you can save a .txt file to the same folder the .scriv project is in.
  • The project itself has varied permissions or ownership settings—typically caused by copying the project from another Mac user folder directly, which a clone of your disk would in most cases be.

You could try resetting just the one project if that is more convenient right now. Please refer to this thread for a checklist on resetting project permissions