Altering numbered lists

I’ve got a list of entities. Scrivener has kindly numbered it from 1 to 106. But one of the companies is listed twice, and is also out of alphabetical order.

I’ve taken it out of where it’s listed, and put it in its alphabetical place. But Scrivener didn’t add it in as a number, and didn’t renumber at the other end.

How can I get Scrivener do do this? I’m hopefully going to be entering lots of new companies into this list, and putting them in their alphabetical place. I’ll need to know how many companies we have.

Can anyone help with this?

What happens when you remove the list formatting and then re-apply?

If you right click in the list and choose ‘Renumber list’, that sometimes works, otherwise as Devinganger says, the simplest solution is often to select the entire list, remove all numbering (‘None’), then reapply it.

Selecting the list and applying “None” has no effect. I can’t see the option for renumbering otherwise. I also tried Copy Special (Without footnotes and comments) and pasting it back, but that didn’t remove the numbers either.

Can anyone help with this? Keith?

The list is also a bit weird - I’d expect it to behave like a hanging indent, but it’s just put the numbers on the left instead.

Eventually I just deleted all the numbers. Having done that, and numbered it again using Scrivener, I discovered that there were tabs before and after all the numbers for some reason. Deleted those and it works fine now. Or, probably, will till I need to add more entities to it.