An error or a bug?

I updated my Scrivener last night. Prior to this, everything was fine, but tonight I copied a Word file that had italicized words in it. I pasted matching style, but all the italics are gone. This had never happened before last night. I’m uncertain how to fix this problem.

Have you tried simply importing the document, rather than copying and pasting? You can use Ctrl+Shift+J in the corkboard of the folder to which you want to add the file, or even just drag and drop the file into the binder folder. This should import the file with all formatting retained.

Yes, Paste and Match Style pastes as plain text, so this always strips character formatting like italics and bold. If you want to retain that and need to copy paste a section of text rather than importing (though in this case, importing sounds like what you want to do), try doing a regular paste and then using Documents > Convert > Formatting to Default Text Style to update the formatting of the entire Scrivener document to match the default formatting set in the Editor tab of Tools > Options. You’ll have some additional options about settings you main want to retain, and character formatting will always be preserved.