Annoying "international" problem


I’m a relatively new Scrivener user. I’ve bought the software to write non-fiction (papers mostly). I’m happy with it but recently I found an issue that is a real minus to me (and, I suppose, to anybody writing in spanish): the footnotes/endnotes in Scrivener always are exported “in english”…

I mean: in english the footnote marker must be located after period, something like this:

I’m a relatively new Scrivener user.(1)

Meanwhile, in Spanish, the right thing is to locate the marker before the period:

I’m a relatively new Scrivener user(1).

Is there any way to correct this issue while compiling the draft? If not, can I expect a fix for it in the near future? In the meantime, anybody knows a workaround for this?


The footnotes get exported so that the marker appears directly after the range associated with the footnote (the range highlighted in grey). In the current release, when you add a new footnote and the cursor is after punctuation, it will automatically include the punctuation after the selected word, meaning the marker will appear after that when exported. In the next free update, there will be an option (turned on for French, Spanish and certain other languages) not to add the footnote to the punctuation as well, so that upon export the marker will appear before the punctuation. In the meantime, the workaround is to select the word after which you wish the footnote to appear (or to click into it) and then add the footnote, so that the footnote is associated with the word but does not include the punctuation after it. That way, everything will export just as you wish.

Hope that helps.

All the best,

thanks a lot!