Another typing lag issue -- how fast does everyone type?

Hi everyone,

I know there are a few of these ‘typing lag’ threads around; I’ve scoured them for solutions, without much luck. Please note this problem isn’t restricted to Scrivener: This is not, technically, a call for Scrivener-based technical support, but more a plea from technically-inclined writers. Mod(s), if you think this inappropriate, please delete it.

Symptoms:
‘Typical’ typing lag problems: keyboard would get ‘behind’ by about a word or three after a line or two of ‘fluent’ (i.e. say 70+wpm?). Stop typing, and it’ll catch up in about a second and a half, and then be good for another few sentences until it slows down again. Isn’t so prevalent when at lower (say, <50wpm?) typing speeds). BUT, on the occaisons I’ve plugged an external keyboard (USB) in, and everything’s beautifully smooth. That said, I can’t type as fast on foreign keyboards, so it might just be that.

Computer: (Originally – see below) a late '06 macbook. (Core 2 duo 2.0ghz, 3gb ram, intel gma950 video card (supports core-graphics)). Had tiger at the time the lag started; upgrading to Leopard didn’t help.

Troubleshooting & present state: After a myriad of tech support calls to Apple, replaced keyboards, new logic board, several HDD formats, new user accounts, and a whole lot of praying, I’ve obtained a spankin new Macbook (early '07; 2.4ghz, 2gb ram). I (and tech support!) was hoping the ‘problem’ would go away.

But The Lag still exists.
Admittedly to a lesser degree (seemingly), but still exists.

So. In desperation, I’ve three questions.

  1. How fast do other people type? I’d be very surprised if the 2.4ghz can’t cope with even 1000wpm, but the human (i.e. me), and its interaction (i.e. typing) is a common factor. That said, I’m sure there are others out there who type faster than me – presumably without issues.
  2. Has anyone on newer hardware (especially faster-typists) observed, heard (or even dreamt!) of such symptoms?
    And finally;
  3. Any ideas? (Note, if it’s hardware, it’s something that’s common across two different macbooks. If it’s software, it’s common across 2 OS’s, and must be prevalent in the system as it still happens in textedit on a fresh install).

Very happy to troubleshoot; am fairly confident mucking around in terminals, etc. Can’t find any reference to anything in the error log.

(And yes, lag occurred throughout writing this post. Grr.)

This is very strange… I type at around 80wpm (and I know others here, such as AmberV, type at well over 100wpm), and have no lag at all, either on a first-gen MacBook, a MacBook from a year ago, or my MacBook Pro… Neither did I have any lag on an old iBook running Tiger (running Leopard on a PPC machine is a different story, but that is not your scenario).

Given that this has happened to you on different machines, it must be something to do with the software you have loaded on both machines. Do you have any typing helpers such as TypeIt4Me etc? One thing to do might be to try setting up a second, clean account on your machine, then log into that account and start typing away. If you have no lag on that account, then you know there is some software on your main account that is interfering with typing. That is the only thing that comes to mind off the top of my head, I’m afraid…

All the best,
Keith

Done the whole account thing. And, since my last post, did a fresh install of 10.5 and still get the lag (Using the old Macbook, with its new hardware, and Scrivener being the only non-OS software installed. Not to point the finger at anyone. :smiley:)

Edit: and no, no strange type-it-for-me-esque software, or anything that I’d expect to hook into the typing/keyboard side of things.

Nonetheleess, thanks for the speedy reply Keith. As you say, very strange. I used to build and sell PCs, so have troubleshooting pretty down-pat. Seems to defy all logic!

You did say that this is happening in other applications, too, though, right, and not just Scrivener? If it’s just in Scrivener then obviously it’s something I need to look at, but if it’s in Safari or whatever browser you use, TextEdit and elsewhere too, then it’s something bigger…
Best,
Keith

you said “foreign keyboard”. I am right in thinking your native language is not english? If this is true you can do a simple test to see if it is the language settings by creating an account and setting it to English. then open a text edit window and type gibberish for a while. keep “word” length realistic, say between 3 and 8 characters. If everything is good using the default EN_US setting then you may have found a bug.

Just a thought.

We now return to our regularly scheduled insanity.

Keen eye, Jaysen! Didn’t mean foreign in that sense – my apologies for being unclear (In my defence, I’m writing a thesis where ‘foreign’ has a broadly ‘strange’ meaning). I’m Australian, but still speak good ole’ english… though, some may disagree, ay? :slight_smile:

So, no foreign keyboards, but come to think of it, Aussies DO have a ‘foreign’ spelling dictionary/layout(according to the OS, anyway. Keys are identical to US, but different profile)/etc. m not hopeful, but I’ll change everything to US and see how it goes.

Thanks again!

Steve.

I will agree that you “downunerers” are upside down in many ways. Including language.

The bad news is that there are MANY ausies on the forums. I think you are the only one with this problem. Go for the EN_US change just for kicks. It really does sound like something that you are adding as a system service (you don’t have an HP printer do you?).

RUBBISH!! Keen eye my arse! Yre lucky if he reads [size=150]half[/size] of what youve posted! Then what bit he has read he rearranges it in his head, before he responds!

Arrrgghh!! haaaa! since when do Aussies speak English!! Theres only one Aussie...well two if y like, that can speak English. Clive James and Barry Humphries. The rest of `y speaK Aussiglish. :open_mouth:

Portlanders had better watch out! They`re almost outnumbered by the Antipodian mob onboard Scrivener now :open_mouth:

Welcome aboard Scrivener, LPB :wink:
Vic

Jaysen; I’m also doubtful of the EN_US change fixing anything: I guessed there’d be a lot of other ‘foreigners’ using Scrivener but as you said, have/am trying it for kicks.

Incidentally, I do have a HP printer; it’s an ooolldd Laserjet 5m, connected via Ethernet (Line Printer Daemon, if that means anything to anyone). Uses the Gutenprint drivers, and they’re the only drivers installed on the system (i.e. when installing OS, removed all the others, including HP ones) Have issues emerged from printer drivers?

Will continue to experiment. Have removed a few things off dashboard, and seems a little better, but no scientific tests yet.

Thanks for the warm welcome, Vic! :smiley:

Can you just confirm whether this is happening only with Scrivener or with other applications as well? In your first post you seemed to indicate that this was a global issue - happening in your browser too - but now you seem to be saying it is specific to Scrivener…
Thanks,
Keith

Open up ‘Applications -> Utilities -> Activity Monitor’ and sort by CPU%. Keep this running while you do you thing and switch back when you notice a lag. It can give you a good idea where the problem lies.

I have lag issues when I keep Mail.app open, so I just keep it closed most of the time :slight_smile:

Tanja

Tanja; Good suggestion; had done that some time ago (For the record, activity monitor has a convenient ‘floating’ meter under window>CPU history/usage). CPU use does perceptibly rise when typing quickly, but never above about 10-20%, with spikes mostly under 50%. Oh, and I’m in the process of experimenting with running/closed apps. Will try Mail.

Keith, didn’t mean to mislead. This is global, and not specific to scrivener: Seems to happen throughout the operating system (i.e. in Firefox, when replying to these forums). Thanks for your vigilance and keenness to keep Scrivener Bug-Free!
From my point of view, the obvious avenues (suggested in this thread) have been exhausted, and the laggy-typing-ghost (which is probably a service, as Jaysen points out) will need to be removed on my own. Thread could probably be closed. Many thanks to all who’ve tried to help!

You mentioned that it also happens in Firefox … I’ve experienced some Firefox lag when I have a tab open to a site that uses lots of Javascript – many of Google’s services, for instance. I’ve never seen it slow down the whole system, but it’s worth a look. You might also look at the intervals for background tasks–things like Scrivener’s Auto Save, Time Machine, Evernote’s Internet sync, etc. all add load to the system, and if you have a bunch of them running at once it could drag you down.

Hope this helps,

Katherine

Lost,

If you want some general diagnostic help, send me a PM. Then once we get a solution you can post it for all to see (the next guy/gal will appreciate it).

Thanks for the tip, Katherine. I do usually have Firefox up and running, though not with anything particularly intensive (rarely need Google’s products). That said, you’re probably on the right track - am testing various configurations of running programs to see what causes changes.

Though, it’s a little hard as it’s kind of intermittent.

Nonetheless, I’ll keep trying, and I might take you up on your offer when I run out of ideas, Jaysen! Will definitely post any progress (or otherwise), in the coming future.

Thanks to everyone for your help!

Steve.