Apostrophes disappear when importing .rtf[BUG LOGGED]

I just downloaded the 1.4 Beta version of Scrivener for Windows. I’ve dutifully completed the tutorials and decided to begin by importing my NaNoWriMo book into the program as a .rtf so that I can do some massive reorganization and rewrites to it. I went to file and selected “Import” and then selected my .rtf file. The import maintained most formatting and punctuation such as the paragraphs, indents, double quotations, French accents and italics, but the apostrophes did not import throughout the document. I double checked the .rtf file and it does have all apostrophes accounted for so the initial saving appears to have been effective, but something may have gone awry in the import. Just some further information…I’m running Scrivener on Windows 7 and I saved the .rtf from what was originally a .doc created in Windows 2007.

I just attempted my first .rtf import with the new beta and all of my apostrophe’s crossed over just fine. Have you opened this .rtf file in another program after you created it? Is it in a unique font?

I’m having the same problem as Kween. I just installed Scrivener (Beta 1.4) on my Windows XP SP3 machine and tried to import some of my .rtf files, and Scrivener ate my apostrophes. I then opened up Word 2007, created a new .rtf file and wrote just a few words and try to import that file, and the apostrophes disappeared again. The font was Times New Roman so nothing fancy there. I even closed the file and reopened it in both Word 2007 and WordPad just to make sure it did indeed save the apostrophes and the file opened correctly there. Only when I resaved the file as a .txt did the apostrophes import correctly.

I don’t have word, so my RTF files were created in OpenOffice, I keep trying to get it to replicate this and cannot, so I’m wondering if it’s Word RTF creation specific.

There is always copy and paste, instead of saving as a .txt, so that you can keep more of your formatting (like bolds, and itallics). 1.4 has definitely improved pasting.

Right now I’m not too worry about importing stuff. I just wanted to alert the programmers of the bug.

The bug is indeed with MS Word created documents. Just now I created a document in WordPad and the apostrophes imported correctly, but opening my previously created document (created in Word 2007) and doing a Save As in WordPad didn’t fix how the document was imported.

I’d like to add, it’s not just during imports - I tried a copy-paste and it ate all my apostrophes as well. I’m quite sure it didn’t happen in 1.3, only 1.4.

I’m copy-pasting from Microsoft Word, and the font is Calibri.


Just to see if I would get the same, I created an rtf file (with plenty of apostrophes) under Word 2010 on Win7 Home Premium.

No problem at all importing or copying Word created files with their apostrophes.

If the problem comes from Word, I would say that it might be Word 2007 (and maybe older versions), but not Word 2010.

The issue seems to be that ordinary apostrophes will import (and cut-paste) successfully but Word’s smart quotes will fail.

However, with one file I tested, apostrophes displayed every time! But I can’t see what is different between that file and any others. All have the same font, etc. If I modify that “good” file and just leave a paragraph with some apostrophes and import again, the apostrophes don’t show up.

I’m having the same problem. Using Windows XP, Office 2007. I’m using Scrivener 1.4 beta

Things I have found:

Importing .rtf file created in Word 2007 - the apostrophes disappear
Cut and paste from a Word 2007 document - the apostrophes disappear
Importing a .txt file created in Word 2007 - apostrophes are all present


Alright, I’m gonna play with a few things tonight, the smart quotes idea might be something. I do not use smart quotes in OpenOffice because it makes the word count weird. So I’m going to see if I can replicate this and figure out what exactly is happening. I also have a computer with Word in the apartment right now. So I’m gonna spend a bit trying to find out if we can settle what exactly causes the loss of apostrophe.

Is anyone completely stymied because of this glitch? Let me know! Once I get it replicated I can figure out how to work-a-round it.

[LOGGED]Finally replicated this sucker. You know I must love you guys when I’m installing bleeding Word 2007 on my laptop just to get this to happen. Anyway, it is specifically smart quote apostrophe’s made on Word 2007 RTF files. The opening and closing smart quotes do not vanish, and import fine.

This is why I hate smart quotes. Don’t get me wrong, they look pretty and what not. But they seem to cause all sorts of interesting problems in a variety of different programs I’ve worked with in the past. As I mentioned before OpenOffice has a glaring wordcount issue when you use smart quotes in your work. Of course, their smart quote apostrophe’s WILL import. Weird right?

For those of you with Word 2007, if you want to save your file as an RTF and import it follow these next steps to deactivate your smart quotes.

Office Button -> Word Options -> Proofing then click on the button that reads “AutoCorrect Options”. Once inside the AutoCorrect menu you will have to deactivate smart quotes in TWO DIFFERENT PLACES: AutoFormat & AutoFormat As You Type. In both tabs you want to uncheck the box next to “straight quotes with smart quotes”.

You have now deactivated smart quotes. Getting the smart quotes out of the file requires a find and replace. I copied a curly apostrophe and put it in the find and then typed a straight apostrophe in the replace and told it to replace all. You can do this with the opening and closing curly quotations as well.

Save as RTF and import into Scrivener apostrophes and all.

There is something much easier to do with Word.

Go to the “autocorrect” list and simply remove the smart quotes there.

Then you can leave the “autocorrect” options on, as they are very useful.

I do not mention the steps to follow, as I could do this only in French (I have a French version installed and do not remember what things are called in the English install).

Mightygitis, if you wish to make this up clearly together with me, I can tell you the steps to follow.
Of the two steps you mention as “autoformat”, one is autoformat, the other is “autocerrect”.
Eh, Word has always been my favourite.
Which means, in the end, that Scrivener must have something particular : It is slowly coming to the first place…

Thanks for this. I’d never heard of ‘smart quotes’ until this forum. Learn something every day.

Incidentally, the double quotes " always came across perfectly despite them being curly quotes. It was only the apostrophe ’ (or single quote as some folk call it) that didn’t.


Just a funny thing with these quotes:

I copied a title from a word 2007 document and pasted it into the editor WITHOUT the quotes.

Then I pasted it into the binder, to use it as title there as well. And it came out WITH the quotes.

This is very strange…

Any easy solution for me was to open each RTF I wanted to import with LibreOffice (an offshoot of OpenOffice), then simply save it again. Add a space or something to enable the Save button, then save. This seems to cleanse the RTF of MS poisons. Then import, and the apostrophes will be there. It’s a bit time consuming if you have a lot of files, but it gets the job done. (Note that I did this in Linux because the Linux version of 1.4 had the same problem.)

And it’s FREE ladies and gentleman:


Something new on this…

I am pasting text from a lot of older Word files.

Simple Paste DOES NOT give the apostrophes.
Paste matching style DOES.

I did this with exactly the same clipboard content and had two completely different results.

The text also contained “small caps” formats coming from Word 2003 and 2007.
These small caps DO NOT come with normal paste.
Paste match style brings them as caps (wich is ok).

As long as there is no solution to this, I can suggest one that is somewhat complicated, but IT WORKS :

This is only on COPY/PASTE, not on import.

  1. Copy the text from Word
  2. In Scrivener, make a single return to get rid of the loss of indentation
  3. Paste your text once and keep only one paragraph (to keep format)
  4. Paste THE SAME text again matching style

Result : You will have the first line indents, as well as your apostrophes AND all the formatting like bold, underline, italics and so on.

But you will have to remove the first empty line and some others at the end.

As I said : For an intermediate solution, at least, it works.

When copying and pasting, it’s easier to just paste it first into Notepad and then into Scrivener, therefore keeping all the apostrophes and long dashes (which also don’t survive the trip from Word 2007 to Scrivener). The downside is you’ll lose all italics in the process.

@Lilith - that works, but the problem for me is that all coloring is lost. I have bits and pieces of text that are colored red in my MS Word docs and I need to preserve those. So I have to use the LibreOffice solution.

Thanks for feedback. I have logged this bug.