app shortcut/association not working

When I d-click a project.scrivx file I get a popup alert titled “Open Project” that says:

The file is not a Scrivener project file.
Please, select a valid Scrivener project file.

This happens on all the .scrivx files I’ve tried and the tutorial’s file.

This means I can’t use custom desktop shortcuts to open my different projects.
I was able to do this in a shortcut’s Target field:
“C:\Program Files\Scrivener\Scrivener.exe” R:\almnov\tgcontact.scriv\project.scrivx
and the project would open.

Win XP
Scriv 1210

Try making sure Scrivener is open first. Use the Start menu or desktop shortcut to load the program, and then you should be able to use your shortcuts. This bug where loading files while the software is closed has already been noted.

Well, I don’t see why I should have to do that since the file association method worked with last release and all the betas up to but not including the recent 1210 release. Looks like a new bug to me.

Note that I’m not loading files. I’m starting an application based on a file association. The app is then passed the path to the file as an argument.

I have tried what you said and found that if I turn off or uncheck Options/General/“Open recent projects on program launch” (Why is that plural anyway?) that I can start Scrivener and have only its New Project dialog showing which I toss over on the other monitor out of the way where it won’t obscure anything. Otherwise I’m likely starting a project I don’t want to start that being the purpose of the custom shortcuts, starting the project I want and only the project I want without menus and dialogs getting in my way.

I’ll just add a shortcut to scrivener.exe to the Windows Startup menu and use it that way until the bug is fixed.

You shouldn’t have to. :slight_smile: It’s a bug, and yes it is a new one. I don’t know where it came from.

Yup, that’s how I’m working as well right now. I’ve never used the reopen projects option myself, I always prefer to open what I intend to work on at that moment in time, not what I was working on last time I quit. But, I think most people out there have one primary project or pair of projects that they use exclusively and so that feature works fine for them. They load the program with the icon on the desktop and actually don’t even pay attention to where the .scrivx are. Otherwise, this forum would be swarming with this bug.