Apple Tab Span

Hi

Running Scrivener 2.8 on OS X 10.11.6 and using Marked 2.5.9, I get the following for a nested list.

[attachment=1]Scrivener28.jpg[/attachment]

Running the same file on Scrivener 2.8.1.2 on macOS 10.12.2 and using Marked 2.5.9, I get the following for a nested list.

[attachment=0]Scrivener2812.png[/attachment]

As you can see, the nested tabs are getting converted to a span class called Apple-tab-span, and Marked is unable to create the proper nested elements.

Any ideas?

Thanks in advance.

What is the method you are using to combine Marked and Scrivener together? I have tried three methods and they all come up clean:

  1. Displaying the active editor content as a temporary file with a Keyboard Maestro plugin. Specifically, the script uses pbpaste to pipe copied rich text from Scrivener into a plain-text file in /tmp and then has Marked open that file.
  2. Opening the .scriv directly with Marked.
  3. Opening a compiled .mmd file with Marked.
  • And this is of course the test document…
  • As well as the forum post. :slight_smile:


Click to enlarge.

Hi Ioa

Thanks for the reply. I am opening the Scrivener project either from Marked (File > Open), or by opening the Scrivener project and dropping the project icon on to Marked in the dock. This allows me to preview the MMD while writing, splitting the screen with Scrivener on one side and Marked on the other.

Attached is a plain-text file (see zip). If I open this in Marked (outside of Scrivener), it looks like this:

[attachment=2]plaintext.png[/attachment]

If I drag the same file into Scrivener, or if I copy and paste the text into a new file inside Scrivener, in Marked it renders like this:

[attachment=1]scrivener.png[/attachment]

I have tried this with several projects. They all render in the same way.

I am also attaching the Scrivener project in the zip below.

[attachment=0]Archive.zip[/attachment]

Mysterious, but given that the file works outside of Scrivener, I assume (perhaps wrongly) that the issue / setting is somehow awry inside Scrivener. The same Scrivener file renders fine if opened in Scrivener 2.8 and Marked running on OS X 10.11.6.

With thanks

An FYI for the thread and for anyone else facing the same issue…

I asked Brett at Marked about this.

I can’t find a setting to change.

I have uninstalled and reinstalled both Scrivener and Marked. I have the reset the PRAM and SMC on the MacBook Pro (Retina, 15-inch, Mid 2015).

I don’t have another Mac running Sierra to try this on.

I’ve posted my response to the Marked support thread as I think Brett needs to look over the data I found. I’m not quite sure what the problem is, other than having found the trigger.

For now you can avoid it by resetting the kerning to default in your default formatting.

Hi Ioa

Thank you so much for sleuthing that one out. I’ve reset the kerning and the bells have tolled.

Very grateful for your help, speed, and kindness. Wish I had figured it out.

Indebted.

Festives wishes

To anyone with the same issue, Brett at Marked says that it will be fixed in the next app update.

support.markedapp.com/discussion … acos-10122

No worries!