Application not working

I’m started having difficulty using Scrivener recently.

The first sign of an issue was the familiar black and white icon changing to a generic Mac one. I noticed this a few days ago. I tried to see if an update was available but the updating window was unable to complete even after several hours and I was unable to stop/close the updating window. I ended up having to force it closed.

I’ve tried using one of my documents to open Scrivener, again needing to force Scrivener to close to remove the window. I tried starting a new project. After several minutes, the Project Templates became available but most of the templates were missing, leaving only the description of the template behind. Selecting cancel in Project Templates disables the buttons but nothing else occurs. Once again, I’m reduced to forcing the application closed to exit the window.

Any help or ideas?
My Mac version is 10.12.2

Back up your data (to be extra safe), uninstall Scrivener and then reinstall.

That seems to have taken care of it.

Thank you!