Applying formatting

I am hoping this is a simple question with a simple answer!
I’m simply attempting to apply formatting to a selection of text; e.g., highlight a phrase, select italic from the formatting menu. I’m getting two results that aren’t making much sense:

  1. the text does not change its display; it does not appear in italic
  2. it appears that even though I’ve highlighted a selection, and would expect the formatting to only apply to it alone, all of the typing that occurs after the selection appears to have the italics formatting applied to it (I can’t see it, but I’ve noticed that the I in the formatting bar is now highlighted when I click anywhere else in the paragraph).
    Is there some basic step or syntax I might be missing here? I’m confused why my text selection doesn’t appear italicized (I’ve tried underline, for example, and that works) and also why formatting a selection appears to apply to all subsequent text.

I made minor font changes to Preferences:Formatting but nothing is customized otherwise. I’m still a newbie.
Thanks for any help!

I think you might be using a font that doesn’t support italics. In the Format Bar above the editor, there is a button with the name of the font, what does that read? Beside it is a second button that might say “Regular”. If you click that, do you see Italic or Oblique in the list? If not, the system can’t set the word to italic until you set the text to use another font.

Ah-ha! Yes, I’m using Lucida Grande, and you are correct that it doesn’t support italics. I’ll choose another and see if that resolves both of the issues I mentioned. Thanks!