As-Is formatting doesn't format As-Is

Here’s a text file with a bold 36-pt Bookerley header. The rest of it is 16-pt. I’ve tried other sizes for the header, with no success. The bold header Compile to PDF smaller than the rest of the text.

Here’s the Page section type attached to an As-Is layout.

Here’s the layout:

Finally (in my first reply) is the PDF.

As you can see, the page did not compile As-Is.

In addition, I don’t think the font is Compiling as Bookerly, despite being embedded in the PDF.

Does it work if you assign the Page section type to Scrivener’s own As-Is section format?

I don’t have Bookerly, but tests with other fonts on my Mac all compile correctly.

  1. Does it work if you try a different font or a different size / weight?

  2. Does it work if you select the text in the Editor and then mark it as preserved formatting?

I understood Bookerly to be a custom Amazon-device font. Perhaps it can’t be compiled as other fonts can.

Slàinte mhòr.

No, and I lose the page break. Thanks for trying.

Changing to Times New Roman didn’t help.

Preserve Formatting did the trick (THANKS), but it shouldn’t be needed.

Disregard my post about Bookerly not Compiling. I had layouts in whIch I set the font to Helvetica, by mistake.

The fact remains that Compiling As-Is doesn’t appear to work.

I suspect your problem is that you just assigned that text a font, size and bold variant in the editor without giving it a style, so “as is” is just treating it as no-style text, so it’s retaining the bold, but using the base font and size of no-style. If you want it treated differently, you need either to give it a style, or mark it with preserve formatting. I think you could use a character style for it instead of a paragraph style, but I’ve not experimented.



“As-Is” should preserve all formatting, whether associated with a style or not.

Please send a test project to our support team, here:

Please tell us exactly what version of Scrivener you have.


I would try compiling with the Default compile format with the Page type assigned to As-Is. If that works as expected, then we should suspect that some setting in the particular compile format is running unexpected interference.


I’m sending the project a second time. I got no response a month ago.

Hmm. We’re backed up, but not that backed up. Please check your junk mail folder.

If you don’t find a response, PM me with the email address you used and I’ll check the queue to see if I can find it.



The suggested PM and a second send of the Dropbox link didn’t work … not even a notice that you got them … and it’s not a Spam blocker to blame. Not at my end, anyway.

I’m sending a 3rd time.

I got acknowledgment of the e-mail this time. (I think I did last time, too, but couldn’t find it just now.)

We have notes from you on April 29, May 6, and today. Nothing before that. We have a query on a different issue from 2017, but nothing since then.

I’ll respond via the support system.


Edit: Response sent. Please let me know if you don’t receive it.

For those watching at home, the issue was that the style in question was being re-defined by the Styles pane – not the Section Layout – of the Compile Format.


Thanks, Katherine. I should have realized. (Duh.) I set out to never use styles in the Editor, and a couple instances slipped by me. Sorry to waste your time.

I wonder why we can’t get mail back and forth, though. I’ve asked about newsletters several times over the years and never received even ONE. I got your mail today and have gotten mail from you before … and I generally check my spam folder before clearing it out.

It’s hard to believe EVERY newsletter got lost by that route, unless you don’t send more than one a year.

It’s a very low volume newsletter, typically only for release announcements and such.

Glad to hear the issue is resolved.


I didn’t receive it. I’m receiving everything else, from spammers of all sorts … manually checking before I empty my spam folder (I use SpamSieve and Airmail 3) … but nothing from you on this.

I know why I wasn’t getting As-Is formatting, but I don’t know why I don’t get a response from you. I do get your automated responses saying “high traffic”, etc. … but nothing else.