assign key commands question & table moving and adding rows

I’m combining two questions, because yesterday when I wanted to ask the questions, a box came up not allowing me to ask the questions because I’d already started a thread (with another question). I’m not sure what to do if this happens again. any suggestions? It seems odd that you can’t ask more than one question.

  1. Assigning key commands. I’d like to not have to use the pull down menu for the commands to change case: text>convert>Upper, lower, title. Is there a way I can assign a key command?
  2. In tables. Sometimes I need to move a row either up or down in the list of rows, or I need to add a row between rows. I’m having trouble doing this. Am I pushing the limits here, or is there a way?


I already answered your first question yesterday:

As for (2), I’m afraid Scrivener has to rely on the not-very-good standard OS X text system implementation of tables in text. Moving rows around and inserting rows is always a bit of a tricky business. Try it out in TextEdit and see if you can do it okay there - if so, it’s a Scrivener bug, so let me know. If TextEdit has the same issues, then I’m afraid you are running into text system limitations…

All the best,

I’m sorry.

I tried it out in text edit. Doesn’t work. Tried it out in Word for Mac. No problem works very well. thanks kris.

Word is completely unrelated to TextEdit and Scrivener in that it uses Microsoft’s own text engine, which they have built from scratch. Bugs (or limited behaviour) that exist in both TextEdit and Scrivener are often difficult to fix because they exist beneath the surface layer of the provide Apple provided text engine.

I’m just letting you know where it works.