Attempting to bookmark a non-http url fails

In my project, I’d like to create a bookmark for a URL using the calibre;// protocol. However, when I do that, it shows up as a “show web page” button and nothing happens when I click it.

Is this the intended result? :frowning:

EDIT: I’m a bit dumb. I just realized double-clicking will open it. :flushed: In any case, perhaps there could be some further refinement of the lower pane – non-http urls will fail, so hiding the button for those to prevent this confusion.

Thanks for posting this! I didn’t know Calibre offered this functionality–I can definitely make use of it. :nerd_face:


Unfortunately, as of the latest Windows patch, it’s failing again. :frowning:

When I double-click, it opens an empty quick reference window. And ‘load web page’ still doesn’t work.

Hi @ownedbycats,

Thanks again for teaching me the calibre://view-book syntax. :heart_hands:

I’m on the latest version of Win Scriv 3.1.2 and can reproduce this bug.

Opening Calibre books in the viewer works beautifully for me using Add Link inside of documents.

But I am seeing the same result as you when I create the link via Add External Bookmark in the Inspector.


Never mind my earlier result–I got it to work!

Instead of double-clicking on the link, right-click & select Open in External Editor.


This will launch Calibre & the viewer & open the book at the specified location. :+1:


That works. Another workaround I found: I added the calibre:// link to the top of my ‘Scratchpad’ document, which is also bookmarked:

As for the Calibre urls: Rather than linking to just one book, I use the ‘search’ syntax to show a selection of relevant books. There’s a plugin called Job Spy which has a lot of functions, and one of them (called ‘Virtual Library Helper - Create Search Criteria’) is to take selected books and turn them into a search that looks like “id:5935 OR id:3045 OR id:5931” which then can be url-ified.

1 Like